Steam games crashing/freezing on start up

Most of my games are crashing on launch or freezing on start up.
I just re-installed manjaro.

Both steam-manjaro and steam-native are installed
I turned off/on vulkan shader ( Currently on) and am running proton 5.0 (changing to an older version didnt help) Forcing proton did not affect the issue.

I recall there being a silly little trick I had to do with a different launcher but I cant seem to find the post that fixed it.

Perhaps this? [Howto] Optimizing the performance of "Bard's Tale 4" on steam

There are some setups.

Thank you.
I tried that but still didn’t work, prepares to launch then just nothing, same as before :confused:

So we’re talking about non-native games? What about native games do tthey work properly?

Rimworld loads but doesn’t see subscribed mods, don’t starve runs, dungeons 3 freezes hard,
I had them all working on my last install, but I don’t remember what I did to do so, but it was the same issue then

What type of rig are you using? If you have hybrid graphics and don’t run steam on the dedicated gpu with prime-run it will cause games to run on the intergrated graphics and then usually crash.

If you use lutris to launch steam and hit the terminal icon it will show you all the logs while the game is loading and why it crashes

I don’t know how to force the Nvidia gxf card

Host: me Kernel: 5.6.15-1-MANJARO x86_64 bits: 64
Desktop: Xfce 4.14.2 Distro: Manjaro Linux
Type: Desktop Mobo: ASUSTeK model: TUF Z390-PRO GAMING v: Rev X.0x
serial: <superuser/root required> UEFI: American Megatrends v: 2804
date: 04/15/2020
Topology: 6-Core model: Intel Core i5-9600K bits: 64 type: MCP
L2 cache: 9216 KiB
Speed: 4499 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 4496 2: 4463
3: 4496 4: 4413 5: 4459 6: 4412
Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP104 [GeForce GTX 1070] driver: nouveau v: kernel
Display: x11 server: X.Org 1.20.8 driver: modesetting,nouveau
unloaded: intel resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz
3: 1920x1080~60Hz
OpenGL: renderer: NV134 v: 4.3 Mesa 20.1.7
Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.6.15-1-MANJARO
Device-1: Intel Ethernet I219-V driver: e1000e
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: d4:5d:64:54:02:57
Local Storage: total: 12.96 TiB used: 2.30 TiB (17.7%)
ID-1: /dev/sda vendor: Seagate model: ST4000VX000-1F4168 size: 3.64 TiB
ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB
ID-3: /dev/sdc vendor: Seagate model: ST4000DM000-1F2168 size: 3.64 TiB
ID-4: /dev/sdd vendor: Western Digital model: WD40EFRX-68WT0N0
size: 3.64 TiB
ID-5: /dev/sde vendor: Western Digital model: WD20EFRX-68EUZN0
size: 1.82 TiB
Hardware-1: Intel SATA Controller [RAID mode] driver: ahci
ID-1: / size: 211.13 GiB used: 28.64 GiB (13.6%) fs: ext4 dev: /dev/sdb2
ID-1: swap-1 type: partition size: 17.08 GiB used: 8.8 MiB (0.1%)
dev: /dev/sdb3
System Temperatures: cpu: 36.0 C mobo: N/A gpu: nouveau temp: 40 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 361
Processes: 249 Uptime: 1d 45m Memory: 15.49 GiB used: 3.80 GiB (24.5%)
Shell: Bash inxi: 3.1.05

It looks like you have nouveau drivers installed. Ideally you want the nvidia 450 hybrid drivers which you can install with manjaro settings manager. The easiest way to launch steam games is with lutris and you can set the launch options there with prime render off load and feral gamemode. If you are using steam then right click the game and select properties. Open "SET LAUNCH OPTIONS " and type “prime-run %command %” and then ok. This will force it to use the nvidia card

no it is

prime-run %command%

You have a space before last %

1 Like

Sorry my bad I was using my phone not the pc and didn’t notice I’d missed the space

@sawdoctor @omano
Thank you both for your help.

I tried prime-run %command% on 3 games (age of wonders: planetfall; which I was playing before the format; Path of Exile and Batman AA ) Same issue where it says its launching and then nothing.
I don’t know why it hates me.

You need to install the nvidia hybrid drivers to get nvidia prime to work. On your output it says nouveau drivers which are the open source drivers. If you are gaming you really need the nvidia drivers

thank you, I will start looking into getting that set

sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime

Warning: no matching device for config ‘video-hybrid-intel-nvidia-450xx-prime’ found!

Dependencies to install: video-modesetting
Installing dependency video-modesetting…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/video-modesetting/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Successfully installed dependency video-modesetting
Installing video-hybrid-intel-nvidia-450xx-prime…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-450xx-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
warning: nvidia-450xx-utils-450.66-1 is up to date – skipping
warning: nvidia-prime-1.0-4 is up to date – skipping
warning: lib32-nvidia-450xx-utils-450.66-1 is up to date – skipping
warning: linux414-nvidia-450xx-450.66-6 is up to date – skipping
warning: linux44-nvidia-450xx-450.66-5 is up to date – skipping
error: target not found: linux56-nvidia-450xx
Error: pacman failed!
Error: script failed!

First things first. You are using a Kernel which is not available since MONTHS if I recall correctly (EDIT: 5.6 is apprently EOL since at least July…), so make sure you have a LTS Kernel if you’re not following dev for the kernel (and remove them before they don’t exist anymore), and make sure the system is up to date, because it is obviously not.

Then once all this is sorted out, install the hybrid Nvidia drivers.

Im pretty noob, where would I find a tutorial on how to do this, like what commands to run?
The installer USB I used would have been about 3+ months old, so that makes sense, I just assumed it would update once I got it up and running. Would it be easier to just reformat again with the newest one?

No need for tutorial, Manjaro should have graphical interface for everything, I don’t use XFCE but on KDE in the start menu, there is System Settings, and from there you can install Kernels, Video drivers, and from Pamac you can update the system.

I guess your best bet would be to update the system, which would automatically replace your non existent kernel with a meta package called linux-lts or linux-latest, this package automatically put you on current kernels. After all is up to date reboot make sure everything works, then find the System Settings interface which I’m sure exists on XFCE too, and install the hybrid video drivers.

from terminal you could update system like this:
sudo pacman -Syyu

Awesome, I found it, thank you. Updating the kernel now then Ill see if I can get nvidia to play nice.

You updated the system first right?

Yes, I updated and restarted before i started this.