Static sound from PC using Wayland with KDE

Hello everyone, and thank you for your attention. I have a particular issue for which I haven’t been able to find any solution despite extensive research online (except for some partial shreds of information, but not sufficient to resolve the issue). Essentially, when I try to open a session with Wayland while using an application like Firefox and scrolling the screen (especially if the background is white), there is a faint but clearly perceptible noise, like static, coming from the PC. This noise stops as soon as I finish scrolling. However, with X11, there is no such problem.

Do you have any idea what this could be? I assume you’ll need more information, so please let me know what details I should provide, and I’ll do it all at once. Thank you very much for any help you can provide.

The only idea I have is that the gpu interfere with the audio chip through magnetic impulses. The AUDIO Chipset is not very good isolated, or just old garbage. You can mitigate that, but it will not go away, since it is hardware related. Also possible that HDDs can interfere like that, then you would here a constant static sound.

I would suggest using an additional USB audio device and disable the internal audio chip.

Why is it happening on Wayland and not Xorg? I don’t know, normally you should hear it everywhere, but it’s just louder on Wayland, so noticeable?

This is one of the clues that emerged during my online research, but aside from this, I haven’t been able to find much else to delve into and try to solve the problem, or to be certain that it is indeed this and not something else.

I would prefer not to.

In no way, with Xorg everything works perfectly, and there is not the slightest noise; it only happens with Wayland.

Thank you!

I’ll update you: I tried a Fedora 39 KDE Live ISO that defaults to Wayland, and the issue does not occur. At this point, it’s reasonable to assume that the causes lie within my Manjaro installation, the kernel, Nvidia proprietary drivers, some settings, or a combination of all these elements and maybe others. The challenge is that I don’t know how to test all these combinations blindly. I don’t have the time, and, in any case, I’d prefer to have at least a specific clue to follow rather than blindly attempting to resolve the issue.

I believe I’ve narrowed down the issue: I installed the ‘Cpupower-gui’ app, and if I select the ‘power’ power profile, the noise disappears, while with any other profile (especially ‘performance’), it’s present. I just can’t understand why the problem only occurs with Wayland and not with Xorg. Do you have any ideas on how to proceed to resolve this? Thanks.

No sorry. I would look for the UEFI Settings and see if something changes there.

The only difference I would see is that Wayland sucks more power when given to it, since it has direct access to the drivers, while Xorg is layered, means rendering happens on the server, not on the client, thus it is also delayed a bit, while Wayland has a client-side rendering, what means there is no server.

Hope you can follow my assumption and why it happens on Wayland. However, I don’t know how you could mitigate it. I still think that this also happens on Xorg, but not as disturbing. At the end it is a clear hardware issue, as you have proven with Cpupower-gui.

1 Like

Good suggestion, I’ll run some tests by adjusting the settings.

So, could it be a problem related to Nvidia proprietary drivers as well?

Even with the most aggressive power settings on Xorg, there’s absolutely no noise.

Thank you.

I think I’ve found the cause of the problem: disabling Intel SpeedStep in the BIOS makes the noise disappear. However, the issue is that, unavoidably, it also disables Turbo Boost, significantly impacting performance. In fact, the maximum frequency is practically halved. Any suggestions?

No, idea. I would say it is only CPU related.

That’s is not what I mean. There is a spectrum of frequencies that are imperceptible to the human ear. Just because you can’t perceive it doesn’t mean it doesn’t exist.

I’ll try to put it another way:

Xorg runs with a delay in user space, which makes it more leisurely and perhaps more consistent, but it also runs with a delay, not necessarily noticeable, but measurable.

Wayland, on the other hand, can react faster thanks to direct access and runs faster, but that doesn’t mean it draws more power. Because it does not run “smoothed” or delayed, and the CPU influences the audio chip through impulses, these interferences are perceptible to the human ear.

However, the hardware is here the problem and the software can only mitigate your problem.

:man_shrugging: I would suggest to stay on Xorg with your system, also because of nvidia.

Hardware !

Maybe recalculate the required power and the power provided by the power supply.

If the power is too close to the limit, the stability of the voltages can be poor. And that can then affect all sorts of components of the Motherboard (especially the sound) :footprints:

  • Disconnect and reconnect all power cables
1 Like

Make also totally sense. Didn’t thought about it.

Yes, I know that. But if the noise is not noticeable, it doesn’t bother me.

I think for now I’ll proceed this way; at least I’ve identified the issue, and perhaps this thread might be helpful to others as well.

It could be, however, the system is a bit particular, a sort of desktop/notebook hybrid, and the power supply is indeed external, like a notebook:

Anyway, I tried again with the Fedora 39 Live ISO (which defaults to Wayland and GNOME), and there is no noise even with SpeedStep active. So there must be a connection between my current software configuration and the noise. It just makes sense.

Fedora 39 uses kernel 6.6 ?

I had an intuition, but I’m not sure how well-founded it might be: disabling the SpeedStep technology in the BIOS also disables the CPU’s idle state (so I suppose the C states). Could it then be an interference generated by the Manjaro Kernel parameters, compared to Fedora’s, which might be more conservative? What do you think?

No, 6.5.9


I specified that I’m using the live ISO, so no kernel updates to version 6.6

Then use what works for you. :man_shrugging: Probably they have patch which is not upstream yet.

I don’t understand the point of this response. I simply clarified the reason why it seemed there was a contradiction with the Fedora Kernel version; there’s no need to be defensive.