[Stable Update] 2024-06-10 - Kernels, Systemd, NVIDIA, Mesa, Qt5

I would guess… yes: Manjaro Status

1 Like

No. I just pushed some new packages to all branches, so it will take awhile for all them to catch up. Red ≠ offline. :wink:


Indeed, there are issues with the website right now. I’m not sure what’s going on, but the team is aware.


We changed how Nvidia drivers use DRM by default. Hybrid systems however use simpledrm to display plymouth. Currently we revert changes made to the nvidia modules.

updated Nvidia drivers are now pushed to stable branch: [manjaro-packages] [BoxIt] Memo (x64)


13 posts were split to a new topic: No GRUB menu after failed update

Solved this issue by installing ly display manager ) also had issues ith anything like sdm, gdm…


Have you seen this?:

Known issues and solutions

No plasma interface with kernel 6.9 + Nvidia gpu + Wayland

If you encouter a black screen with no inteface after login in, it’s probably a problem with simpledrm loading.

To solve it add nvidia_drm.fbdev=1 to /etc/default/grub
in the line begining with GRUB_CMDLINE_LINUX=" .
Verify that you also have nvidia_drm.modeset=1 in the same line.
Then exec sudo update-grub

Also, verify that you have nvidia_drm in /etc/mkinitcpio.conf in the MODULES= or HOOKS= line.
Exemple :

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

If it was not present, then run sudo mkinitcpio -P after adding it.

I dont’t know if you’re on wayland. It maybe this (or something of this) works on X11 too.


I don’t think this update was a stable update. There should have been more testing before it was rolled out. Many Users then quickly become overwhelmed.


A quick and problem-free update. Thanks devs.

1 Like

Solved this issue by installing ly display manager

This along with plymouth.enable=0 disablehooks=plymouth is the best I’ve seen.

The only problem is that ly has no virtual keyboard.


systemd-analyze                                                                             ✔ 
Startup finished in 7.857s (firmware) + 1.503s (loader) + 2.292s (kernel) + 3.321s (userspace) = 14.974s 
graphical.target reached after 3.321s in userspace
1 Like

Not sure what was updated in the latest that just came last night (11 hours ago), but I still need fbdev and modeset = 0 in grub or I just get a blinking cursor (hybrid laptop)

khelpcenter orphan?

Nothing depends on it except for kde-system-meta (just a meta package), so it’s up to you if you want it or not. If so, mark it as explicitly installed:

sudo pacman -D --asexplicit khelpcenter
1 Like

Since Linux kernel 6.7 is at the end of life, will there be a newer kernel being released with RT (real-time) for us music producers?

ok, thanks
well. it was made explicitly installed by me before the update, but when it became orphan, if I try to remove with octopi it want to remove three or four more packets (xapian-core, kdoctools and others that now I don’t remember)
so I removed with pacman -R
kde-system-meta is not installed here

Sooo, 6.7 was a kernel release for music producers?

If not and you want newer you can get 6.9 from your systray,

for sure, there will be newer rt-kernel. nothing to hesitate, use your kernel it’s eol but it’s not dead.


That’s unfortunate. The latest stable update (2024-06-10) finally made KWin Wayland usable on my setup. Since the revert (550.90.07-2 → 550.90.07-3), my Kwin Wayland setup is broken again. With broken I mean: I can log in and I see a mouse cursor, an app (evolution) autostarts successfully but is scaled like 300% and that’s it. No menu, no wallpaper, no keybinding, I can’t click anything.

For the time being I just switch back again to Kwin X11.

My setup: Kernel 6.6 LTS + AMD Ryzen + Nvidia GTX 1060

  Host: yeee Kernel: 6.6.32-1-MANJARO arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro Linux
  Info: 6-core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP cache: L2: 3 MiB
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 550.90.07
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: nvidia gpu: nvidia resolution: 2560x1440~60Hz
  API: EGL v: 1.5 drivers: kms_swrast,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
    renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2
  API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib

But besides: I appreciate all your hard work. Been using Manjaro for years on the same system successfully. With the help of these nice curated stable update posts, updating is smooth with Manjaro. Thanks guys!

Well, then what you need to do to fix it is add the parameters which were present with 550.90.07-2:

set the modeset=1 kernel module parameter for the nvidia_drm module.

Additionally, with the driver version 545 and above, you can also set the experimental nvidia_drm.fbdev=1 parameter, which is required to tell the NVIDIA driver to provide its own framebuffer device instead of relying on efifb or vesafb , which do not work under simpledrm .

NVIDIA - ArchWiki

One can also create a custom config file; i.e., /etc/modprobe.d/nvidia.conf containing:

options nvidia-drm modeset=1 fbdev=1