[Stable Update] 2024-05-18 - Linux-Firmware, PHP, Gitlab, Qt6

I followed the instructions in the wiki post

Can you please post the link to the wiki you are mentioning there?

He means the second post in this and the topic from 13.5. (Known Issues) i guess

Kjots lost all my notes, I suspect a problem with akonadi similar to last time:

org.kde.pim.akonadicore: "QLocalSocket: Remote closed" "/run/user/1000/akonadi/akonadiserver-cmd.socket"
org.kde.pim.akonadicore: Socket error occurred: "QLocalSocket: Remote closed"
org.kde.pim.akonadicore: Job error:  "Cannot connect to the Akonadi service." for collection: QVector()

Any suggestions?

Anyone know how to fix a dolphin crash, when i drag a file about the window path area?

Exactly where i normally would see additional folder pathings, when i stop with my mouse over the path from a filedrop, the dolphin is crashing instead showing subfolders.

Edit: It looks that this bug is already confirmed and solved with KDE Frameworks 6.2.0

Please create your own Support thread.

1 Like

3 posts were split to a new topic: Is there a way to switch off kernel 6.9.0?

libva-vdpau-driver-wayland 0.7.4-1 is from AUR so no way the update installed it.

@ Manjaro Team

And this update did not help or fix this issue:

Yes I installed Telegram from the official repository and deleted the settings. But the mouse focus problem persists in Plasma 6 X11 and crashes in KDE Wayland. In the Awesome interface, which I also have installed, Telegram has no problems. It works correctly!
Maybe an Nvidia 550.78 graphics drivers issue? I see this error in dmesg command:

[drm:drm_new_set_master] ERROR [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership

And this one in the Telegram LOG:

RPC Error: request 31 got fail with code 400, error WEBFILE_NOT_AVAILABLE

file a bug with Telegram: I’m still on X.org

1 Like

Logs or it didn’t happen. :stuck_out_tongue_closed_eyes:

Sorry, can’t reproduce.

Maybe mention it again in the next stable update and see if that fixes it.

Kidding aside, please create your own Support topic for troubleshooting.

“If something can go wrong, it will.” :woozy_face:

3 posts were merged into an existing topic: Update requests for packages imported from Arch Linux

sorry, I meant to say “community post”, which is the second after the stable update announcement… it’s editable by the commuity thats why I called it a “wiki post”

1 Like

I just now realized we can add stuff to this post, thank you


Something in this release seems to have broken pamac-manager.
Whenever I do anything that would need authentication (such as installing/removing software or opening the preferences dialogue) it immediately pops up “Error Authentication failed”, but doesn’t prompt for the password.

Running from the command line, there are no error messages.

It’s evidently not pamac-manager itself at fault, as I’ve tried downgrading pamac-gtk with no results. The only way at present I can do anything with it is to run it using sudo, which probably isn’t a good idea.

This is a KDE Plasma system, now running Plasma 6.


Fixed In next 6.0.5
bugs.kde - polkit-kde-agent crashes with nullptr

ps: for me, in stable, no bug found with polkit since plasma6

EDIT : 6.0.5 is in testing


My experience so far with update 2024-05-13 + 2024-05-18 (KDE + nvidia + x11):
Over all updating went without any major complication.

My findings:

  • the animation for maximizing and stick to edges of windows seemed kinda laggy → disabling floating panel resolved it for me.
  • I forgot to remove kde5 widgets (e.g. modern clock) → at first not really a problem; I just removed the broken ones in edit mode. But after a few days I wanted to add some of them again via the download wizard. Which resulted in a bugged download GUI (Install-button did not work) → to get it working again I moved/removed the corresponding widgets folders from ~/.local/share/plasma/plasmoids
    (Edit: removing the widget via GUI also did not work.)

The external monitor connection options now no longer woks. My current external monitor connection type (during the update) was “extend to right”. After update, changing it to any other types, for example to “switch to laptop screen” if I want to disconnect my second monitor, does not change anything. This morning, I just unplugged my second monitor, is that safe?

UPDATE: The unresponsive display configuration change only affects the keyboard shortcut for changing display configuration. Changing the configuration from the icons at the panel bar works, but much less inconvenient than being able to access it just by pressing a button.

After the 5/13 update, logging into the Plasma Wayland session produces a black screen with no visible shell. Most keystrokes (e.g., Ctrl+Alt+T to open Konsole) still work but I cannot access programs or menus. Programs on autostart appear. The X11 session works fine.

I’ve tried clearing my ~/.cache to no avail.

Still trying to diagnose why.

1 Like

If nvidia … see the nvidia notes :point_up:

1 Like