[Stable Update] 2024-05-13 - Kernels, Plasma 6, Gnome 46, LxQT 2.0, Nvidia, Pacman

After another KDE update:
Most programs open delayed, e.g.
Chromium, Thunderbird…
There is a noticeable delay, especially when opening several konsole windows, also copy & paste actions in kate or kwrite are delayed

The system has been cleaned up after the upgrade, I can’t see any conflicts yet …

1 Like

Could something be using a lot of CPU? That would cause those symptoms. Have a look using htop.

CPU load is fine … mostly 0.2 - 0.5% us

%CPU(s):  0,5 us,  1,3 sy,  0,0 ni, 97,4 id,  0,3 wa,  0,3 hi,  0,2 si,  0,0 st

looks like a kwin or kde issue …
also this inxi output comes delayed:

$ inxi -Fxxxz
System:
  Kernel: 6.9.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A wm: kwin_x11 with: cairo-dock
    vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
Machine:
  Type: Desktop System: Dell product: OptiPlex 7040 v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Dell model: 0HD5W2 v: A00 serial: <superuser required> part-nu: 06B9
    uuid: <superuser required> UEFI-[Legacy]: Dell v: 1.11.1 date: 10/10/2018
CPU:
  Info: quad core model: Intel Core i7-6700 bits: 64 type: MT MCP smt: enabled
    arch: Skylake-S rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 1450 high: 3400 min/max: 800/3400 cores: 1: 3400 2: 800
    3: 800 4: 800 5: 800 6: 800 7: 800 8: 3400 bogomips: 54417
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel
    arch: Gen-9 ports: active: DP-2,HDMI-A-1,HDMI-A-2 empty: DP-1,DP-3,HDMI-A-3
    bus-ID: 00:02.0 chip-ID: 8086:1912 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: intel dri: i965 gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1848 s-dpi: 96 s-size: 1016x488mm (40.00x19.21")
    s-diag: 1127mm (44.37")
  Monitor-1: DP-2 mapped: DP2 pos: top-center model: Samsung SyncMaster
    serial: <filter> res: 1360x768 hz: 60 dpi: 84 size: 410x230mm (16.14x9.06")
    diag: 470mm (18.5") modes: max: 1360x768 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI1 pos: bottom-r model: Acer K242HL
    serial: <filter> res: 1920x1080 hz: 60 dpi: 92
    size: 530x300mm (20.87x11.81") diag: 609mm (24") modes: max: 1920x1080
    min: 720x400
  Monitor-3: HDMI-A-2 mapped: HDMI2 pos: primary,bottom-l model: Acer K242HL
    serial: <filter> res: 1920x1080 hz: 60 dpi: 92
    size: 530x300mm (20.87x11.81") diag: 609mm (24") modes: max: 1920x1080
    min: 720x400
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.6-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 530 (SKL GT2)
    device-ID: 8086:1912
  API: Vulkan v: 1.3.279 layers: N/A surfaces: xcb,xlib device: 0
    type: integrated-gpu driver: mesa intel device-ID: 8086:1912
Audio:
  Device-1: Focusrite-Novation Focusrite Scarlett 2i2 driver: snd-usb-audio
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-4:3 chip-ID: 1235:8016
    class-ID: fe01
  Device-2: USB MIDI Interface driver: snd-usb-audio type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 bus-ID: 1-7:5 chip-ID: fc02:0101 class-ID: 0103
  API: ALSA v: k6.9.0-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator
  Server-1: sndiod v: N/A status: off
  Server-2: JACK v: 1.9.22 status: active with: 1: a2jmidid status: active
    2: nsmd status: off
  Server-3: PipeWire v: 1.0.5 status: off with: wireplumber status: off
  Server-4: PulseAudio v: 17.0 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module
Network:
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b7 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: wireguard1 state: unknown speed: N/A duplex: N/A mac: N/A
Drives:
  Local Storage: total: 1.39 TiB used: 253.67 GiB (17.9%)
  ID-1: /dev/sda vendor: SanDisk model: SDSSDH3 500G size: 465.76 GiB
    speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 20RL scheme: GPT
  ID-2: /dev/sdb vendor: Silicon Power model: SPCC Solid State Disk
    size: 953.87 GiB speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 916a
    scheme: GPT
Partition:
  ID-1: / size: 57.37 GiB used: 26.8 GiB (46.7%) fs: ext4 dev: /dev/sda2
  ID-2: /boot size: 511 MiB used: 171.3 MiB (33.5%) fs: vfat dev: /dev/sda1
  ID-3: /home size: 152.74 GiB used: 62.32 GiB (40.8%) fs: ext4
    dev: /dev/sda3
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 36.0 C pch: 50.5 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 32 GiB available: 31.11 GiB used: 2.92 GiB (9.4%)
  Processes: 267 Power: uptime: 17m states: freeze,mem,disk suspend: deep
    wakeups: 0 hibernate: platform Init: systemd v: 255 default: graphical
  Packages: pm: pacman pkgs: 1604 Compilers: clang: 17.0.6 gcc: 13.2.1
    Shell: Bash v: 5.2.26 running-in: konsole inxi: 3.3.34

Okay, a few days later I’ve noticed one issue with bluetooth. Before the update, my bluetooth headsets paired and stayed connected without issue. Now they connect, and they seem to stay connected, but every few seconds I get an intermittent notification saying “Connected.”

If I’m watching a youtube video, the audio sounds great and never seems to stutter. While watching, I opened the bluetooth-monitor GUI and though the audio seems to stay connected, the GUI clearly shows the device disconnecting and reconnecting. I’m glad that it seems to work, but I confess the repeated notification is a distraction.

Anyone else see this behavior? I’m using XFCE.

Does anyone know how these errors can be eliminated?

Using GtkSettings:gtk-application-prefer-dark-theme with libadwaita is unsupported. Please use AdwStyleManager:color-scheme instead.

plasma-polkit-agent.service: Main process exited, code=killed, status=11/SEGV

Theme parsing error: <data>:2:27: The style property GtkButton:default-border is deprecated and shouldn't be used anymore. It will be removed in a future version

Theme parsing error: <data>:1:42: '-gtk-cursor-aspect-ratio' is not a valid property name

gtk_accessible_text_get_contents: assertion 'end >= start' failed

Are they causing you problems? If not, I expect they can be ignored.

:man_shrugging:

Yes, opening windows, copy & paste action … are delayed

Try a new profile first.

If that works, try a different theme.

Downgrading to kernel 6.6 seems to have fixed the nvidia issues. If I get a crash again, I’ll post there in the other link (see msgs above). For now, thanks for the help.

Hi all,
a few days after the latest major update pamac now shows error messages:

pamac update --no-aur
Vorbereitung...
Synchronisiere Paketdatenbanken...
cp: die Zeiten für '/var/tmp/pamac/dbs/sync' werden beibehalten: Die Operation ist nicht erlaubt                                    
chmod: Beim Setzen der Zugriffsrechte für '/var/tmp/pamac/dbs/sync': Die Operation ist nicht erlaubt
Warnung: task: Ignoriere Paket-Aktualisierung (2.6.2-2 => 3.0.2-1)
Es gibt nichts zu tun.
Vorgang erfolgreich abgeschlossen.

I did not change something manually, and prior to the latest update of libpamac, libpamac-flatpak-plugin and libpamac-snap-plugin I didn’t see these error messages.
Any ideas?

Access rights for the directories mentioned are:

drwxr-xr-x 18 root root 4096 13. Mai 13:02 /
drwxr-xr-x 12 root root 4096 17. Mai 12:17 /var
drwxrwxrwt 11 root root 4096 17. Mai 17:45 /var/tmp
drwxrwxrwx 4 admin admin 4096 13. Mai 13:08 /var/tmp/pamac
drwxrwxrwx 3 admin admin 4096 17. Mai 17:45 /var/tmp/pamac/dbs

Files in /var/tmp/pamac/dbs are (user “joerg” is myself, of course…):

-rw-rw-rw- 1 joerg joerg       29 10. Jul 2023  community.db
-rw-rw-rw- 1 joerg joerg 35524392  8. Jul 2023  community.files
-rw-rw-rw- 1 joerg joerg   142284 14. Mai 03:02 core.db
-rw-rw-rw- 1 joerg joerg  2344710 14. Mai 03:02 core.files
-rw-rw-rw- 1 joerg joerg  8740625 16. Mai 22:24 extra.db
-rw-rw-rw- 1 joerg joerg 43482418 16. Mai 22:24 extra.files
-rw-rw-rw- 1 joerg joerg    18086 24. Dez 2022  mhwd.db
-rw-rw-rw- 1 joerg joerg   149770 13. Mai 10:59 multilib.db
-rw-rw-rw- 1 joerg joerg   224050 13. Mai 10:59 multilib.files
-rw-rw-rw- 1 joerg joerg 10668731 17. Mai 15:24 packages-meta-ext-v1.json.gz
-rw-rw-rw- 1 joerg joerg        0 17. Mai 15:33 refresh_timestamp

Thx for any comment or suggestion.

Not sure about your problem, but on the first glance, that should be in /var/tmp/pamac/dbs/sync

Anyone know what could be causing this?
Happened after the update.

NOTE. If you are going to answer my question, please read my “About me” first.



Ups, thx for your hint - that was my fault when copying the text from xterm to the forum board:
the mentioned files are actually already in …/dbs/sync/ (not …/dbs/
and permissions for /var/tmp/pamac/dbs/sync/ are:

drwxrwxrwx 2 admin admin 4096 17. Mai 18:44 /var/tmp/pamac/dbs/sync/

Sorry - but the described problem still persists…

Do you have a separate user named admin? On my system, those 3 directories are owned by my one (and only) user. I always wondered what would happen if multiple users ran pamac.

Indeed, in my case they are also owned by my only user and not by root.
If they are owned by “admin”, that can explain why the user “joerg” receives an error about permissions. That will of course mean that pamac is concepted as a single user thing which is kind of stupid on linux. In that case you will have to update from “admin”, or root, or just use pacman -Syu.
Not sure if sudo pamac is a good idea as alternative, the experienced users warn against it.

Good point, that is helpful!
In deed, I have multiple users on my system: “admin” is the first “user account” (id 1000), then “joerg” (= myself, ID 1001), and some others, too.
I usually log in to the system using the “admin” account (which has permission to use sudo) for system maintenance or config changes.
For normal “day2day” work I usually use the “joerg” account (which can use pacman via sudoers, and is limited to some other programs otherwise).
I can not remember exactly, but rumor has it that I ran pamac update as user “admin” the last time before the latest big update.
And now I’m trying to run pamac as user “joerg” - which might explain the error messages now.
But: I’m sure that in the past I ran pamac with both accounts successfully (i.e. without error messages), and now I have them…
That makes me wonder what the concept of using pamac might look like: use it with a single user ID only, and never run it with another?
(and of course, I now that running pamac as root is a bad idea - I never did!)
To make a long story short: I changed the owner+group of directory /var/tmp/pamac/dbs/sync/ to be “joerg” insted of “admin”, and the error messages are gone!
Thank your for your help - what remains is open questions in my mind regarding the use cases for pamac (and why its behaviour was changed with the lastest update)?

I am glad we found it. It seems like some bug anyway, because in theory with those permissions it should not matter if you are the owner of the folders or not…but it seems in practice it does.

Because for this big update you need to update it on a special way, don’t use pamac GUI, i hope you have a timeshift snapshot before you updated to rollback your system and follow this steps:

1.Fresh start
2.Log out
3.crtl+alt+f3 to open TTY
4.sudo pacman-mirrors --fasttrack
5.sudo systemctl stop sddm
6.sudo pacman -Syu
and spammed Y to replace everything
7.reboot

2 Likes

Updated today - no problem, everything is fine, but there is one problem. All audio devices are working correctly, but are not displayed in the volume control widget. Does anyone know how to fix this?

meme1

10 Likes