[Stable Update] 2024-05-13 - Kernels, Plasma 6, Gnome 46, LxQT 2.0, Nvidia, Pacman

EDIT: In my case the problem was casued by an outdated config for wireplumber in my ~/.config/wireplumber directory

1 Like

The update broke the game Squad on Steam for me. Launching the game fails with a “failed to load the anti-cheat module” message.

Other Steam games not dependent on Easy Anti-Cheat work fine. If I Timeshift back to before the update Squad works again.

Just thought that I would post that I am still running kernel 5.15 and upgrade seems to have gone OK. linux-firmware is 20240409.1addd7dc-1.1 (not -1.2). Running XFCE.


For those who updated plasma and didn’t read the post, the solution that worked for me was to restore the theming as said, and remove al orphan packages, there was a lot of qt5 and others related to plasma 5, reboot and the icons and menu were back.

1 Like

The XFCE upgrade worked well, but I can’t upgrade my KDE systems …it makes them unusable.

3 posts were split to a new topic: Whenever I log in to session I see this weird graphical glitch

XFCE updated fine, followed upgrade to Python 3.12, which is good since I messed up the proper maintenance of python packages for 3.8, 3.9, 3.10 and now have those directories with packages that I don’t know how to deal with.
So far no issues, and Linux 6.9 seems to be stable and isn’t causing the high CPU temps like in 6.7

I confirm that plasma-firewall thinks ufw is disabled although I verified it is enabled using systemctl status ufw.

When I try to “enable” the firewall using plasma-firewall in the System Settings GUI I get an error:

Error enabling firewall: An error occurred in command 'setStatus':

How to fix `plasma-firewall` error in System Settings GUI when running `ufw`

Open /usr/lib/kde_ufw_plugin_helper.py and change the first line from #!/usr/bin/python3.11 to #!/usr/bin/python3.12. This fixed the issue for me immediately and makes sense since Manjaro is currently on Python 3.12.


This fixed the issue for me, too.

1 Like

May I ask what is a total noob question? I’m use BTRFS and a snapshot is automatically taken prior to any update/upgrade. If I perform this latest system update and things go completely south, is it really as easy to recover as I think?

  1. Reboot computer
  2. At Grub menu, reboot from a snapshot
  3. Once the snapshot boots, run Timeshift and restore the same snapshot.
  4. Reboot
  5. From Grub menu, select the normal Manjaro boot option.
  6. Computer boots successfully in pre-update state and I give a sigh of relief.

I’ve done some searching on this and have not found a ton of clarity on restoring from a BTRFS snapshot, and I just want to be prepared. I acknowledge that I should probably know this already as I deliberately chose BTRFS for its recovery capabilities.

Thank you, and happy updating.

Ah, great! There already was an update to libplasma, looks like it fixed the problem.

195 posts were split to a new topic: Sublime text does not detect the dark theme on GNOME

7 posts were split to a new topic: Multiple issues with stable update

I’m getting this error, too. I try installing the 6.6 or 6.8 kernel as suggested and I keep getting this error message so the whole process stops. Do I need to uninstall the nvidia driver first?

hi! I have the same problem. did you manage to solve it?

1 Like

Im on Manjaro KDE and I can’t even load the tty in the first place. I press control,alt,F3 or any other function Key and all I get is a black background. This is the first time this happens and I don’t even know where to begin.

This is before updating anything. I want to go into the tty to do the update as is recommended for this update.

1 Like

No issues at all from a month old install of Gnome. thanks for all the work over the years. I really appreciate it!


Hello everyone,

I would like to express my gratitude. Before the update, I tried everything to achieve the same sound quality I had on Windows with my Astro A40. After the update, the quality improved significantly. Thank you very much!


All pretty smooth on my KDE Plasma system. Although I had a number of now unsupported Plasma widgets, they didn’t actually cause problems.

Just a pity I now need to roll my own replacement for the extremely useful popup launcher, which I have half a dozen instances of.

1 Like

No big issues so far on my installation. I went down the risky route of not resetting Plasma settings, just logged out, logged in through a tty, created a snapshot, removed some eventually-problematic AUR packages like linux-firmware-git, ran pacman -Syu and rebooted. (Also updated the kernel to 6.9.0-1 later on)

Things that I encountered:

  • Window Title Widget didn’t work anymore. Replaced it with a Plasma 6 port.
  • Font in Konsole got reset to a non-nerd-font (already mentioned here in the thread). Needed to re-set fixed-width-font in System Settings to what I had before (Hack Nerd Font).
  • Some python venv of mine wasn’t able to find packages anymore (somebody posted a similar error here in the thread) Not sure how python updates are usually handled but I would expect pip-packages to be re-installed or if possible - copied over from the previous version.
  • Found quite some orphaned packages and selectively removed all connected to kde/plasma

Overall, based on what I read here I was already nervous but seems like I got lucky today :smiley:

Update: Had to remove all links since it’s my first post but it should still be easy to find out what I’m referring to