[Stable Update] 2023-11-13 - Kernels, KDE Gear, LibreOffice, LXQt, Pipewire, Phosh, Firefox, Thunderbird

See FS#80156 - [cuda] 12.3.0 compilation errors

Which version of Wine? On EndeavourOS it was 8.18 while this problem started cropping on on Manjaro for 8.18 as well, both using Staging.

There is a blog post about a kernel update breaking a tablet pen. Maybe not related, but there is the post and an update at the bottom that may be of interest to you.

There is more discussion on Lemmy in the Linux channel.

I have an ASUS ZenBook UX363, with Manjaro GNOME and everything was fine until (the previous 2023-11-6 and also) this update (sudo pacman -Syu).

I’ve tried numerous times, ditched all extensions before the upgrade, just to be sure, but after this update the system becomes sluggish. Videos I played before, I can not play after. The sound is playing, but the video window does not show (and when showed after a long while, it is dropping nearly all frames). Even just opening terminal window animation is not fluent (was before) and takes a significant more time. It seems, that all HW video acceleration is not working.

I’m using 6.1 kernel, and tried the 6.6, but it didn’t help. Gladly I’m using btrfs+timeshift, so (as after the 2023-11-6 update) I’m back to the last update with GNOME44, on which everything is smooth & fast.

Does anybody has the same experience with graphics speed after upgrade? Any ideas what should I check, poke and fix to be fast after upgrade, as before?

Thanks.

Here I will try to answer my own question:
The command “pacman -R -dd” in Arch Linux is used to remove a package from the system with increased verbosity and debugging information enabled.
–dd`: This option enables debug mode and increases the verbosity level of pacman. Debug mode provides additional information about the removal process, helping to diagnose any issues encountered during package removal.
By executing this command, you would trigger the removal of a package from your Arch Linux system while getting detailed debugging information about the process.

1 Like
pacman -h -R
Verwendung:  pacman {-R --remove} [Optionen] <Paket(e)>
Optionen:
 ...
  -d, --nodeps         Überspringt die Versionsüberprüfungen für Abhängigkeiten
                         (-dd überspringt alle Überprüfungen)
  ...

Thanks for the pointer! Tried to see if it could solve my problem, but I couldn’t see that they were connected (maybe they are, but the symptoms were very different).

I ran into the same problem. Thanks, the solution you provided worked for me.

After installing, all my automatically opening windows open on my most left monitor and all my windows don’t have the kde top bar anymore, which makes it impossible to use. I was only able to get my pc back up and running in a usable state by restoring one of my backups

After resolving the openjdk issue, I get this error:

looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing kpeople5 (5.111.0-1) breaks dependency ‘kpeople’ required by kpeoplevcard
:: installing kcontacts5 (5.111.0-1) breaks dependency ‘kcontacts’ required by kpeoplevcard

Any tips?

EDIT: Solved with pacman -Syuu as noted in Unable to upgrade using pacman -Syyu (kpeoplevcard) - #2 by Teo

It is not in aur yet. this commit in gnome-shell-extensions -W2kYermok06MN4 has the fix. Errors are still logged but there is no crash.

TexStudio still not working. Same problem than signaled here

What is the reason to keep DDCutil 1.4.1?

sysctl is missing something? why is it trying to enable unprivileged users??

( 3/26) Applying kernel sysctl settings...
Couldn't write '1' to 'kernel/unprivileged_userns_clone', ignoring: No such file or directory

whats is this thing now? ( i mean the new excessive warning text I see first time ever)

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

For security reasons, the password you type will not be visible.

[sudo] password for deemon:

4 posts were split to a new topic: Dependency hell with various java programs

Ran out of Disk space on the root partition… pacman cache took up over 50% of partition.

Cleared that.

sudo pacman -Scc

JRE JDK conflicts, set the JDK JRE updates to ignore, after the update I removed tham, system complained 1 or other JDk JRE was Optionally required by LibreOffice… ignored that

CUDA threw a corrupted file error, so I set CUDA to ignore, adn finally completed the upgrade. Removed CUDA, as I don’t have any nVidia cards, I’m not even sure why it was installed in the first place.

Other than the above the upgrade went just fine.

I just updated another computer of mine this evening and the I guess another update was pushed since this morning because the conflicting issues of jdk-openjdk and jre-openjdk have already been resolved. I simply did a pamac update, and everything got updated without any issues! Kudos to outstanding job at Manjaro team! :clap:

I’m stuck with this:

# pacman -Syuu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace kdsoap with extra/kdsoap-qt5? [Y/n] 
:: Replace kirigami-addons with extra/kirigami-addons5? [Y/n] 
warning: kpeoplevcard: downgrading from version 0.1+r38.32d50a9-1 to version 0.1-2
:: Replace kuserfeedback with extra/kuserfeedback5? [Y/n] 
:: Replace libqaccessibilityclient with extra/libqaccessibilityclient-qt5? [Y/n] 
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing kholidays5 (1:5.111.0-1) breaks dependency 'kholidays' required by kalarmcal
:: installing kparts5 (5.111.0-1) breaks dependency 'kparts' required by kmediaplayer
:: installing kwidgetsaddons5 (5.111.0-1) breaks dependency 'kwidgetsaddons' required by kpmcore3
:: installing kcoreaddons5 (5.111.0-1) breaks dependency 'kcoreaddons' required by kpmcore3
:: installing ki18n5 (5.111.0-1) breaks dependency 'ki18n' required by kpmcore3

What am I missing?

Update: Tested Wine 8.20 on that same EndeavourOS laptop and didn’t have these issues on there either. It’s looking like it’s a Manjaro issue specifically.

2 posts were split to a new topic: My octopi is broken