[Stable Update] 2023-11-13 - Kernels, KDE Gear, LibreOffice, LXQt, Pipewire, Phosh, Firefox, Thunderbird

It’s worth routinely tidying the pacman cache.
I have a wrapper script for my system upgrades, and when it’s finished it does:

echo clear old cache packages...
sudo paccache -v -r
echo clear uninstalled cache packages...
sudo paccache -ruk0

I have it configured to keep 3 versions of each package (so I can downgrade if I need to, YMMV).

1 Like

This also happened to me.

1 Like

Yeah the overly large cache was on me.

On the other hand I did think I had it sorted, by setting pamac to keep only 1 old package. Seems I was wrong.

I’ll pinch your script, if you don’t mind.

I also had jre-openjdk and jre-openjdk-headless installed.

I had to do what you did, but with the pacman -d option (some things depended on it) to remove it and then reinstall jre-openjdk as you did.

5 posts were split to a new topic: I still have the jre conflict and cannot update

The same problem - all windows (I use Plasma) lost header line, I cannot manage to minimize the window - only to close - and even Alt-Tab is not working. Thanx god I’ve regular timeshift backups confiured and i could retrn to 9th of november.

Did it twice with th same result :frowning:

Could you manage to resolve it?

Maybe stupid question, but after this update first time ever I saw in htop (which was not updated since 2023 feb.) new line
zrm[ 0K(0K)/0K]
A bit investigation and it’s something called zram. Never used it before to my knowledge.
However updated in this update was util-linux, which for example contains /usr/bin/zramctl.
So what changed now? suddenly I have zram activated(?) which I never had before? Why now? Why 0K? Used by what and whatfor?

Also another thing I noticed that started recently (if not this update, but max only a few before) is that my network nfs mounts in fstab do not automount anymore upon login. Had to add to fstab options after the nfs mounts _netdev and now they do mount once again. Previously I assume type nfs implicated that it’s “network device” … apparently not anymore?

The Power Management bug affects afaik, all KDE desktop users. And there’s seems only one combination of Powerdevil/DDcutil versions that keeps the users’ power management alive. In the KDE bug thread, the solution seems not in sight yet. Downgrading must be manually done by all those.
But maybe there are more users on laptops who are not affected so they wanna keep on the latest version on the other hand. Or on Gnome, Xfce too. I of course didn’t think of those.

I had a similar problem, had to ignore widgetaddons5, kcoreaddons5 and ki18n5 in the end.

1 Like

Hello guys,
I think I did a mistake.
I saw in this update that the /etc/sudoers file was updated by a pacnew file.
I did the next command after diff the two files :

sudo mv /etc/sudoers.pacnew /etc/sudoers

Now I have the next problem :

user is not in the sudoers file

If I check my groups, I saw that I’m in the “wheel” one.
What is the problem ?
How can I solve this…

What’s the point of diff tool if you just use mv in the end?

“wheel” group needs to be set, ie. uncommented, in the sudoers file to have any effect, otherwise it’s just some useless group you’re in.
I strongly suggest you use /etc/sudoers.d/ directory and put any modifications there though. (I thought manjaro puts the wheel line there anyway… :man_shrugging:)

I corrected the problem by booting with a root shell.
I did the diff without my eyes open. I didn’t see that the line was commented…
Sorry for the inconvenience, I will check the sudoers.d, thank you for the advice.

1 Like

One of rare things (sudo, pam, shadow,…) you need to have your eyes wide open at. :stuck_out_tongue:

You caused one only to yourself. :stuck_out_tongue:

1 Like

I thought manjaro puts the wheel line there anyway

Manjaro uses /etc/sudoers.d/10-installer file for the wheel group

# cat /etc/sudoers.d/10-installer
%wheel ALL=(ALL) ALL
1 Like

Could you please tell me how? Thanks a lot

The problem is that kalarmcal, kmediaplayer, and kpmcore3 are not in the Manjaro repository. Furthermore, kalarmcal and kpmcore3 are not even in the AUR.

You should remove all 3, and then perform the update. You can then rebuild kmediaplayer. If you do not have kpmcore (without the “3”), you may need to install it if you also use KDE partitionmanager.

1 Like

Anyone else getting any erros with VirtualBox after this upgrade? I’m getting “Could not load the Host USB Proxy service: VERR_NOT_FOUND.” and there is no /proc/bus/usb. My VM still opens properly; however, I still get that error every time I open VirtualBox and never got it before.

Thanks, this solved my problem.

Straight after this stable update, my Veracrypt shows error messages when i mount a drive,
Not Enough Data and Broken Pipe.

I restarted Veracrypt and lucky its working for now… but there is something wrong with Veracrypt in the official repos!

systemd-coredump[17265]: [🡕] Process 17230 (veracrypt) of user 1000 dumped core.
                                                      Stack trace of thread 17230:
                                                      #0  0x00007f6ede4ac83c n/a (libc.so.6 + 0x8e83c)
                                                      #1  0x00007f6ede45c668 raise (libc.so.6 + 0x3e668)
                                                      #2  0x00007f6ede4444b8 abort (libc.so.6 + 0x264b8)
                                                      #3  0x00007f6ede6dd3b2 _ZSt21__glibcxx_assert_failPKciS0_S0_ (libstdc++.so.6 + 0xdd3b2)
                                                      #4  0x00005609b2c64762 n/a (veracrypt + 0x1c7762)
                                                      #5  0x00005609b2b85a94 n/a (veracrypt + 0xe8a94)
                                                      #6  0x00007f6ede445cd0 n/a (libc.so.6 + 0x27cd0)
                                                      #7  0x00007f6ede445d8a __libc_start_main (libc.so.6 + 0x27d8a)
                                                      #8  0x00005609b2b8c775 n/a (veracrypt + 0xef775)
                                                      ELF object binary architecture: AMD x86-64
░░ Subject: Process 17230 (veracrypt) dumped core
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ Documentation: man:core(5)
░░ Process 17230 (veracrypt) crashed and dumped core.
░░ This usually indicates a programming error in the crashing program and
░░ should be reported to its vendor as a bug.

It looks like the error is gone, maybe a bug in a config file that only occurred a singletime after this update and is vanished after a simple application restart.

After this update, ctrl + Q keyboard for quit no longer works for libreoffice. It works for all other applications.