[Stable Update] 2023-11-06 - Kernels, Gnome 45.1, Plasma 5.27.9, Firefox, Thunderbird, Pipewire

Packages don’t work. I got that error message

files conflict
linux65-zfs : /usr/lib/modules/6.5.9-1-MANJARO/extramodules already exists in filesystem

Folder contains nvidia and virtualbox modules but nothing related to zfs’s module

1 Like

Don’t Do That!™

Just use… :point_down:

sudo pacman -Syuu

… this one time to install the updated package.

(This was already mentioned several times on the thread. Next time please read before posting.)

1 Like

xsensors 0.80.

Cinnamon edition.

This program now stops from time to time. If I request a high load from the CPU, it seems that the update will definitely get stuck.

I think they must have been posted between me reading the thread before upgrading and me coming back after upgrading.
Though since KDEConnect is the only package I use that needs those packages, it’s as good a workaround for me as any other.

i can confirm, samething over here

After recent updates there are the following issues:

More than agree, ZFS is major FS it should be supported and it works in many distros and bsds. If it fails it means something wrong not with ZFS but with environment.


OK, I’ll recheck the packaging. Maybe some went wrong in placing the modules.


After the update parts of GNOME (the applications) have green accent (Maia) and part (the shell) appear in default GNOME blue. How do I make it consistent like it was before? I prefer Maia accent.

1 Like

@staff The current version of VapourSynth is broken, upgrade to Arch Linux - vapoursynth R65-1 (x86_64) please

check with @Yochanan on how to do it.

I might fix other zfs modules later today: [pkg-upd] 2.2.0-1.0 (78305c7d) · Commits · Packages / Extra / linux66-extramodules / zfs · GitLab


I felt adventurous, so I tried pacman -S linux65-zfs --overwrite /usr/lib/modules/6.5.9-1-MANJARO/extramodules. Also /usr/lib/modules/6.5.9-1-MANJARO only contained a single file “version”, which contains the current kernel name.

Sadly it didn’t work. The boot hangs while loading the zfs module.
Had to revert to a snapshot I created beforehand and recreate the initramfs from a stick via chroot.

My guess is, that linux66-zfs will behave in the same way.

Solved: found sddm-maia-theme was just a relict lying around… deleted.

Why is my gnome version 45.0 and not 45.1

1 Like

pacman would not update for the reasons mentioned about kpeople5 and kcontancts5. I uninstalled kdeconnect and it’s dependances to no avail. So I tried @gzyms advice to use Pamac which worked fine. I reinstalled, kdeconnect without issue. I reran pacman -Syu and ended up with the warning manjaro-panew-checker: local (0.5.4-1) is newer than extra (05.3-1) Which is not an issue for me right now. This was on my old laptop. For my newer desktop, I just used Pamac straight away without issue.

this change resulted in linux61 and linux61-zfs to break:

pacman -S linux61 linux61-headers linux61-zfs --overwrite /usr/lib/modules/6.1.60-1-MANJARO/extramodules
resolving dependencies...
looking for conflicting packages...

Packages (3) linux61-6.1.60-1  linux61-headers-6.1.60-1  linux61-zfs-2.2.0-1

Total Installed Size:  290.43 MiB

:: Proceed with installation? [Y/n] y
(3/3) checking keys in keyring                                                       [------------------------------------------------] 100%
(3/3) checking package integrity                                                     [------------------------------------------------] 100%
(3/3) loading package files                                                          [------------------------------------------------] 100%
(3/3) checking for file conflicts                                                    [------------------------------------------------] 100%
error: failed to commit transaction (conflicting files)
/usr/lib/modules/6.1.60-1-MANJARO/extramodules exists in both 'linux61' and 'linux61-zfs'
Errors occurred, no packages were upgraded.

And yes neither linux65(-zfs) nor linux66(-zfs) currently allow affected systems to boot, although kernel modules and initcpio look fine.

From the current Stable Update 2023-11-06 announcement:

Most or our Kernels got updated or rebuilt:

  • dropped ZFS support.
    There is still some dkms support but we are considering to drop it completely

See ZFS package changes above, and read related comments in this thread, if needed.

yes, but it seems that some errors where made and @philm is still trying to not leave people with broken systems. I wanted to chime in on these efforts.

Dropping support for it is fine. People should migrate to something else like off of ZFS or to another distro (like cachyos) if manjaro cannot support it anymore.

Please tell me if I miss understand these efforts and I am wasting my and everybody else’s time.

Same here!

Yes, that seems to summarise it. :slight_smile:
I thought you were simply asking for a solution:

Aside:- BTRFS might be a good alternative (I’ve noticed more people are choosing it lately); EXT is fine for my needs.