[Stable Update] 2023-06-04 - Kernels, Gnome 44.1, Plasma 5.27.5, Python 3.11, Toolchain, Firefox

When I used the command to print this list, after updating but before rebooting, it gave me a pretty long list ( > 300 packages).

When I printed the list again, after rebooting, it shrunk to just a few.

Is this expected?

So I guess everyone should reboot before they’re doing this rebuilding step, right?

The point is to be run on the newly updated system - searching for packages still using python3.10.
Your experience is expected.


Gnome 44.1 introduced a bug in Mutter that prevents giving proper focus to windows.
There is an issue on the gnome gitlab for that: https://gitlab.gnome.org/GNOME/mutter/-/issues/2690

Unfortunately I only learned this after the update. My “launcher based workflow” (currently using Albert) is completely broken. I am always typing into the wrong windows and it’s driving me nuts.

Is there a safe way to downgrade Gnome?

I could not open digitally signed pdf after latest poppler update to 23.05. Switched to poppler 23.03 with required dependencies and it works.

It was actually introduced during the development cycle of 44 series. Maybe the upcoming 44.3 might fix it. That is scheduled for 1st of July.

No internet, wifi interface unable to connect.
Similar to: WLAN funktioniert nach Update nicht mehr - #19 by go2sh
Manjaro does not connect to WPA2/3 mixed WIFI network - #2 by Pino

Workaround/Solution (choose 1):
a) disable mixed wifi network in router
b) downgrade wpa_supplicant
c) switch to lan

Broke “Asbru connection manager”, as it now seg faults.

To fix, update package “perl-glib-object-introspection”, like shown here.

pacman -U https://archive.archlinux.org/packages/p/perl-glib-object-introspection/perl-glib-object-introspection-0.050-2-x86_64.pkg.tar.zst

Because everything was moved to python 3.11
so it’s like fresh install of python, most tools aren’t installed.

Updating went smoothly, I had the same issue, firefox/telegram/etc… slow to start up after the fix is went back normally
Had to rebuild some of the packages to python 3.11
My real issue is with my pip packages, there are many of them and some even use configuration files.
Anyway, I’m thinking upgrading one by one is safer than running a vague do it all command, and since certain pip packages have been included in arch repo (eg. ueberzug), I think it would be better that way, espacially since I missed up and updated before using the workaround :expressionless: :expressionless: :expressionless:
Which make me feel it would bite me back some time in the future.
What do I do with the old 3.8 → 3.10 directories in /.local/lib?
can you just delete it?

the question is more if the hardware is not detected or you’re not able to connect to a router with a certain setup.

Okay, I had to get work done and do some live streams. Now I just did the updates! Here are my results:

  1. My computer restarted!! YAY!! (Last time it didn’t so I had to use Timeshift to go back)
  2. Firefox took forever to start so I did the fix listed above. It launches fine now!
  3. Steam didn’t work, so I reinstalled it. It works fine now and Elden Ring starts!! YAY!!
  4. OBS doesn’t work!! Here’s what I get:
$ obs
obs: error while loading shared libraries: libpython3.10.so.1.0: cannot open shared object file: No such file or directory

Any ideas would be appreciated. Thanks!!

UPDATE: I just tried to Build obs-studio-git (that’s what I’ve been using) and I got the following error:

CMake Error at plugins/obs-webrtc/cmake/legacy.cmake:9 (find_package):
  By not providing "FindLibDataChannel.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "LibDataChannel", but CMake did not find one.

  Could not find a package configuration file provided by "LibDataChannel"
  with any of the following names:


  Add the installation prefix of "LibDataChannel" to CMAKE_PREFIX_PATH or set
  "LibDataChannel_DIR" to a directory containing one of the above files.  If
  "LibDataChannel" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  cmake/Modules/ObsHelpers.cmake:519 (include)
  plugins/obs-webrtc/CMakeLists.txt:3 (legacy_check)

-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().

I tried this and my existing OBS does launch now and I did a short test stream. I really DON’T KNOW if this is a bad idea but I did…

$ sudo ln -s libpython3.11.so.1.0 libpython3.10.so.1.0

Use the flatpak from obs, it is more stable and has official support.

1 Like


Last time I checked, the Flatpak version doesn’t support the plugins I use. I have a huge post about this in the OBS forums. Maybe they fixed stuff in the past couple of months? I don’t know. Here’s my post if you want to take a look…

1 Like

Thanks! I just installed libdatachannel from AUR but I’m not going to try building OBS just yet because I got the current install working with a symbolic link.

1 Like

Edit: never mind they are: “Library with common API for various GNOME modules”.

Hardware is detected, I guess.
ip addr show lists my Wi-Fi interface. I am not able to connect to my router anymore. Another Kernel also didn’t fix the issue.
Is there any information which would help to pinpoint this issuo?

I use a 20W4CTO1WW ThinkPad T15 Gen 2i with up-to-date firmware.
The router in question is a Fritzbox 7530AX.

Does deleting it cause any issues? what does it even do?

It was dropped from the Arch repos and nothing requires it.

1 Like

Yep, no issues noted. Some info.

1 Like