[Stable Update] 2023-03-31 - Kernels, Plasma 5.27 LTS, Pamac, Phosh, Mesa, LibreOffice

Since the update I get following error at boot which does not seem to affect the booting process.

error: no such cryptodisk found
Press any key to continue...

My system is LVM encrypted but seems to run good even with this error.

There are some people with the same error in the archforum

https://bbs.archlinux.org/viewtopic.php?id=281647
https://bbs.archlinux.org/viewtopic.php?id=281959

But I do not get it how they solved the problem

My /etc/default/grub looks like this:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet lsm=lockdown,yama,apparmor,bpf"
GRUB_CMDLINE_LINUX="cryptdevice=/dev/nvme0n1p2:mytlscryptvg root=/dev/mytlscryptvg/root resume=/dev/mytlscryptvg/swap"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
#GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
GRUB_ENABLE_CRYPTODISK=y


Can somebody help?

@Grimmzz Hi there. Check out this string - read the whole thing to get a sense of the flow of conversations & go from there…

I know how you feel - I faced the same thing yesterday. As long as you have a Live Manjaro or other USB to boot into, you will be fine.

Ruziel :slight_smile:

1 Like

@Grimmzz You may just need to add cryptodisk to this line GRUB_PRELOAD_MODULES="part_gpt part_msdos" as first entry and call update-grub once. Else read thru the article @ruziel pointed at. Also this is linked in the first post and second post already.

1 Like

After the update all of my 3 monitors finally work as intended.
HDMI audio disappeared at first, but then I found out that my system now has two HDMI profiles. I switched to HDMI 2 and audio is working again.

Haven’t found any new bugs yet.
So update went surprisingly well for me.

mine boots fine w/out this luks+btrfs

After the update, I’m getting the dreaded [amdgpu]] *ERROR* ring gfx_0.0.0 timeout error on my AMD 5700XT every time I try to do something 3D related, like Blender, ParaView, or games. On X11 this causes my session to terminate. On Wayland it just hangs.

Haven’t found a solution yet.

1 Like

I just update my second older computer running an even newer install of Manjaro KDE. Running Kernel 6.2.8-1 with no AUR enabled. I oddly enough got the same error messages as my previous post.

Might this be something to do with using the Unites_States mirrors in Pamac?

Pamac error message upon 3-31-2023 updates finished installing:

Error while configuring manjaro-keyring
Error while configuring manjaro-keyring
Error while configuring manjaro-keyring
Error while configuring manjaro-keyring
Error while configuring manjaro-keyring
Error while configuring manjaro-keyring
Error while configuring manjaro-keyring
Error while configuring manjaro-keyring
A restart is required for the changes to take effect.

/var/log/pacman.logs relevant error messages:

[2023-04-01T10:35:49-0400] [ALPM] transaction started
[2023-04-01T10:35:49-0400] [ALPM] upgraded archlinux-keyring (20230130-1 -> 20230320-1)
[2023-04-01T10:35:49-0400] [ALPM-SCRIPTLET] ==> Appending keys from archlinux.gpg...
[2023-04-01T10:35:56-0400] [ALPM-SCRIPTLET] ==> Updating trust database...
[2023-04-01T10:35:56-0400] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2023-07-07
[2023-04-01T10:35:56-0400] [ALPM-SCRIPTLET] ==> Updating trust database...
[2023-04-01T10:35:56-0400] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2023-07-07
[2023-04-01T10:35:57-0400] [ALPM] upgraded manjaro-keyring (20221028-4 -> 20230318-1)
[2023-04-01T10:35:57-0400] [ALPM-SCRIPTLET] ==> Appending keys from manjaro.gpg...
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] gpg: error reading key: No public key
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] gpg: error reading key: No public key
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] gpg: error reading key: No public key
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] gpg: error reading key: No public key
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] gpg: error reading key: No public key
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] gpg: error reading key: No public key
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] gpg: error reading key: No public key
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] gpg: error reading key: No public key
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] ==> Locally signing trusted keys in keyring...
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET]   -> Locally signed 2 keys.
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] ==> Importing owner trust values...
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] ==> Disabling revoked keys in keyring...
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET]   -> Disabled 8 keys.
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] ==> Updating trust database...
[2023-04-01T10:35:59-0400] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2023-07-07
[2023-04-01T10:35:59-0400] [ALPM] transaction completed

After the update, gdm shows up as an orphan in pamac GUI. Removing it apparently put me in cmd-line at boot.

Mark it as explicitly installed:

sudo pacman -D --asexplicit gdm

In the future, be more careful about removing orphans. :wink:

My issue with this update:

I was running the old linux60 kernels (that aren’t supported anymore but I was unaware because I forgot to check) and when updating something went wrong with the kernels and GDM.
I was made aware of the fact today, when the screen lock activated when I was AFK for a while. The DM was throwing an error and not giving me the option to enter a password and unlock.
I rebooted and reached a tty. I logged in from there and using startx I could log in to a GUI.
I researched the forums extensively to understand what was wrong.

  • Old not supported kernel still active
    Solution:
    I cleaned up the kernels (I am now on linux62) and but the issue was there again.

I tried a systemctl on GDM and an error occurred stating there was no GDM, I, therefore, installed and enabled GDM following this guide in the Wiki, and my laptop boots correctly and GDM works.

For some reason being on older kernels when updating deleted GDM from my system or an older version was still there active and prevented the new one to work even if I had the new latest kernel.

Note to self, always check kernels before upgrading and read the release notes so that you know what to expect.

There it is. I did remove the orphans! So in fact it was me who removed it… unwillingly. Thanks @kevin77 for this explanation on how it was magically gone.

Can the maintainers of Manjaro please confirm clearly that the solution about disk encryption error provided by Skunkie: [Unstable Update] 2023-02-17 - Plasma 5.27 LTS, GNOME, Python - #50 by Skunkie

Is the final/working solution?

Many of us are not technical or semi-technical and asking us to run sudo commands to GRUB at the risk of borking our machines requires some assurances from the maintainers.

A clear outline for what people should do if they are on GRUB or UEFI is required here.

  1. How do we check if GRUB or UEFI?
  2. If GRUB, do what?
  3. If UEFI, do what?
  4. Does the DE matter? Does this apply to all DEs (KDE, etc.)

A clear & final solution that works and not “might work”, please!

1 Like

I’ve got an Issue with VirtualBox which is not starting any virtual machine since the Update.
Was running fine with Kernel 6.2.7 , is running fine with kernel 6.1.21, but is not running with kernel 6.2.8.

Something with kernel driver error, sorry didn’t write down the exact message.

Switched back to 6.1 and now everything is running fine again.

Any Solutions?

the system has updated smoothly (manjaro gnome) but i found out that after restart the headphone doesn’t work unless i unplug it and plug it again .
i found the solution in the forum
the title : [Dell Laptop: Analog Speaker Audio only after plugging and unplugging headphones]

the link :

the solution is deleting your pulseaudio user settings

rm ~/.config/pulse/cookie ~/.config/pulse/*.tdb

then reboot

I allowed myself to edit the wiki post in order to clarify the two points regarding GRUB, if anyone wants to double check me.

1 Like

Great operating system, smooth update. Thanks for everything. The combination of Plasma and Manjaro has proved stellar. Come on everyone, consider donating to Manjaro on a regular basis. I have been a supporter 5 for the last months for the price of two espressos a month. Small price to pay for a great system!

so this is why i now don’t have my desktop anymore?
wow!

Automatically removing orphans could lead to problems, list them out and do it manually, it’s only a bit of time but could potentially save you time.

A post was split to a new topic: Davinci Resolve: gpu init failed, cannot find opengl

I’m getting a systemd error on boot after the update:
Failed to insert module 'nvidia_uvm': No such device

System continues on afterwards and finishes booting.

For background, I am using vfio-pci to stub out my nvidia card for GPU passthrough to a VM. I don’t need to load any drivers for it. lspci -nnk shows these drivers are correctly in-use for the video card.

EDIT: I simply added nvidia, nvidia-drm, and nvidia-uvm to the blacklist, restarted systemd-modules-load successfully.

Also for some feedback on the LUKS encrypted drive solution, I ran update-grub and grub-install after adding the cryptodisk module to the grub config. Didn’t rerun mkinitcpio however since it didn’t make sense to me do so (the pacman hooks already run this, and the grub config doesn’t affect the kernel images). Rebooted fine save for the one error message.

May I make a suggestion for the partition scheme?

It is very nice that Manjaro includes Plymouth again. Plymouth CAN be particularly useful if the root partition is encrypted - because the graphical password prompt has a few advantages over the simple text input. (It also just looks better…)

In order for the graphical password prompt to work with EFI we need actually an unencrypted /boot-partition in addition the unencrypted /boot/efi and /root partitions.

I know there is supposed to be a potential security vulnerability with an unencrypted /boot. I’m not sure what it is, but other otherwise professional distributions (Fedora, Ubuntu, …) do this as well. So maybe this would be a nice addition to the installer for Manjaro?