[Stable Update] 2023-03-31 - Kernels, Plasma 5.27 LTS, Pamac, Phosh, Mesa, LibreOffice


A post was split to a new topic: Mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 5

With 500 updates for Plasma, maybe I shouldnโ€™t be surprised that the vote for โ€œNo issuesโ€ was only 74% after 200 votes. Fortunately Iโ€™m one of these 74%. Itโ€™s been about a year since I started with Manjaro pretty much without issues, maybe it is time I donate or at least pickup up a tshirt.



manjaro-start at the desktop needed about 20 seconds. But finally it run. I dont know why, but the desktop background dissapeared.

And one more thing, JDownloader looks like an ant farm, everything super tiny. I have checked

and the options are activated.

Dont know how to fix this :confused:

Hi Yochanan, I have been running 6.1 for a while now but i did not remove 6.0 as a fallback. So, I cleanup all linux60 but still those errors persist. I cannot go forward with the update.

la satisfaction des dรฉpendances a รฉchouรฉ:
- la suppression de lib32-libjpeg-turbo casse la dรฉpendance ยซ lib32-libjpeg-turbo ยป requise par lib32-libtiff
- la suppression de lib32-libjpeg-turbo casse la dรฉpendance ยซ libjpeg.so=8-32 ยป requise par lib32-libtiff
- la suppression de lib32-libelf casse la dรฉpendance ยซ lib32-libelf ยป requise par lib32-libva-mesa-driver
- la suppression de mpv casse la dรฉpendance ยซ mpv ยป requise par smplayer

Actualizacion instalada y sin ningรบn problema que reportar, todo funcionando y probado. Almenos en mi particular equipo

I have one question, maybe you know the answer to it. before, when I was on Manjaro Sikaris, systemd-analyze showed 6-8 seconds, and now on the Talos version, the shortest time is 13 seconds, can you understand the reason?

No, as we maintain it ourselves: Packages / Core / linux-firmware ยท GitLab You can complain about it in our gitlab instance.

1 Like

So there was some initial weirdness where my timeshift backup drive (separate) was not being detected (I think). This might have been causing a delay in all GTK apps when opening the file dialogue. I say this because once I disconnected and reconnected the backup drive and let a backup complete, the delay in opening file dialogues was gone. Since timeshift is a GTK app, there might be some connection there but I wouldnโ€™t know.

Everything working great now. On the plus side, Bismuth still working fine for meโ€ฆ

At first: after this 1,4 Gt update my PC booted 2 times OK, but during the 3rd booting - after successful LUKS process - the booting process ended into black screen with tty asking login name + password. I did not remember login name, so I had to re-install Manjaro (version 22.0.5) again.

Secondly: After re-install I received 1,3 update and I got โ€˜โ€˜error in updating manjaro-keyringโ€™โ€™. How to fix it ?

I do not know if this issue causes that porting of AUR packs end into error and cancelling.

A bit of a queer problem with Darktable. I may be the only person this is affecting (highly customised setup) but Iโ€™ll post this in case it does help anyone else.

Both the GUI and darktable-cli hang immediately on startup. After some debugging, I found that the GUI would work OK if invoked as darktable --disable-opencl but unfortunately the cli version doesnโ€™t have this option.

After more digging, I found that the problem is caused by intel-oneapi-compiler-shared-opencl-cpu, which annoyingly is required by another package I need. I think Iโ€™m going to have to somehow block access to /etc/OpenCL/vendors/ by Darktable, unless I can find a replacement for the package that needs the intel package.

I have so far noticed 3 relatively minor issues I assume are Plasma-related:

  1. My taskbars were wrong: all 3 had shrunk to below size 50 when I have them at 70, and the one on my portrait screen moved to the right side instead of the bottom.
  2. All font sizes had shrunk by 2pt.
  3. Favourites on the application launcher seem bunched up with incorrect spacing and thereโ€™s an unnamed folder icon among them that reappears immediately when I remove it - this is the only one I donโ€™t know how to fix.

I think this may be the cause / relation:

โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   ultra@Manjaro 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   ----------------- 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   OS: Manjaro Linux x86_64 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   Kernel: 6.1.21-1-MANJARO 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ            โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   Uptime: 39 mins 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   Packages: 1950 (pacman), 36 (flatpak) 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   Shell: bash 5.1.16 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   Resolution: 1080x1920, 2560x1440, 2560x1440 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   DE: Plasma 5.27.3 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   WM: KWin 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   WM Theme: Nordic 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   Theme: Breeze Dark [Plasma], Breeze [GTK2/3] 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   Icons: breeze-dark [Plasma], breeze-dark [GTK2/3] 
โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ  โ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆโ–ˆ   Terminal: yakuake 
                               CPU: 11th Gen Intel i5-11600K (12) @ 4.900GHz 
                               GPU: NVIDIA GeForce RTX 3060 
                               Memory: 9341MiB / 31932MiB 

1 Like

Something has gone wrong with your try of enabling https://nonfree.eu/ .

extra/libva-mesa-driver 23.0.1-1
mesa-nonfree/libva-mesa-driver 1:23.0.1-1

So again:

### install ###

## locally trust the ci key (you see two lines, but it is ONE command)
sudo pacman-key --recv-keys B728DB23B92CB01B && \
  sudo pacman-key --lsign-key B728DB23B92CB01B

## add the repo configuration:
sudo sh -c "curl -s https://nonfree.eu/$(pacman-mirrors -G)/ > /etc/pacman.d/mesa-nonfree.pre.repo.conf"

## include the repo configuration:
sudo sed -i '/^\[core\]/i \Include = /etc/pacman.d/mesa-nonfree.pre.repo.conf\n' /etc/pacman.conf

## run a full system update:
sudo pacman-mirrors -f5 && sudo pacman -Syyu

Now, when you open pamac-manager (donโ€™t forget to refresh the database), clic on repositories and you should see โ€œmesa-nonfreeโ€ on top.

After the Update some Software did not start anymore. That effects LibreOfiice, Darktable, OBS. Also deleting the .config files doesnโ€™t help. As a workaround I installed the Flatpak Version of LibreOffice and darktable which work.

Operating System: Manjaro Linux
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.1.21-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 ร— Intelยฎ Coreโ„ข i7-4790 CPU @ 3.60GHz
Memory: 15.5 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: H97-HD3

Try running darktable with darktable --disable-opencl. This fixed the problem for me. See my earlier post for more info on my diagnostics.

The nvidia driver (530.41.03) included in the latest stable update is not a stable driver according to nvidia. It is categorized as a โ€œNew Featureโ€ version, the โ€œProductionโ€ branch driver is 525.105.17.

The 530.41.03 driver ONLY support the 4090 GPU from the 4000-series, the 4070 and 4080 + all notebook 4000-series GPUs are unsupported.

How do I upgrade all components except the nvidia driver?

I think is something with pamac. I do not use pacman to upgrade my system, I always use pamac using this command below.

pamac upgrade --force-refresh 

To bypass these I have commented non-free repo and the upgrade was successful using the command posted earlier. After reboot, I have uncommented the non-free repo and tried again the same command to upgrade the mesa with non-free mesa and surprise the same error regarding invalid signature.
Then I have tried again the command but without โ€“force-refresh and what are you known, It worked by ignoring the signature error.
Maybe can someone light me, what I must to do to make it work when I use pamac upgrade --force-refreshโ€ฆ

You canโ€™t partially update if you use Nvidia drivers. Well if you donโ€™t use the binary modules for the kernels and use dkms then you might, if you find the old binaries for that or compile them yourself from our sources.

As i was reading, i can confirm i too โ€œlostโ€ my secondary monitor setting after a reboot-

Altough, i found out they were not lost, but Plasma detected the secondary monitor as a new one.
The settings for the monitor are still present when entering โ€œedit modeโ€ > โ€œmanage desktop and panelsโ€ under โ€œdisconnected monitor Xโ€ , you click on the hamburger menu of the panel you want and just "move it to [fullname of the monitor] and then delete the disconnected monitor.

Another really minor issue is that icon sizes in my main bar are a bit weird, but after changing the setting they got fine.

As of now, no further problems with the update.


After update and restart the desktop icons were gone (under KDE Plasma).
A repeated restart brought back the desktop icons.