[Stable Update] 2023-01-24 - Kernels, Plasma, Frameworks, Gear, Libreoffice, Mesa, Nvidia, Deepin

Gee, I have/do use AUR packages. I did not realize that they are not considered an official supported method.

Seriously guys… Twice now we have to use AUR to fix major bugs, first with Firefox and now with VLC! This is not serious! Especially when, in the meantime, you say that you don’t support it!

What firefox bug do you need to use the AUR for? I use firefox as my primary browser and it has worked for the past 3 years with basically no issue. I think in those 3 years I’ve had to delete the profile one time because something got messed up about 2 years ago but the current firefox in the repo works great.

1 Like

After this update I decided to install the 6.1 kernel, to have it together with 5.15.

On the 6.1, my mouse (breeze color scheme) has red outline.
On 5.15 it is correct: black mouse with white outline.

Did anyone else experience this? How to fix it?

Confusing post - you said my mouse and (breeze color scheme).
Actually, on the screen, what you see is a CURSOR. You can see this in settings - so maybe ‘Breeze’ is right?
Anyway, no problem here… but some information is helpful.
X11, KDE plasma 5.26.5…
Try creating a new user ‘TEST’ and see if it happens there.

After some updates this (known) problem is not fixed:

In summary, the graphical user interface of firefox only opens after one of several running processes has been terminated manually. All measures such as clearing the cache etc. and others as stated in the above thread do not lead to a consistent solution.
Whether this is a libx11 problem that can be fixed with an available AUR-libx11-firefox-fix is not for me and probably some others to judge (especially since it’s more of a startup problem than a freeze). If possible I would avoid installations from the AUR.
It would be very helpful and kind if you could take a further look.
Experiences with the AUR fix would also be helpful.

A post was split to a new topic: The stable update broke the run-time shader compilation

Second message of this topic in the known issues.

Sorry for the confusion. Yeah, the cursor theme is breeze.

After a bit more experimenting, I think I found what causes it — redshift!! (But I still don’t understand why)

I still have no clue why the same never happened before on the 5.15 kernel.

If anybody knows how to deal with this, I’d appreciate it.

Run it!

Firetools doesn’t start anymore.

Thank you, i had the same issue.

You saved me a lot of time and researches :slight_smile:

1 Like

Thanks for posting that link. I had the same VLC problem.

Same issue with OBS crashing with segmentation fault. Re-installation had no effect.

Are we expected to download Decklink from AUR to use OBS now? I’ve never had any Blackmagic stuff, which may be why it’s not installed.


warning: Failed to load 'en-US' text for module: 'decklink-captions.so'
warning: Failed to load 'en-US' text for module: 'decklink-output-ui.so'
libDeckLinkAPI.so: cannot open shared object file: No such file or directory
warning: A DeckLink iterator could not be created.  The DeckLink drivers may not be installed
warning: Failed to initialize module 'decklink.so'
warning: Failed to load 'en-GB' text for module: 'frontend-tools.so'
warning: Failed to load 'en-GB' text for module: 'linux-alsa.so'
warning: Failed to load 'en-GB' text for module: 'linux-capture.so'
warning: Failed to load 'en-GB' text for module: 'linux-jack.so'
warning: Failed to load 'en-GB' text for module: 'linux-pipewire.so'
info: [pipewire] No captures available
warning: Failed to load 'en-GB' text for module: 'linux-pulseaudio.so'
info: NVENC supported
Segmentation fault (core dumped)

Virtualbox refused to update because the AUR package virtualbox-ext-oracle is pinning the old version. You can resolve it by removing the AUR package before pacman -Syu and re-install it later.

mkinitcpio complained the consolefont, ter-124n not found. This can be solved by installing terminus-font from the main repo.

or by modifying the PKGBUILD and building manually.



A post was split to a new topic: Can’t start Steam anymore

A post was split to a new topic: DisplayPort issues

2 posts were split to a new topic: Doom and Doom Eternal in Steam freeze


When I rapidly move the firefox window towards the side of the screen (so that the window uses the left half for example), X11 get killed :

[118810.972] (EE) 
[118810.972] (EE) Backtrace:
[118810.972] (EE) 0: /usr/lib/Xorg (WriteToClient+0x3ed) [0x55fc9c12857d]
[118810.973] (EE) 1: /usr/lib/libc.so.6 (__sigaction+0x50) [0x7fca689329e0]
[118810.973] (EE) 2: /usr/lib/libc.so.6 (pthread_key_delete+0x14c) [0x7fca6898264c]
[118810.973] (EE) 3: /usr/lib/libc.so.6 (gsignal+0x18) [0x7fca68932938]
[118810.973] (EE) 4: /usr/lib/libc.so.6 (abort+0xd7) [0x7fca6891c53d]
[118810.974] (EE) unw_get_proc_name failed: no unwind info found [-10]
[118810.974] (EE) 5: /usr/lib/libc.so.6 (?+0x0) [0x7fca6891c45c]
[118810.974] (EE) 6: /usr/lib/libc.so.6 (__assert_fail+0x46) [0x7fca6892b486]
[118810.974] (EE) 7: /usr/lib/dri/iris_dri.so (nouveau_drm_screen_create+0xa16ab0) [0x7fca66c79810]
[118810.974] (EE) 8: /usr/lib/dri/iris_dri.so (nouveau_drm_screen_create+0x7477b9) [0x7fca669aa519]
[118810.974] (EE) 9: /usr/lib/dri/iris_dri.so (nouveau_drm_screen_create+0x75b6a1) [0x7fca669be401]
[118810.975] (EE) 10: /usr/lib/dri/iris_dri.so (__driDriverGetExtensions_d3d12+0x61bf98) [0x7fca65ef4808]
[118810.975] (EE) 11: /usr/lib/dri/iris_dri.so (__driDriverGetExtensions_d3d12+0x7d7f3) [0x7fca65956063]
[118810.975] (EE) 12: /usr/lib/dri/iris_dri.so (__driDriverGetExtensions_d3d12+0x67879) [0x7fca659400e9]
[118810.975] (EE) 13: /usr/lib/dri/iris_dri.so (__driDriverGetExtensions_d3d12+0x6e839) [0x7fca659470a9]
[118810.975] (EE) 14: /usr/lib/dri/iris_dri.so (__driDriverGetExtensions_d3d12+0x6f10e) [0x7fca6594797e]
[118810.975] (EE) 15: /usr/lib/xorg/modules/libglamoregl.so (glamor_name_from_pixmap+0xb3bb) [0x7fca67c1ccdb]
[118810.975] (EE) 16: /usr/lib/xorg/modules/libglamoregl.so (glamor_change_window_attributes+0x4a41) [0x7fca67c22c91]
[118810.975] (EE) 17: /usr/lib/xorg/modules/libglamoregl.so (glamor_set_pixmap_texture+0x95) [0x7fca67c09d55]
[118810.976] (EE) 18: /usr/lib/xorg/modules/libglamoregl.so (glamor_egl_create_textured_pixmap_from_gbm_bo+0x16c) [0x7fca67c09f4c]
[118810.976] (EE) 19: /usr/lib/xorg/modules/libglamoregl.so (glamor_back_pixmap_from_fd+0x11e) [0x7fca67c0a16e]
[118810.976] (EE) 20: /usr/lib/xorg/modules/libglamoregl.so (glamor_pixmap_from_fds+0xe2) [0x7fca67c0a4c2]
[118810.976] (EE) 21: /usr/lib/Xorg (ProcessCommandLine+0x2830) [0x55fc9c12c090]
[118810.976] (EE) 22: /usr/lib/Xorg (dri3_screen_init+0x44fe) [0x55fc9c133a1e]
[118810.976] (EE) 23: /usr/lib/Xorg (SProcXkbDispatch+0x28b8) [0x55fc9c00ff1f]
[118810.976] (EE) 24: /usr/lib/libc.so.6 (__libc_init_first+0x90) [0x7fca6891d290]
[118810.977] (EE) 25: /usr/lib/libc.so.6 (__libc_start_main+0x8a) [0x7fca6891d34a]
[118810.977] (EE) 26: /usr/lib/Xorg (_start+0x25) [0x55fc9c010315]
[118810.977] (EE) 
[118810.977] (EE) 
Fatal server error:
[118810.977] (EE) Caught signal 6 (Aborted). Server aborting
[118810.977] (EE) 
[118810.977] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[118810.977] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[118810.977] (EE) 
[118810.977] (II) AIGLX: Suspending AIGLX clients for VT switch
[118811.065] (EE) Server terminated with error (1). Closing log file. du code ici