Firefox runs without interface

Yep, still the same problem for me, although I tried all the workarounds suggested above. And this is definitely not a KDE issue (I’m running GNOME).

I was hoping that yesterdays Manjaro update should solve the problem.
There were both an Firefox update, as well as a kernel update.
It didn’t help, though.

/ Hans Gatu

1 Like

After the new system update and reboot, Firefox did not open its window, and I made different tests :

  • kill the last FF process(es) through task manager,
  • open about:support in a new tab when FF opens and clear start cache,
  • open a “new” window through FF icon on my task bar, then about:support and clear start cache
    but each time that I closed FF and tries to reopen it, no window opens.
    The only thing that worked (for me) was to start FF through Terminal :
firefox --new-window about:support

and click on Clear startup cache… then click on Restart FF
FF reopens the single tab window and my FF window with all my tabs. Then I can close FF and start it without problem.
So, there is problem somewhere … :innocent:

firefox --new-window about:support

That didn’t work for me. That was the first thing I tried before having to attempt to open FF and kill the process a few times until it said something about safe mode. The problem is definitely with FF as this happens on my Ubuntu laptop now as well. I guess we’ll just have to hope they figure out the issue sooner or later.

1 Like

You are right. This workaround seems to work for me, too. Starting Firefox from the Konsole starts 3 processes called Firefox, but no window. Killing one of these 3 processes causes a Firefox window to appear. The Konsole produces the following messages when I kill one of the original 3 processes. I don’t know whether they are useful.

[GFX1-]: glxtest: VA-API test failed: process crashed. Please check your VA-API drivers.
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
[2022-12-07T21:48:22Z ERROR glean_core::metrics::ping] Invalid reason code startup for ping background-update

So, there is problem somewhere … :innocent:

There’s clearly a bug, indeed. On another topic, someone mentioned that this could be caused by specific Manjaro settings for Firefox (maybe in the package manjaro-browser-settings). Don’t have any clue, and the process to report this kind of weird and unidentified bug to Manjaro devs is still unclear to me.

This really was just a guess of that “someone”, I guess :wink:
but to rule that one out and for peace of mind
it is easy to deinstall that package.

Something that seems to be working for me that everyone might want to try. I’ve been waiting a few minutes after booting my system before opening FF. Not sure if it’s a coincidence or what, but so far it’s worked for me.

OK, @tempest2084. I tested to wait for some time.
By accident, it became around half an hour.
But, Firefox started on first attempt, though.
/ Hans Gatu

Same problem for me after the last update (20-12-22) and reboot.
The solution I used last times was :
firefox --new-window about:support (+ Clear Start cache)
but without effect today.

What worked this time is :

  • open Task Manager and enter firefox in selection area
  • kill the FF process with highest PID number
  • possibly repeat on the second one
  • FF opens with all the tabs …

Now Firefox works. It starts at first attempt. Everything looks just fine.
It all happened yesterday, after Manjaro big update that (among plenty of other package updates) included updated Firefox and updated kernel.

/ Hans Gatu

He doesn’t believe it. It could be a coincidence. I don’t know what manjaro updated in this update but on arch it doesn’t continue to work.
Looking at the packages it firefox still hasn’t gotten the update since 16
Mesa hasn’t either
It’s either they came up with a workaround or it will be something else
Arch gets updates faster than manjaro so I really don’t know why it still works the way it does
But I’ll believe it when I see a clean manjaro after installation with ff running

Well. Tried latest updates … [Stable Update] 2022-12-20 - Kernels, XFCE 4.18, KDE Frameworks, Kde Gear, Mesa, Plasma-Mobile, Thunderbird, Firefox. Update itself went without problems.

But situation around mesa higher than 22.1.7 causing trouble for Firefox startup persist.

  • So we are lucky and still have packages from 22.1.7 version of mesa and we can downgrade to this version of ?-mesa-?, ?-vulkan-? packages. (or other version that worked for you).
  • Or endure, go along with upgrades and manually kill highest PID of Firefox to let it continue.

As I read this is unrelated to removal of video codecs from open source AMD graphic mesa driver (22.3+). Since my trouble started at start of november already. And that is moving from mesa version 22.1.7.

Its not problem with radeon vulkan package because i don’t use it cuz i’m using radeon instead of amdgpu.
Try remove libva-mesa-driver and mesa-vdpau it should help i think. These packages problems recently caused my firefox to behave like this

wake up people.
The mesa update for the 31.12 arch still does not fix the problem.
I played around and check for yourself if you have pipewire-pulse installed.
When I uploaded it the first time after a reboot the browser launched but that’s probably just luck

Another mesa update for arch still firefox not fixed

Yeah. For me … keeping mesa and vulkan packages back at 22.1.7 solved everything with starting Firefox. But I actually started using Manjaro in august 2022. So I have 22.1.7 version of mesa from that installation.

There is no VA-API error with this old version and looking at:

It seems more and more changes are still happening. So probably in future some mesa, vulkan and firefox might just again work with one another and will use hardware acceleration using VA-API without errors. Unless these will get entirely replaced with something else.

This happens only when we are talking physical and accessible AMD graphic cards, since in virtual machines I never got any problems with Firefox. Either way “Big companies” messing around with open source drivers and video decoders/encoders at least does explain current problems. It will take time, before Mozilla can repair their hardware acceleration to whatever will be used for new video decoder/encoder.

At least that is how I understand current situation.

Firefox had been working perfectly up until I updated this morning and now it’s back to not starting unless I kill it several times and I get that safe mode prompt. Did they revert something?

With this upgrade ([Stable Update] 2023-01-24 - Kernels, Plasma, Frameworks, Gear, Libreoffice, Mesa, Nvidia, Deepin) I can’t downgrade to mesa 22.1.7 … because new KDE release becomes software rendered.

Now there is no way to avoid this quirky Firefox startup anymore. :sweat:

same bug with a liveusb:

    1. launch manjaro-kde-22.0.1-230124-linux61.iso
    1. click on the firefox icon
    1. and … nothing happens!

This bug does not occur on Fedora, Ubuntu, …