[Stable Update] 2022-12-20 - Kernels, XFCE 4.18, KDE Frameworks, Kde Gear, Mesa, Plasma-Mobile, Thunderbird, Firefox

I got this (no response, no error)


The program does start however. It is shown in task list. But it does not display any GUI, nor does it automount my two SMB shares which it is configured to do.

With this update, my keyboard behaves strangely
Control, Shift, Num Lock key does not work.
I can’t change the case of the first letter with shift, nor select and copy text.

Using the new kernel or lts 5.15 the modifier keys do not work.

Restart each kernel change and the same thing happens.

SOLVED: Using another keyboard, this one worked for me.
Then I disconnected my failed keyboard, worked for a while with the other one; reconnected my working keyboard and now it is working correctly.

(before switching keyboards).
Checking the keyboard configuration I see that it changed to 86 keys, I also reset it to 105 keys.

After update screen is freezing after suspend with lid close.
On wayland session mouse freezes, and I can`t switch VT, only force shutdown works.
On X11 session i can switch VT, but restart doesn’t work.
No problem on Xfce4.
I use KDE Plasma, Intel Xe, Intel Core i7-1165G7, Huawei Matebook Pro Notebook.
I come to Manjaro from EndeavourOS because of that problem, and now issue appear here too.
Any Ideas what package cause these?

1 Like

Not even in the tray, hidden or otherwise?

I’m not sure this is a general problem. I’m running a Haswell CPU on KDE 5.26.4, and haven’t seen any freezes so far:

  $ inxi
  CPU: quad core Intel Core i5-4670 (-MCP-) speed/min/max: 2880/800/3800 MHz
  Kernel: 6.1.0-1-MANJARO x86_64 Up: 1m Mem: 2878.7/15664.2 MiB (18.4%)

After the update, I restarted. After the restart, the title bar of many apps had turned white. So I fixed it by going to Tweaks > Appearance > Selected Adw-gtk3-dark for Legacy Applications.

I am also having the same issue (matebook pro) with the screen freezing after suspend. Using the LTS kernel 5.15 seems to have fixed it for the time being for me.

I had a problem with the update, receiving this error:

Error: opencc: extract: not overwriting dir with file /usr/lib/python3.10/site-packages/opencc/clib/share/opencc

I thought it was a minor conflict problem, so I decided to temporarily exclude the package, update the rest and fix it later.

sudo pamac update --ignore opencc

Oddly enough, at the end of the process, opencc was updated and no problem was left. My guess is that two packages tried to write the same files or something like that. In any case, ignoring opencc solved the problem and no further steps were needed.


Spoke too soon, for some reason, the kernels updated but didn’t place the .img files in /boot. I guess the update process was interrupted at some point and pamac thought it was successful while it really wasn’t. I hope that didn’t happen with other packages.

I fixed it by using manjaro-chroot -a from a live usb and then removing and reinstalling linux510, linux54 and linux419. I find it odd that the tree of them failed at the same time in the same way, the very reason why I have the three of them is to prevent situations like this.

By the way, is this supposed to be the new default wallpaper? (I use gnome) I like it, but you usually use more green and the Manjaro logo, I wonder if the theme-related packages were installed correctly.

I saw a big space between letters in my terminal:

I resolved unchecked this option on the terminal preferences (Preferences > Your profile and the “Text” tab):

Other way is to configure the custom font. In my case the checkbox was checked and the font was empty after the update.

After the update, my computer seems to forget the WiFi password when it wakes from sleep. It spends a while trying to connect, fails and prompts for the password. I’m honestly not sure where to start with this. Kwallet maybe?

On first boot and login-

  • KDE plasma desktop shows as small area in top left of screen and most of screen area is unresponsive to mouse and screen updates
    loging out and back in fixes this

  • calendar widget displays behind menubar until I go into edit mode and readjust it

I should mention that these 2 problem started a few updates ago

otherwise update seems good

New change added to the wiki post:

EDIT: The change has been reverted.

Don’t know how to fix the error but they are to do with the konsole app which now is built with two plug-ins. “Show SSH Manager” and “Show Quick Commands”. The two plugins seem to be functioning and it seems like the warning about using a possibly deprecated way making the shortcuts work. At least that is my understanding of it. Anyway, this is a fairly small error for sure. Hopefully it gets fixed.

I believe this is the bug report: 462615 – Use KActionCollection::setDefaultShortcut(s) instead

1 Like

Hibernation is no longer working after this update…wonder if anyone is having similar issues?

Pacman GUI, only shows updates when i use pamac update -a in the Terminal. When i dont use that command, its telling me that no updates found and that im up to date.

After updating Manjaro tonight to the latest bits, I get this notification every time I use ALT+TAB in KDE: “The Window Switcher installation is broken, resources are missing. Contact your distribution about this.”

just to check, you are using integrated graphics, right?

No, nothing. Tried a remove / reboot / re-install. Same result.

Had the same issue. Somehow, even if the switch “Search for updates” is set and a fixed time intervall is set, it would not search for the updates. After refreshing the database, it found all the updates.
Try this the next time (update databases) in the pacman GUI:

1 Like

This has been “solved”, but read below!!

First reboot after the update of my KDE flavor got me to the login, after that I had a mouse cursor and a totally black screen. I waited for a long time tried to go to a terminal (also a black screen), returning to the ‘desktop’ gave me nothing, also no cursor anymore. I waited a while until I rebooted.

Now after the BIOS there is sometimes a short one-liner flashed to the screen for like one frame. I am still trying to capture it with a camera. After that: Nothing. Black, no cursor.

I am trying to download a new image, but apparently manjaro.org is down.

This really weird thing happened, but only on my laptop. The desktop is still blacked out:

By the way: Witchcraft happened: I let the laptop unattended for about three hours - turned on, ready to do something but children came into the planning… Well. I last saw it about an hour ago, still the same, black screen. Now it showed the graphical log-in. The only difference is that the battery apparently has run down to 20% in between. (Not plugged in for some reason)

I really would like to find out what has happened in between! Any ideas what to look for?

I am on kernel 6.0.14-1, by the way. If anyone will give me some command to run for information I will happily provide that, if not, I probably just won’t find the time these days to dig myself.

(My other machine is still on a black screen.)

This is really, really bad. I’m scared to reboot!

In hindsight two things have happened:

Machine number one:

  • No Grub, nothing. Restoring the MBR and grub did allow for one bootprocess, ending in a black screen, no TTY, nothing after graphical login. Each time. Restore MBR, restore Grub, boot, login, black screen.

This was solved by: Going to kernel 5.15. Cleaning up space on the system partition, which was down to 0 byte at some point. (This cannot really have been the main issue, there was space at first, but apparently some updates did fill the system at some point. In my opinion pacman/pamac should be very much more aware of low disk space…)

The system is back for now, I am scared to use a different kernel…

Machine number two

  • No idea. It did show the grub menu, but did not accept any input. It went straght to black screen with a curser, blinking in a non-regular, repeating pattern. I could not switch to a TTY, input (any key) changed the blinking pattern to another one, no other input did anything else. I tried a lot of things, mainly to get grub to accept any input, all without any success. The machine was unattended for about three hours, sitting with a blinking cursor on a black screen. Sometime between two and three hours the machine must have “healed itself”. I looked at the screen after three hours, it showed a graphical login and behaves like nothing happened. It boots, suspends, comes back etc. Updates ran through, kernel was and is 6.0.15.

The second machine scares me. I have no idea what had happened, I missed the chance to look at the logs (I rebooted before trying…).