[Stable Update] 2022-12-06 - Kernels, Mesa, Plasma, Cinnamon, Nvidia, LibreOffice, Pipewire, Virtualbox

You can use pacman-mirrors to let it choose another one.

I had problems a while ago with systemsettings segfaulting on startup. It turned out to be that the theme I was using was buggy and was making some call or other that had been deprecated for a long while. (If memory serves correctly).
I can’t remember how I changed the theme without access to systemsettings, but presumably it was just an edit of one of the config files (possibly ~/.config/kwinrc).

Better check this:

Solved. Looks it’s not a problem with the update itself… very strange…

I noticed since the update that when on battery the CPU is stuck at the lowest frequency, when plugging it back to AC the CPU is still at the lowest frequency and I have to manually change the governor.

This may have happened with a previous update but I didn’t notice it before.

I can’t start any of my VMs after the Qemu packages got updated. It also removed edk22-armvirt in favor of edk2-aarch64. There is no error message, all I can see is that all VMs snap to the same CPU usage in Virt Manager and their is no output, they just get stuck.

Some potential workarounds were proposed in another thread:

if you search for VPN in the forum, you might even find a solution

you can add it to IgnorePkg in /etc/pacman.conf

Thanks for that - problem solved by clearing plasma caches

1 Like

Could you see if this is fixed in the latest Firefox (v108, which was released to the Manjaro repository just today)?

yep, but this don’t solve. I mean, probably it’s a easy fix, and the problem it’s very annoying, so it’s kind of urgent…

Updated everything here, and nope, it is not fixed yet. An update of Firefox will not fix, it’s a problem with the libx11 itself.

Possibly related: FS#76669 - [libx11] Firefox unresponsive on copying or pasting

  • KDE Plasma wayland session crashes
  • telegram crashes after screen sharing

Well, that stinks, but thank you for trying and letting me know!

It’s an important bug for me to have resolved, since I use my Manjaro box in my lab, quite often highlighting things like part numbers, and then searching for them, e.g. locating data sheets for ICs. Having the browser freeze every time I highlight something is unacceptable.

That’s an interesting bug report, because I’d last read on Mozilla’s bug reporting site that Firefox v108 (beta, at the time) had supposedly fixed the issue(s). It seems there’s been a slight improvement, since, as one user in that thread said:

The frequent freezing has turned into (less?) frequent crashing.

which is actually kinda good, because crashes usually result in logs, whereas freezing doesn’t (always/often), IME.

Looks like rolling back libx11 to v1.8.1 is the “best” fix until that package’s developers do something about it. Time to get out the cattle prod.

1.8.3-2 seems to have fixed it for me.

Maybe 1.8.3 fixes the firefox crashes. Even though I downgraded to 1.8.1 for now, which works fine as temporary fix.

EDIT: I’ve just seen in the testing repo of Manjaro version 1.8.3-3 of libx11 library is included :crossed_fingers:

This one fixed it for me:

Downgrading kernel is only viable as a short-term fix

Simpler long-term solution is to install kernel v6.0

1 Like

Hi, yes – I cloned it from git and rebuilt it and re-installed it.

EDIT: Found the solution. Security levels have changed in openssl 3. My SQL server only talks TLSv1. In order for openssl to accept this, one has to make the following changes in /etc/openssl.cnf:

At the top of the file:

openssl_conf = default_conf

At the bottom of the file:

ssl_conf = ssl_sect

system_default = system_default_sect

MinProtocol = TLSv1

Further reading: