[Stable Update] 2022-11-14 - Kernels, GNOME 43.1, Plasma 5.26.3, Systemd 251.8, Firefox 106.0.5, Thunderbird, LXQt

Ah I get it now.
Your keyslot uses Whirlpool AF hash which needs /usr/lib/ossl-modules/legacy.so in order to be unlocked on boot, and that has been worked around by Arch maintainers with adding it explicitly to /usr/lib/initcpio/install/{sd-}encrypt with this:

I suggested you to switch over to sha256 hash btw so you could be sure if that was the reason why you have this issue.

Anyway, the culprit here is poor integration with Plymouth which hasn’t been updated the way encrypt and sd-encrypt hooks were, i.e. it’s plymouth-encrypt hook has no instructions on adding ossl-modules/legacy.so to the initrd, you can check it now with say, lsinitcpio /boot/initramfs-5.15-x86_64.img |grep legacy.so (assuming your kernel is 5.15, amend accordingly), and the output should be empty. But that’s what you use as encrypting hook in your mkinitcpio.conf instead of encrypt, because you use Plymouth. So what you can do (3 ways):

  1. Switch away from Whirlpool hashing
  2. Switch over to regular encrypt hook without Plymouth support
  3. Edit plymouth-encrypt hook manually in a way that the above 2 hooks were modified by Arch people.

Pinging @Yochanan to let him know that our Plymouth package might need slight adjustments… :upside_down_face:

Shame on me, I always forget about the fact that Plymouth has its own encrypting hook and it often could be out of sync with everything else, but I use it too and sometimes experience weird hiccups as well.

1 Like

"There was an error extracting ‘manjaro-gnome-22.0-221115-linux519.iso.zip’
not an archive"


@Riquez: download .zip and .z01 files. You must use the following command line: 7z x *.z01
You will have the iso file after that and then you can check checksum.

@ManjaroTeam: Thanks to give Gnome 43.x. I’m come back to Gnome because I’ve got many issue with KDE. I’m also using Manjaro Cinnamon who is very good too. :slightly_smiling_face:

After updating, Duplicati started returning the error Failed: EVP_MD_size assembly:<unknown assembly> type:<unknown type> member:(null). This thread on the duplicati forum clued me into it being openSSL-related.

I installed openssl-1.1 and restarted Duplicati, this fixed the error.

I get Using GtkSettings:gtk-application-prefer-dark-theme with libadwaita is unsupported. Please use AdwStyleManager:color-scheme instead when opening nautilus from the terminal (within Awesome WM). The icons and colors are screwed up.

Seems to be a configuration issue in ~/.config/gtk-4.0/settings.ini. I copied my settings from the gtk3 configuration to gtk4, which seems to work (with some warnings).

The latest update broke my OpenVPN connection. I tried a few setting changes that worked in Kubuntu 22.10 but no luck. So I rolled back to the previous version of OpenVPN and my connection was restored successfully.

Below is the proper way to restore back OpenVPN to the previous version (2.5.7):

# remove openvpn and networkmanager-openvpn
sudo pacman -R openvpn networkmanager-openvpn

# install openssl-1.1. This won't override openssl-3.0
sudo pacman -S openssl-1.1

# download and install openvpn-2.5.7
cd ~/Downloads
wget https://archive.archlinux.org/packages/o/openvpn/openvpn-2.5.7-1-x86_64.pkg.tar.zst
sudo pacman -U ./openvpn-2.5.7-1-x86_64.pkg.tar.zst

# install networkmanager-openvpn
sudo pacman -S networkmanager-openvpn

To mask openvpn package from upgrading:

sudo nano /etc/pacman.conf

Uncomment IgnorePkg and add openvpn:

IgnorePkg   = openvpn

Save the change.


hmm, i tried that but it gave an iso which properties says is a plain text doc size 0 bytes.

7z x '/home/rico/Downloads/manjaro-gnome-22.0-221115-linux519.iso.z01'
the zip is is also in the same location (Downloads)


Screenshot from 2022-11-15 14-30-51

It seems this issue is related to having a browser open before putting the laptop to sleep. Then later waking up the laptop, then later connecting bluetooth headphones. And possibly related to the automatic profile switching (from A2DP to HSF/HFP) from when the browser requests the default microphone. Somehow, this combination leads to the browser being unable to get the microphones anymore, until the browser is restarted.

I don’t have Zoom, Slack, Discord or any of those installed as applications. (And I believe under the hood they’re just browsers.)

On my machine KeePassXC stopped respecting a dark theme. If I downgrade it back to 2.7.1, it gets back to being dark again; if I upgrade it to 2.7.4, it goes to being white.

Can anyone confirm that it happens on their system too?


7z x '/home/rico/Downloads/manjaro-gnome-22.0-221115-linux519.iso.zip'

the first file .zip not .z01.

Also try closing file manager, then re-open file manage and see if its still 0 bytes, some times file managers fail to update/refresh the window.

Thank you, thank you, thank you!!!

For me, the most favorable choice will be the plymouth magic
on the one hand for the fun factor and to fit my use case.
On the other hand I had tried to use the one char key previously for testing,
which had used sha256, however it has not worked either as I had mentioned before
(but the digest is pbkdf2 and using whirlpool soooo… who knows).

yepp the command, (

lsinitcpio /boot/initramfs-5.15-x86_64.img |grep legacy.so

) you have mentioned, gives back empty output indeed

I will write again as soon as I get results.

well the masterkey’s digest itself is made with whirlpool,
and I have no idea, how to change that without luksFormat :-((

(I have read the dm also. Thank you as well!)

tried, same result.
I also rebooted & copied the resulting iso file to a USB drive - it really is a 0 byte file. :thinking:
downloading both files again …

oh, perhaps this is why!

Igor Pavlov - 2012-03-19

7-Zip doesn’t support .z01 multi-volume ZIP archives.

Finally wow
zip -F manjaro-gnome-22.0-221115-linux519.iso.zip --out mg22.zip

My bad it should have been

7z e filename

and not 7z x filename
And yes 7z now supports multi-volume.

I already tried e after reading the docs on 7z, it also did not work, 0 byte file.
Try downloading the files & see if it works for you.

anyway, zip -F worked, I tested the iso as live boot it was ok.

I believe this issue is related to the OpenSSL update:

(12/25) Install DKMS modules
==> dkms install --no-depmod broadcom-wl/ -k 5.10.154-1-MANJARO
/usr/lib/modules/5.10.154-1-MANJARO/build/scripts/sign-file: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory
==> dkms install --no-depmod broadcom-wl/ -k 5.4.224-1-MANJARO
/usr/lib/modules/5.4.224-1-MANJARO/build/scripts/sign-file: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory
==> dkms install --no-depmod broadcom-wl/ -k 4.19.265-1-MANJARO
/usr/lib/modules/4.19.265-1-MANJARO/build/scripts/sign-file: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory
==> depmod 5.10.154-1-MANJARO
==> depmod 4.19.265-1-MANJARO
==> depmod 5.4.224-1-MANJARO

I did download the files and this worked for me from terminal:

Make sure terminal was cd into Downloads and typed:

7z e manjaro-*.zip

and i ended up with 3.7GB Iso file.

Yes. Install openssl-1.1 package to fix them.

Now it worked!

I found that pipewire-pulse crashed whenever this bug happened. Somehow it looks like it can crash when I’m not expecting, and then later it doesn’t crash while I’m looking.

Process 1825 (pipewire-pulse) of user 1000 dumped core.

Module linux-vdso.so.1 with build-id 90ee25c0c8a737fbd9ab0ab726544e975f60d2f0
Module libspa-audiomixer.so with build-id 41d67f6952a6f52558b694ed47985922bebe9599
Module libspa-audioconvert.so with build-id c9e34f32440b48706250fe8c6bb2d0f7a9230088
Module libpipewire-module-fallback-sink.so with build-id dfb6d813bf99ab61573523bf9512d1bb0e40076e
Module libpcre2-8.so.0 with build-id 917fc43d2c9f8539a3e324555c6c73886e8000a8
Module libdl.so.2 with build-id 414d1d630bc04818a150b9c73e4493f3395e8869
Module libpthread.so.0 with build-id 3954d7fd57fa4db438d0ccdd8e2c6f7cc97c2e46
Module libglib-2.0.so.0 with build-id 49826f5cd4f784c8050176991d46fd93a5fcee9f
Module libavahi-client.so.3 with build-id 1858551543958190c653b565cf0eb64609ad908a
Module libavahi-common.so.3 with build-id 80fda945459a3476ccd1050783dfd5f5c17c479a
Module libm.so.6 with build-id 2c8ff1d29b255da5b7371efd5caf57444d622838
Module libpipewire-module-protocol-pulse.so with build-id 0993158b0189967c383a8f03e0c37f50cd62346b
Module libpipewire-module-metadata.so with build-id d1eea02e4337978f2b3ddb3e142cd88f4d23c548
Module libpipewire-module-adapter.so with build-id f39a5ad6685f5b3f5787e9f32176f4f9cff2eca7
Module libpipewire-module-client-node.so with build-id 48b1ebc279a38e295dd8b96507d6bd149d51000e
Module libpipewire-module-protocol-native.so with build-id be7cbc067d0a5555903bdec2e717b60bf6e3209d
Module libpipewire-module-rt.so with build-id 8af2194661e3f46a2c212faece1affa71fe6939a
Module libdbus-1.so.3 with build-id 6d6e4846c8e56903b4fe7d992ae6bb30c8a20a9c
Module libspa-dbus.so with build-id f87ba868d686a5723d86dc01298c58d328d1ed27
Module libgpg-error.so.0 with build-id 470d76ceb1e53cb017f78c08936e9bafaeb4058b
Module liblz4.so.1 with build-id 84ea95d811dad359e94e100ebe6a746294ffe8a7
Module libzstd.so.1 with build-id ab54c2881f53ab314e134f3e08c76d504376dd5d
Module liblzma.so.5 with build-id 8a7334fec02fef6a82ff641a68b3e3200a44a702
Module libgcrypt.so.20 with build-id 8bf3cb884124273640de797a3e77d86c98434ea4
Module libcap.so.2 with build-id 9b38b08de708f439a9d0a4f8b9914151bc8d4b50
Module libsystemd.so.0 with build-id 1c1489e575197ffbf417c79f926e572421f3692f
Module libspa-journal.so with build-id 3972bf709dbb8d8f9c949cc6445e307600f9110d
Module libspa-support.so with build-id cad133043b9ab839acce3b2d7721cc43000f6e59
Module ld-linux-x86-64.so.2 with build-id 22bd7a2c03d8cfc05ef7092bfae5932223189bc1
Module libgcc_s.so.1 with build-id 85db482c4585a328d95ec41124337a967bb24d8f
Module libc.so.6 with build-id 1e94beb079e278ac4f2c8bce1f53091548ea1584
Module libpipewire-0.3.so.0 with build-id a63cda269c614fb1308131cf9c33dedc0952101a
Module pipewire with build-id 00522760edc96aa45bae6b4a8f122ae149d99fee
Stack trace of thread 1829:
#0  0x00007f7e8a2a4be7 n/a (libspa-audioconvert.so + 0x42be7)
#1  0x00007f7e8a28d860 n/a (libspa-audioconvert.so + 0x2b860)
#2  0x00007f7e8a26e842 n/a (libspa-audioconvert.so + 0xc842)
#3  0x00007f7e8badc429 n/a (libpipewire-0.3.so.0 + 0x63429)
#4  0x00007f7e8badc8e7 n/a (libpipewire-0.3.so.0 + 0x638e7)
#5  0x00007f7e8bb83cc7 n/a (libspa-support.so + 0x6cc7)
#6  0x00007f7e8baba317 n/a (libpipewire-0.3.so.0 + 0x41317)
#7  0x00007f7e8b9188fd n/a (libc.so.6 + 0x868fd)
#8  0x00007f7e8b999c74 __clone (libc.so.6 + 0x107c74)

Stack trace of thread 1825:
#0  0x00007f7e8b99a096 epoll_wait (libc.so.6 + 0x108096)
#1  0x00007f7e8bb91669 n/a (libspa-support.so + 0x14669)
#2  0x00007f7e8bb83b7b n/a (libspa-support.so + 0x6b7b)
#3  0x00007f7e8bad9291 pw_main_loop_run (libpipewire-0.3.so.0 + 0x60291)
#4  0x00005564d3eda2ee n/a (pipewire + 0x12ee)
#5  0x00007f7e8b8b5290 n/a (libc.so.6 + 0x23290)
#6  0x00007f7e8b8b534a __libc_start_main (libc.so.6 + 0x2334a)
#7  0x00005564d3eda495 n/a (pipewire + 0x1495)
ELF object binary architecture: AMD x86-64

I have monitor issues with 6.08.1 and (before the update) 6.06. Only Dell P2423D is affected.
Overall I tested Kernel 6.xx.x with 9 different monitors and 1 beamer, and apart from this Dell monitor all worked fine.

Rollback to the latest LTS-Kernel fixed it.