[Stable Update] 2022-10-10 - Kernels, Octopi, Deepin, GlibC, Haskell, Python; Nvidia 520.56.06

qbittorrent works and timeshift also works great again with this update

I tried the CLI version again this morning and it worked. I will remember to add the comments variable.

Part of my Timeshift experiments on two different partitions of the 500gb USB drive:

One is formatted ext4 the other BTRFS. I seem to have better success using the BTRFS partion for creating snapshots. Not conclusive though.

I too am getting libre office docs opening up minimized… i need to right click and maximize them to see them

Update went great this time but the “primary monitor” selection is still broken for me since the previous (October 5) update. Going to take a dive in the Google machine this weekend to see if I can find a fix.

(I’m on Gnome)

Found a workaround, if anyone else needs it. Edited my ~/.config/monitors.xml to set the primary-monitor and logged out/in to apply the settings.

A bit more verbose but it does the trick for now.

Unfortunately GeForce 3080 support still broken in this update. Tested with kernels 6.0 and 5.15.72 LTS.

The following describes a hacky workaround, which hopefully will lead to another patch.

I’m in the same situation as you, I was using linux519-broadcom-wl with my BCM43228.

Two possible workarounds I could think of:
A. create a temporary package for linux60-broadcom-wl
B. try the alternative package broadcom-wl-dkms

I went with the second, thinking that if it just works, it would be easier. In hindsight option A might have been easier …

I’ll highlight the useful steps. The first two need internet access, but can be done on an older linux version.

1. install broadcom-wl-dkms


I used the GUI pamac, from dependencies it installed dkms and uninstalled linux519-broadcom-wl

No magic, and reboot showed still no wifi, so that’s not another step.

So what is dkms anyway? man dkms shows it has an install command, lets give it a whirl… after a few naive attempts I got:

[misha@delphin ~]$ sudo dkms install broadcom-wl/
Sign command: /usr/lib/modules/6.0.0-1-MANJARO/build/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub
Binary sign-file not found, module won't be signed
Creating symlink /var/lib/dkms/broadcom-wl/ -> /usr/src/broadcom-wl-
Error! Your kernel headers for kernel 6.0.0-1-MANJARO cannot be found at /usr/lib/modules/6.0.0-1-MANJARO/build or /usr/lib/modules/6.0.0-1-MANJARO/source.
Please install the linux-headers-6.0.0-1-MANJARO package or use the --kernelsourcedir option to tell DKMS where it's located.

Hooray for meaningful error messages … so lets give it what it wants.

2. install linux60-headers


Using pamac GUI again, yeah I know there’s a command line, I like GUIs haha.

Trying dkms install again …

[misha@delphin ~]$ sudo dkms install broadcom-wl/
Sign command: /usr/lib/modules/6.0.0-1-MANJARO/build/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub
applying patch 001-null-pointer-fix.patch...patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 2165 (offset 8 lines).

applying patch 002-rdtscl.patch...patching file src/shared/linux_osl.c

applying patch 003-linux47.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c

applying patch 004-linux48.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c
Hunk #1 succeeded at 2386 (offset -2 lines).
Hunk #2 succeeded at 2496 (offset -2 lines).
Hunk #3 succeeded at 2928 (offset 4 lines).

applying patch 005-debian-fix-kernel-warnings.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c

applying patch 006-linux411.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c
patching file src/wl/sys/wl_linux.c

applying patch 007-linux412.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c
Hunk #1 succeeded at 54 (offset 1 line).
Hunk #2 succeeded at 471 (offset 1 line).
Hunk #3 succeeded at 2396 with fuzz 1 (offset 27 lines).
Hunk #4 succeeded at 2424 with fuzz 2 (offset 34 lines).

applying patch 008-linux415.patch...patching file src/wl/sys/wl_linux.c

applying patch 010-linux56.patch...patching file src/shared/linux_osl.c
Hunk #1 succeeded at 946 (offset 4 lines).
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 586 (offset 4 lines).
Hunk #2 succeeded at 776 (offset 4 lines).
Hunk #3 succeeded at 3352 (offset 17 lines).

applying patch 011-linux59.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c
Hunk #1 succeeded at 38 with fuzz 2.
Hunk #2 succeeded at 444 (offset 8 lines).
patching file src/wl/sys/wl_iw.c
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 1647 (offset 4 lines).
Hunk #2 succeeded at 1668 (offset 4 lines).
Hunk #3 succeeded at 1681 (offset 4 lines).
patching file src/wl/sys/wl_linux.h
patching file src/wl/sys/wlc_pub.h

applying patch 012-linux517.patch...patching file src/wl/sys/wl_linux.c

applying patch 013-linux518.patch...patching file src/shared/linux_osl.c

Building module:
Cleaning build area...
make -j4 KERNELRELEASE=6.0.0-1-MANJARO -C /usr/lib/modules/6.0.0-1-MANJARO/build M=/var/lib/dkms/broadcom-wl/ exit status: 2)
Error! Bad return status for module build on kernel: 6.0.0-1-MANJARO (x86_64)
Consult /var/lib/dkms/broadcom-wl/ for more information.

Crash and burn! Oh well, what’s in make.log … a bunch of warnings and just one error:

/var/lib/dkms/broadcom-wl/ In function ‘wl_bss_roaming_done’:
/var/lib/dkms/broadcom-wl/ error: ‘struct cfg80211_roam_info’ has no member named ‘bss’
 2384 |                 .bss = bss,
      |                  ^~~
/var/lib/dkms/broadcom-wl/ error: initialization of ‘const u8 *’ {aka ‘const unsigned char *’} from incompatible pointer type ‘struct cfg80211_bss *’ [-Werror=incompatible-pointer-types]
 2384 |                 .bss = bss,
      |                        ^~~
/var/lib/dkms/broadcom-wl/ note: (near initialization for ‘roam_info.req_ie’)

Looks a bit yuck, but the important bit is struct cfg80211_roam_info’ has no member named ‘bss’.

With the pragmatic logic of “surely it won’t care if it doesn’t receive something it knows nothing about”, plus I’m not roaming across a mesh wifi network, I decided to delete the prickly part, aka. “Cutting out the BSS”.

I found that the bit of code is added by one of the patches in the package broadcom-wl-dkms.

3. edit broadcom-wl patch file


Edit the patch file /usr/src/broadcom-wl-

+       struct cfg80211_roam_info roam_info = {
+               /* .bss = bss, */   /* removed by Misha */
+               .req_ie = conn_info->req_ie,
+               .req_ie_len = conn_info->req_ie_len,
+               .resp_ie = conn_info->resp_ie,
+               .resp_ie_len = conn_info->resp_ie_len,
+       };

Now there’s a highly irresponsible patch on a patch! Ideally another separate patch will be added to the package instead, with a more thorough understanding behind it.

4. dkms install broadcom-wl


Here we go again, this time I’ll trim the output:

[misha@delphin ~]$ sudo dkms install broadcom-wl/
Building module:
Cleaning build area...
make -j4 KERNELRELEASE=6.0.0-1-MANJARO -C /usr/lib/modules/6.0.0-1-MANJARO/build M=/var/lib/dkms/broadcom-wl/
Signing module /var/lib/dkms/broadcom-wl/
Cleaning build area...

Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /usr/lib/modules/6.0.0-1-MANJARO/updates/dkms/

Much better. Still no wifi though. Some status …

[misha@delphin ~]$ dkms status broadcom-wl/
broadcom-wl/, 6.0.0-1-MANJARO, x86_64: installed

[misha@delphin ~]$ modinfo wl
filename:       /lib/modules/6.0.0-1-MANJARO/updates/dkms/wl.ko.zst
license:        MIXED/Proprietary
srcversion:     A381D4132F4C558B7BB6575
alias:          pci:v*d*sv*sd*bc02sc80i*
depends:        cfg80211
retpoline:      Y
name:           wl
vermagic:       6.0.0-1-MANJARO SMP preempt mod_unload 
... and other lines

5. modprobe wl

[misha@delphin ~]$ sudo modprobe wl

The wifi suddenly turned itself on, yay! And persisted over a reboot.

Caveat: this method will likely get undone by a new version of broadcom-wl-dkms.


Thanks for the detailed response, I really appreciate it and I’m glad to know I’m not the only one affected by that.
But since the ethernet port doesn’t work on this Laptop, I’d rather keep running Kernel 5.19 until linux60-broadcom-wl gets added (hopefully).

I don’t want to risk losing access to internet right now lol.

1 Like

I still haven’t got this update even though I still don’t see version 6.0 in the kernel manager. When I check manually with pamac it says my System is up to date. Is it possible I’ll get it later ?

Try: sudo pacman-mirrors --fasttrack && sudo pacman -Syu :wink:

1 Like

Thanks it did the job! Why did I have to do this ? Will I have to run this manually each time I want to update now ?

1 Like

Because you were using an outdated mirror.

No (if your currently chosen mirror syncs properly).


Some reading could be of interest, so scroll down to the bottom of this current page where it’s written “Support”…directly underneath that you’ll find “Wiki” and “Archived Forum”: they are literal mines of information - especially the latter which is a real treasure trove full of nuggets! :wink:

Update led to installation of “ceph” from AUR repos - the build of which was failing. uninstalled ceph and its dependencies and then update went smoothly.
Also pdfsam java dependency needs to be updated to the latest openjdk-jre-lts and not on openjdk-jre 11.

That’s currently available only as an AUR package. If you need to have some inputs regarding its dependencies, it’s better to direct any questions to its AUR maintainer or upstream.

Found a new issue after this update. When I close the lid of my laptop and re-open after a while. I appear to be logged out and have to log in again. A bit of a bummer that I need to re-open all my apps every time I close the lid of my laptop.


A post was split to a new topic: I noticed that I’m using an unsupported kernel

My ~/.local/share/kwalletd/kwallet.kwl file just disappeared after a reboot.
Was able to restore a backed up version.

Super annoying as all wifi passwords would have been gone if not for my backup.

A post was split to a new topic: Night Light isn’t working anymore

Using i3wm.

Before all windows just had a 3 pixel border, without the title bar.
After the update (this or the previous one, I’ve skipped the last one), some windows (not all) now have an unwanted title bar.

How to get back the previous behaviour, i.e. to force windows to not have a title bar?

EDIT: I think this might be the bug: `default_border pixel` doesn't hide title bars after upgrading to 4.21 · Issue #5149 · i3/i3 · GitHub

Just discovered that OBS 28.0.3 from the official repos is core dumping as well.

1 Like