[Stable Update] 2022-09-12 - Kernels, LibreOffice, KDE Gear, KDE Frameworks, Firefox, Thunderbird, Pipewire, Mesa

I am currently trying out alternative compression/decompression plugins in Dolphin. In example just tested the “7zip Service” and it does not open a new window (or tab). But not happy with it either, but that is a personal preference. So it seems to be a problem with the plugin itself.

After this update PulseAudio JACK Sink is no longer showing up as Audio Device.
Through JACK (Ardour), audio works normally, but audio is broken for anything outside of JACK (OS, browser, etc).

Booted with linux515 lts kernel and everything is back to normal, so expect this change should be the culprit:
linux518-rt 5.18.0_rt11-2 5.18.0_rt11-4

Installed & booted linux519-rt, PulseAudio JACK Sink works fine.
Seems to be isolated to 5.18.0_rt11-4

Thanks a lot -I wasn’t sure where to check to make sure at the moment of writing, so next time something like this happens, I’ll know to check /var/log/pacman.log .

Evidently not a universal problem; my own autostart is working as normal.
Though this may be because I have a single script which is run from autostart, that launches everything I want.
Perhaps if applying autostart to .desktop files is the problem, switching to a wrapper script might be a workaround?

1 Like

That’s not happening to me -some sort of QTile/Plasma conflict?

No. This is independent of Qtile. The issue is known and was plaguing many users last year. Qtile has nothing to do with it and can’t. It is just a window manager and does not interfere with the Dolphin plugin to extract or create archives. And it happens only with this one plugin in Dolphin, as I tried alternative archive plugins and they work fine.

This is a known issue that got solved and is back again.


I also got some issues with pipewire 0.3.57 downgraded all related packages back to 0.3.56.
When I start a video on youtube inside google-chrome I get those errors on mass after some minutes and sound is completely gone:

Sep 14 21:50:00 x1c7 pipewire[1676]: spa.alsa: hw:sofhdadsp: snd_pcm_avail after recover: Broken pipe

Seems to be already known upstream:

and it is also reported on arch forum:

An empty desktop environment and plasmashell using 100% of cpu.

Manjaro KDE with two panels. (one fixed on right, one autohide on left)
After update, found an empty desktop environment and plasmashell using 100% of cpu.
Wallpaper was present, but no icons. Outlines of panels, but no buttons or widgets.
Completely blank and not responsive to any clicks.
Various attempts at restarting kwin and plasmashell, clearing cache, logging off/on, rebooting etc… did not fix.
By using krunner, kupfer, and konsole, I kept the somewhat hobbled DE running in a regular use pattern until I had time to fix it.

My fix was to remove all plasmashell configuration files and restart.
Resulting in a vanilla plasma panel at the bottom.
+30mins~ to manually reconfigure.

I don’t know why, but my Thinkpad started not to boot after this upgrade. Once I typed the LUKS password, I got a black screen with a blinking cursor.
According to the journalctl:

Sep 14 22:54:01 rotor gnome-session-binary[1131]: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
Sep 14 22:54:01 rotor gnome-session-binary[1131]: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
Sep 14 22:54:01 rotor gnome-session-binary[1131]: Unrecoverable failure in required component org.gnome.Shell.desktop
Sep 14 22:54:01 rotor gdm-launch-environment][1081]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 14 22:54:01 rotor gdm-launch-environment][1154]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 14 22:54:01 rotor gdm-launch-environment][1191]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 14 22:54:01 rotor gdm-launch-environment][1242]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 14 22:54:01 rotor gdm-launch-environment][1293]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 14 22:54:01 rotor gdm-launch-environment][1317]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Sep 14 22:54:27 rotor kernel: watchdog: watchdog0: watchdog did not stop!

Once I removed the splash option from the grub config (and run update-grub) the problem was gone, so the issue is somehow around the display of the splash screen…

I did reboot, but thanks for the tip. :slight_smile:

I agree, I have six autostart entries, all of them working as before.

1 Like

With luck you won’t need it, but a tip for that sort of situation is to just remove ~/.config/plasma-org.kde.plasma.desktop-appletsrc before logging in (the desktop writes it dynamically so if you remove it while logged in it won’t help.

It may be that restoring that file from a recent backup could clean things up, if the problem was something just caused at the time of the update. Again, make sure you restore it while you’re logged out. Though this won’t help if for some reason one of your applets has become incompatible with the current Plasmashell (this happened to me a while ago when the webslice applet became broken and just made the whole desktop crash).


After the update, every time I restart my PC my default keyring disappears out of seahorse and gets replaced with kdewallet. To “Fix” it, I need to create a new dummy keyring, close seahorse, reopen seahorse and then ONLY the default keyring reappears. Hopefully someone finds a permanent fix for this.
The problem is that the kdewallet keyring doesnt work with apps like nordpass or minecraft so it’s pretty much useless for me.
I use Manjaro Plasma

you can disable kde wallet from system settings, and hopefully it helps

I have an autostart issue. One autostart entry works as usual - just starts Mullvad VPN automatically on login. The other is a bash script that launches three instances of Conky - that one does not autostart.

1 Like

Same issue here on my DELL XPS.
I had to boot in fallback and update grub. No issues after that.

1 Like

Update broke my polybar. I have no idea how, since I don’t think polybar updated :upside_down_face: I am using stable XFCE.

error: background_manager: Failed to copy slice of root pixmap (XCB_MATCH (8))
error: Fatal Error in eventloop: XCB_MATCH (8)
notice: Termination signal received, shutting down…
error: /usr/src/debug/polybar-3.6.3/src/components/eventloop.cpp:187: libuv error for ‘uv_loop_close(m_loop.get())’: resource busy or locked

I have problems with autostart too. I have said it before but I only get 2 answers if I remember correct that was telleing the same as us.

update borked my nvidia drivers somehow, main screen now stuck at 480p and is not recognized as before (it’s just identified as “NVIDIA”). Nvidia-utils is installed. Tried to re-install graphics drivers via “Hardware Configuration” system settings, got

error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-utils breaks dependency ‘nvidia-utils’ required by cuda
Error: pacman failed!
Error: script failed!"

One reboot fixed it, curious why rebooting the first time after the update apparently didn’t count. I still should have been able to re-install my drivers via the system settings though, that definitely seems like some bug in the script.

remove cuda first … and if you are not using cuda, dont install it again, its several gb big, so it just wastes your space…