[Stable Update] 2022-09-12 - Kernels, LibreOffice, KDE Gear, KDE Frameworks, Firefox, Thunderbird, Pipewire, Mesa

That is weird. I have Arch with 5.25 and I dont have issues. Maybe its the upgrade path itself?

I still do not get update notifications…

I solved my autostart problem by editing the bash script that starts Conky. I added a 30 second delay and it starts properly.

sleep 30
conky -q -c /home/user/.conkyrc-date-time &
conky -q -c /home/user/.conkyrc &
conky -q -c /home/user/.conkyrc-todo & exit

conky command has -p or --pause= option to add a time delay

so this command could be used instead of first two commands

conky -qp30 -c /home/user/.conkyrc-date-time &
conky -qp30 -c /home/user/.conkyrc-date-time

This command works fine when I type it in Konsole, but does not work from a bash file. I’ll stick to the sleep option since it works for me. Thanks!

I just found this cause and possible solution: (for autostart problems) https://www.reddit.com/r/archlinux/comments/ves6mh/comment/inf2mwq/

According to that, the reason for autostart stuff breaking is due to the change to use a systemd approach. That said, I think “Autostart” in the KDE system settings should still work as expected regardless of the underlying technology powering it.

The linked comment has a command to go back to the old behavior, but I haven’t tried it yet. I’ll be waiting a bit more.

EDIT: here is the solution in that reddit post:

kwriteconfig5 --file startkderc --group General --key systemdBoot false

and it did actually work for me, too.


yes, I can confirm the same. I made a reset default configuration as well

steam games broke for me this update. cant get any game to launch

I did notice that when I change the Wallpaper type to “Image” that it worked again.
I will keep KDE 5.25 and wait for future updates.

Thanks for your reply in this matter :slight_smile:

After the update every time I connect to my headset via Bluetooth, it automatically defaults to HSP/HFP for handsfree communication when I am in a meeting and using my mic, but when I am not in a meeting and I don’t want the handsfree profile I can’t change. I use pipewire with wireplumber.

Is anyone experiencing this or has an idea of how I can fix this?
So far the only way I’ve been able to fix this is by restarting the pipewire service each time.

I also have a problem with new plasma. When i use the hotcorner to show all desktops with all apps opened, it’s laggy as if i were using a 1960-s PC. Also everything on my panel became big and switching desctops with hotkeys became more smooth but that’s not an issue.

I tried removing my ~/.cache but it didnt change anyth (but my plasma launched as usual after removing it, unlike for ppl who couldnt launch it after removing).

Is it safe to downgrade plasma (no dependency issues or anything) and how to do it safely or should i wait for a new update?

1 Like

Thank you so much, it seerves to me. All correct :slight_smile:

KDE Autostarts were also not working in my system, but this Reddit thread’s solution made my ksuperkey and ibus-daemon work again

does this update contain the grub issue with fwsetup that requires grub-install?

After applying last updates, no access to the AUR repositories softwares. There is only Flatpack in third sources.

I am having the same issue. The “throbber” or activity indicator keeps going back and forth on my tabs. Were you able to resolve or find the source of this problem?

Everything ok and smooth here.
But, an interesting thing: something made me gain a notorious performance in-game, something like 10~20 FPS. In GTA Online, sometimes the peak of gain was 30 FPS. Using NVIDIA here. I don’t have any clue what made me gain that performance, but well, that’s good anyway.

I have not faced any major issues.

There’s one tiny issue I faced though. In KSysGuard, I had a custom view for the laptop’s fan speed plotted as a graph. For some reason this stopped working after the update, and I can’t find the equivalent setting anymore. It used to be set to lmsensors/dell_smm_isa-0000/fan1.

I’m using a Dell XPS 13 9360

From the change my VSCODIUM is broke
The only extension is not working and I keep getting a quite high usage of RAM (up to 8GB) just and only to open it

Before this version no issue at all

Cannot find any clue :frowning:

Top left hot corner got enabled after the update, but that’s not really an issue

Autostart entries in systemsettings5 on KDE doesn’t work anymore.

Created an shell script in ~/.local/bin, added it as login script in systemsettings5 to run all my applications after boot. First I tried to run the .desktop files with gtk-launch via shell script but that didn’t work either.

Audio devices created via LADSPA plugin are no longer visible via audio volume control symbol in system tray.

An option has been added to display virtual devices, which is disabled by default. :man_facepalming: