[Stable Update] 2022-09-12 - Kernels, LibreOffice, KDE Gear, KDE Frameworks, Firefox, Thunderbird, Pipewire, Mesa

You and every body else. After it was repeatedly said that KDE 5.25 isn’t ready for prime-time yet.


1.Does this also works with the GUI (Pamac) Updater? If not, can someone give advise what i had to adjust in Pamac to block this Plasma updates?

2.Could this blocking lead to additional bugs, when i update KDE Plasma in future?

Just curious about those reporting many (mainly unspecified) bugs with new Plasma - are you perhaps Wayland users?

So far, everything seems to be working smoothly. However, with Plasma I ran into a wee problem: The screen got locked during upgrade and I couldn’t log back in.
Easy solution:

  1. Wait long enough to be confident that the upgrade is complete.
  2. Drop into TTY using Ctrl + Alt + F2/F... and log in
  3. Reboot from TTY using systemctl reboot

In my case, at least (only the login manager had got stuck, everything else had gone well), this solved the problem.

I have the same feeling -no problems here on Plasma 25.5 using X11.

1 Like

after latest Thunderbird update, my mail account doesn’t load (IMAP)
Liberomail account

That is not true. It’s perfectly fine to use 5.18 for now.

The complete package changelist (https://gitlab.manjaro.org/-/snippets/792/raw/) tells this update contains an update for 5.18.

The next update won’t have a new update for 5.18.

  1. Yes, since pamac “works atop of pacman”.
  2. Depends for how long you ignore the group.
    With this change, you prevent installing plasma’s main packages and packages depending on them. Unless you’re using a package which has an obscure dependency on plasma’s main packages, you’ll be fine. However I won’t guarantee that for a (half)year. Please note other packages depending soley on Qt without using additional plasma libraries will work fine.

Is there any way to check, just too make sure I’m not forgetting anything?

After this update, chromium fails to cast to chromecast (keep getting a “disconnected - try to cast again” message on TV).

Casting works on google-chrome-stable however …

EDIT: downgrading chromium (in my case to -104.0.5112.79-1) fixed it.

IDNK to do it the gui-way because I upgrade manjaro from a plain tty without begin logged in any gui nor DE.

AFAIK you could do pamac checkupdates | less to figure out what’s getting updated.
I would expect pamac-gui would also show a dialogue what’s getting updated and whatnot with the ability to not proceed when the user spots something odd.

I have reverted back after this update.
I am on Plasma. I was glad 5.25 was kept back until the 5.25.5 as 5.24.6 was LTS and more or less usable for me.
I upgraded today and very soon hit the first bug. If you have global menu and you try to add a widget to the desktop or any of the panels , kwin freezes and crashes. The same happened on 2 of my computers.
I could reproduce this crash on my Endeavour KDE install as well, but on Arch / EOS it’s solved by an update (kwin and or plasma-workspace maybe ?)
Found this reported by others too:

I installed a testsystem with stable and switched to unstable. The latest package of plasma-workspace fixes the problem with global menu.
So I really think holding back updates could be sometimes a bad idea.
If you release a stable version 1 day after the testing one, how much did you test really ? I guess not too much. This package should have been here in this stable one.
Please add this to the know issues.
Thank you

i downgraded the pipewire package - only this one - and the errors are gone, together with some minor sound issues …

sudo DOWNGRADE_FROM_ALA=1 downgrade pipewire 

Do not be mislead by this stable update having a “newer” 5.18 than the stable update before.

Kernel 5.18 went EOL quite some time ago (2022-08-21), see https://kernel.org/.
It hasn’t had any (security) updates since - it’s certainly not “perfectly fine” to use any longer.

Great advice on forum, where there is typically at least one user per week asking for help, because he can’t be bothered to keep up with kernels and can’t update because some “perfectly fine to use” 16 months old kernel is causing dependency issues.


I use a script which detects EOL Kernels and run it automatically after updating my system. It told me that 5.18 is out of date. I recommend anyone to pay attention to the blog posts or use some kind of notification. Because I use Qtile, the notification from Manjaro does not work for me, so I wrote the script. Here for anyone interested into it: Check if one of the current installed Linux kernels has reached EOL · GitHub (and forum post)


Probably. I would actually look through to make sure you either find alternatives for them in the repositories or really just check whether you need them. Having a bunch of random AUR packages that you did not intentionally install is a recipe for problems in Manjaro

I know yours was just a rant, but just like you are asking to keep plasma at 5.24, a lot of people on this forum were asking for 5.25. ultimately it boils down to the fact that Manjaro is generally speaking, a rolling distro that moves to the latest versions of packages. Some packages might be held for a bit, but ultimately the update will happen.

For what it’s worth, I’m not saying you’re wrong or unjustified. I also do think a feature freeze for two versions of plasma would be great. I’m simply explaining that there is another crowd that really wanted the update

1 Like

I do it from a terminal myself, but am to cautious to update right now, due to Plasma. But I think I’ll be OK for now, but I’m still gathering intel…I learned a long time ago not to blindly do updates.

1 Like

Nope X11