[Stable Update] 2022-09-12 - Kernels, LibreOffice, KDE Gear, KDE Frameworks, Firefox, Thunderbird, Pipewire, Mesa

Didn’t help), 5.19 behaves the same as 5.15, NVidia 390 driver, m820 graphics card

Well that is a major bummer. :frowning:

Let’s wait, I think it will improve over time), the 5.19 kernel is somehow faster or something, I’ll test it, until I see any problems with it (well, except for these, of course)

1 Like

After increasing the Virtual RAM to 4 Gig, the upgrade of XFCE in a Virtual Box VM went as smooth as butter.

It caused the Host to crash, requiring a hard shutdown, with 2 Gig of RAM, even though the initial update after install worked perfectly, with only 2 Gig.

I’ve not noticed any issues, other than it failed to reboot, after the upgrade was complete, and I had to shut it down from the VM Manager.

Hello. I upgraded my computer recently and after that, it doesn’t resume after suspend. Just a black screen and it doesn’t respond. I have tried several kernel versions because I updated it, but no luck.

Any idea of what causes this?
Thanks

If you don’t mind, open a thread in the support section and post the details of your computer through the output of sudo journalctl -p3 -xb and inxi -Fazyv7

2 Likes

Hello, have you tried to rollback with timeshift? If everything is configured correctly for you, snapshots are created automatically before updating.

1 Like

Firefox 104.0.2

Version 105.0, first offered to Release channel users on September 20, 2022

We need to get the latest versions of browsers as soon as possible for security reasons.

2 Likes

I agree.

I was going to wait and see what happened after 104 took so long.

For most people the Browser is where they operate, so staying up to date is really important.

Three “high impact” vulnerabilities on list:

1 Like

I also have this mentioned standby issue, but I don’t even use standby mode intentionally, it just does that now when I want it to shut down and close the lid. Shutting down with open lid works and closing the lid with a regularly running system works (AKA: does nothing with my settings), but if I combine both, it goes into standby instead. This did not happen before. Would this also be fixed with the 5.19 kernel? I would prefer to stay on LTS, because updating graphics drivers etc. every time and checking if everything still works is a hassle.

I just want mention something. While I don’t use a laptop, but a big stationary PC and make use of the standby mode manually with a keyboard shortcut. I never had a problem with waking up or going into standby mode. So that in itself is not faulty, but maybe something that is specific to laptops. I am on Kernel 5.19 and didn’t have any problem with it prior versions either.

I know we should not post here just saying it works. But I think this little information can help in understanding the issue. Did anyone have a standby issue on a PC?

is it i just got used to the laggy new plasma or has it became a bit less laggy? anyway im waiting for the stable update for it

Bad news, but:

1 Like

I want to mention something to try for getting KDE to resume from sleep mode using the 5.19 kernel or any of the newer kernels for that matter.

Go to Energy saving in settings. Go to the Buttons event handling. Under that where it says

“When power button pressed” select Prompt log out dialog.

See if your system likes that,

I found that, It crashes only when there is Application Menu Bar

Thanks, I found that It crashes only when there is Application Menu Bar, Now I anderstand.

1 Like

For the KDE folks who are having issues, maybe it helps:

I upgraded and KDE was totally broken to unusable, reverted using timeshift, then I found something on a reddit post something about adding XDG_CURRENT_DESKTOP=KDE to /etc/environment and also removing ~/.cache folder.

I did only these 2 things and upgraded again, and seems to work, but I can’t confirm if both are needed or not.

4 Likes

I have a issue with h265 playback since the update.
There are now green and purple artifacts from the beginning of playback, starting out in the top left corner.

I have the same effect on four different installations with a different age. The last one installed 16.09.2022 with the latest ISO from that day.
I tried several different .mkv files on VLC and Kodi.
All installations use KDE.

.mkv files using the h264 codec have no issue.

Not sure if there is anything I could test.
Does someone else have this issue too?

I had no heavy issues so far, only with the KDE wallpaper plugin “Inactive Blur”, which I initially pulled from KDE store, but updated manually from its git repo.

The other greater issue was the package libgovirt, which I needed to revert to 0.3.8-1. This was because of virt-viewer crashed (I am disallowed to include a big ticket link here).

I am no user of Wayland so far, because X11 does what it should: It simply works. I recently tried Wayland, and it almost immediately crashed after login. I don’t know about the cause, maybe my user profile is very special. Yes, KDE has flaws. But Gnome or XFCE is not better at all.