[Stable Update] 2022-05-13 - Kernels, Mesa, Nvidia, Gnome 42, PipeWire, LIbreOffice, KDE Gear & Frameworks, Virtualbox, Qemu 7.0

Regarding Firefox, try to clear the cache completely. With me it improved the situation

Unfortunately this is not true.
Firefox crashed my system again, forcing me to do a brute force reboot.
This was the situation at the time of the blockade.

2 Likes

Thank you!

Can confirm, I have the same issue since the update. Hope to see 5.15.39 asap if it is indeed fixed there.

I’m trying to replicate this behavior but failing to do so. There is no key screenshot in my settings. The settings window does not crash with this error.

Resetting the configuration via dconf could be a option, see manpage of dconf But this seems like the same as deleting ~/.config/dconf/user witch you tried and had no result. Maybe someone more knowledgeable about gnome settings can explain.

Does disabling all extensions, logging out and in solve this?

If you want, you can switch to 5.17.6 this haven’t this bug.

1 Like

Yeah, I might just do that. I hate the idea of shutting down my computer :o
Thanks

I had that issue too. Will uninstall!!! Thanks.

It looks like manjaro-gnome-settings replaced manjaro-gnome-assets.
$ pamac info manjaro-gnome-settings                                
Name                  : manjaro-gnome-settings
Version               : 20220423-2
Description           : Manjaro Linux Gnome settings
URL                   : https://gitlab.manjaro.org/profiles-and-settings/manjaro
                        gnome-settings
Licenses              : GPL
Repository            : community
Installed Size        : 13.1 MB
Groups                : --
Depends On            : adw-gtk-theme gnome-wallpapers manjaro-base-skel
                        manjaro-gdm-branding qgnomeplatform qgnomeplatform-qt6
                        ttf-hack xcursor-breeze
Optional Dependencies : lighter-gnome: disable some gnome-settings-daemon components
                        papirus-icon-theme: default icon set [Installed]
                        manjaro-wallpapers-18.0 [Installed]
                        illyria-wallpaper [Installed]
Required By           : manjaro-gnome-extension-settings
Optional For          : --
Provides              : manjaro-desktop-settings
Replaces              : manjaro-gnome-settings-gnome-next manjaro-gnome-assets
Conflicts With        : manjaro-gnome-settings-gnome-next
                        manjaro-gnome-settings-19.0 manjaro-gnome-assets
                        manjaro-gdm-theme
Packager              : Mark Wagie <mark@manjaro.org>
Build Date            : Sat 23 Apr 2022 11:53:43 AM PDT
Install Date          : Fri 13 May 2022 08:15:23 AM PDT
Install Reason        : Installed as a dependency for another package
Validated By          : Signature
Backup files          : --

Found it! @Hanzel was write, all hail Hanzel! If you turn off «User Themes» in Extension it works no problem. Actually I had a not so serious related problem already on he previous update.

Happened for me as well.
Uneventful update, kernel 5.17 seems faster, I think.
The only issue is the font.

Both deleting ~/.config/dconf/user then logout and log back in, and running dconf reset -f / then logout and log back in did not work. I still got the same crash and the same error message.

I just tried that with all extensions disabled, then logout and logged back in, still the same. :frowning: Kinda lost, not sure what else to do.

Before resetting dconf, all my custom keyboard shortcuts worked EXCEPT the ones for taking screenshots (strange!). After resetting dconf, taking screenshots with Print Screen works just fine. However, the same crash persists, with the same error.

I build picodrive which includes GL/EGL from libglvnd /usr/include/EGL/egl.h and /user/include/GL/gl.h.

Used to work fine before the update now I get this error message on program run eglSwapBuffers 300d which appears to be related to this.

Recent update breaks EGL/Mesa drawing surfaces? Not sure where or how to proceed with this problem.

Thank you for the update guys.

All works fine, just I see this error whenever I open a console:
manpath: can't set the locale; make sure $LC_* and $LANG are correct

Console works fine as far as I can see so not bothered too much just wanted to let you know.

Thanks a lot, Manjaro team! Everything works perfectly, except the Night Light. Does anyone have any idea how to fix this problem? :blush: :slightly_smiling_face:

Options to try and see if this changes the situation.

  • Partial update: The settings are not in sync whit the settings that control center expect. (check mirror and update)
  • change to X11 or Wayland session depending on the session you use now

If nothing solves this issue make a new post in #support with details it seems specific to your situation.

1 Like

UPDATE:
I don’t know why (i did not change anything, just runing the update and removed ophaned packages with pamac)… but the freeze-ups and crashes on reboot/shutdown are gone! :smiley:


I’m currently experiencing several freeze-ups and issues after the update and i’m forced to use magic keys to get it out of it.

After the first reboot i got a grey screen with only the mouse pointer show up and nothing else starting up. I tried Ctl-Alt-F2 to switch to tty which shows only a blinking Curosor but does not work, so I do a reisub.
Second start up look fine, but crahed after I used a MXLinux in a virtual machine (kvm/qemu) for an hour or so (Black screen, Magic key the only way out)
Got the libkipi issue too, but after the second try updating it in pamac and choosing ‘trust him’ it installs.

Since then it seams to start and run fine, but hangs on every shutdown/reboot and tty still dont work.
I not enough into to it to know why.

I’m experiencing freeze-ups. Having pinpointed it hett, first I thought it was latte-dock fault.

I’m using kwin_x11 on latest Nvidia, driving 2-3 displays (at 4K)

I’m not sure what’s going on

1 Like

There’s already a merge request for timeshift with a fix: https://github.com/teejee2008/timeshift/pull/904

Here’s a workaround that works for me:

  • temporarily disable the schedules in the timeshift settings (until a fixed version is available)
  • create the backups manually by running this command in the terminal:
sudo LC_ALL=C.UTF-8 timeshift --create

timeshift uses rsync to do the actual work and parses rsync’s output. It seems that the latest version of rsync now takes care of the locale (region) settings, thus its output has changed on many systems and timeshift is unable to parse it any more. Running the command with the LC_ALL environment variable set to C.UTF-8 overrides the locale settings and forces the command to use the default “C locale” instead.

3 Likes

Implemented with 21.09.1-4.

4 Likes