[Stable Update] 2022-05-13 - Kernels, Mesa, Nvidia, Gnome 42, PipeWire, LIbreOffice, KDE Gear & Frameworks, Virtualbox, Qemu 7.0

I can confirm that. My keyboard (directly connected with a cable) doesn’t work with kernel 5.17, works fine with 5.16 though.

Just attempted the update and got an unusual package conflict. Upgrades normally happen for me without any hitches.

Synchronizing package databases...
Checking electron9 dependencies...
Checking tuxedo-keyboard dependencies...
Warning: python-pyqt5: local (5.15.6-7.1) is newer than extra (5.15.6-7)
Resolving dependencies...
Checking inter-conflicts...
Error: unresolvable package conflicts detected
Error: Failed to prepare transaction:
conflicting dependencies:
- tuxedo-keyboard-dkms and tuxedo-keyboard are in conflict

Update halts after that. Any help would be appreciated.

Downgrade to 5.15.6-7, 5.15.6-7.1 had issues and no longer exists:

sudo pacman -Syu python-pyqt5

Install tuxedo-keyboard-dkms, it replaced the tuxedo-keyboard package.

1 Like

Hello, I found dav1d is updated from 0.9.2-1 to 1.0.0-1, and ffmpeg4.4 from 4.4.1-4 to 4.4.1-5. The update of dav1d provide libdav1d.so.6 instead of libdav1d.so.5, which broke much other software (as far as I know, electron (all version) and python-pyqt5-webengine). Reverting these two package works on my machine. Is this a wrong pull from upstream?

I have manjaro gnome installed on both my laptop and work desktop (I work from home).

I first applied the 1.9 gb of updates to my laptop last night.

I am really liking the simpler gnome console, I was annoyed that I could not silence the tab complete bell in bash as there are no preferences like terminal, but there is a ~/.inputrc fix for that.

The only other issue I had was vagrant, and a vagrant plugin update fixed that.

Otherwise flawless and my work desktop is getting updated as I type this :slight_smile:

Impressive work guys

No, you’re in a partial upgrade state. Make sure your mirrors are up to date.

❯ ldd /usr/lib/electron/electron | grep libdav1d
	libdav1d.so.6 => /usr/lib/libdav1d.so.6 (0x00007fbf63452000)

Steam is acting funky when running from “favorites” in dash to dock. Earlier when I had it open it didn’t have the white dot next to the icon like the other open apps did while it was open. Even so, it remained open and when I’d click the shortcut in dash to dock it would return Steam to the store page. I removed the icon from favorites and closed Steam and opened it with “Steam (Native)” and it worked fine, added to favorites, closed and opened it to test a few times. Seemed to work fine. I left my computer and went to work. When I got back and opened Steam every page was nothing but black screen. I closed it and opened it again and the same thing. Then I reset the “favorites” icon like before and it worked when I opened it with “Steam (Native)”. No idea what is going on

Well, it seemed to be a smooth update but…
It took more than 3 minutes to reboot.
Can’t run many apps by clicking them.
My laptop started to sound for no reason. It sounds like when you render a 3D scene and the machine works really hard. The sound goes away for few seconds and then starts again. Have no idea how to stop it.

I had an issue after updating and before restarting, using Firefox for some minutes shut down my GUI. I had to restart and the problem is apparently gone. Not sure if this was cause by the update or because I was using a back-up kernel at that moment

Another issue I’ve encountered with the latest Gnome updates is that I can’t set custom keyboard shortcuts anymore in Settings → Keyboard → under “Keyboard Shortcuts” → “View and Customize Shortcuts”. It always crashes the moment I clicked on it.

If launched via the terminal, it crashes with:

(gnome-control-center:16886): GLib-GIO-ERROR **: 15:15:41.463: Settings schema 'org.gnome.settings-daemon.plugins.media-keys' does not contain a key named 'screenshot'
fish: Job 1, 'gnome-control-center' terminated by signal SIGTRAP (Trace or breakpoint trap)

It still crashes even after I deleted ~/.config/dconf/user then logout and log back in again.

1 Like

After the update, the Manjaro Branding Setting has been deactivated and the GDM do not use the Manjaro colors anymore. I can’t turn it back on through the Layouts Switcher, it gives me this error :

Failed to prepare transaction
target not found: manjaro-gnome-assets

I tried to reinstall the manjaro-gnome-assets package, however no package “manjaro-gnome-assets” was found. It doesn’t exist anymore?

It’s the same in GNOME 42.
For Example:


1 Like

It does not exist anymore.


I’m having an issue with the coloring of the global menu which was introduced with Plasma 5.24.5. This bug has already been reported (https://bugs.kde.org/show_bug.cgi?id=453348) and should be fixed in Plasma 5.24.6.

strange one of the pcs does not even support vulkan.

I am having a very similar issue. In my case, clicking on “Change Background” sends me to the settings Appearance section, which is literally empty.
I tried changing the appearance through Gnome Tweaks, but the changes aren’t reflected either.

Bluetooth doesn’t start on login screen after reboot.

I tried applying AutoEnable=true in /etc/bluetooth/main.conf . It did not work.
Neither did this snap Install bluetooth-autostart on Manjaro Linux using the Snap Store | Snapcraft

Also have an issue with qBittorrent not showing in the notification area, which might be related to this; Cannot enable "Show qbittorrent in notification area" in 4.4.0 in GNOME 41 · Issue #16015 · qbittorrent/qBittorrent · GitHub

A post was split to a new topic: Stremio has an error when it launches the stream server


$ gsettings set org.gnome.desktop.interface color-scheme default

I can set background from Settings again. Changing Appearance in Tweaks also works.

However I still have no idea how to fix keyboard shortcuts.

1 Like

I was playing portal 2 before installing the update, everything was fine I had not issues.

I then installed the update, restarted and then I started having issues with stuttering with the aiming. The issue is that I did not have this issue before the update.I don’t know if the update changed something to cause this issue. I’m not sure how to diagnose what went wrong, it seems as if the update caused this issue.