[Stable Update] 2022-03-14 - Kernels, KDE, LibreOffice, Kodi, Qt5, Mozilla, NetworkManager, Pipewire

Downgrading hplip to previous version via downgrade fixes the scanning issue on HP devices connected on the network via hpaio:

the NetworkManager update broke my WiFi connection.
downgrading NetworkManager to fixed it.

1 Like

I had only one problem regarding the upgrade, wine7.3 staging to wine7.4 staging. I play overwatch via Lutris with the wine staging version. After the update the game didn’t register my (usb) keyboard. So it wouldn’t register my keys that I pushed.

The solution for me was to downgrade to wine7.3 staging and it can register the keys that I pressed again. Anyone else had a similar problem?

Just upgrade to newest update. SpeedCrunch and qpdfview are no longer working.
Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3) Aborted (core dumped)
Followed sudo pacman-mirrors -f 5 && sudo pacman -Syyu
Got no help.

See second post for troubleshooting that issue.

No. 21.2.5 is. As always we may need to test the ISOs before we announce them or change download links at our official download page …

1 Like

Update went through smoothly, although I ran into a problem with WINE and Proton, couldn’t launch any of them (not even winecfg).

If you have the same problem, disable MANGOHUD for now by running command like so:

MANGOHUD=0 command

Same goes for Steam Proton games. Native ones seem to be largely unaffected.
More info in MangoHud Git issue

Do you also have games via wine and have keyboard issues? On my side, I only have overwatch via wine and with wine7.4 it does not register any key input from my keyboard, although my mouse works, but not my keyboard. With wine7.3 it works fine.

1 Like

Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3) issue with all Qt programs I use (LyX, virtualbox, manjaro-settings-manager and maybe some other, too).

Neither forcing mirror update (as suggested in the second post of this thread) nor (re)installing all qt5 packages (as suggested in the other thread (to which I can’t link)) helps. I have no Qt related AUR packages installed, so I have nothing to rebuild.

I am on Manjaro i3 community edition if that matters.

Yes. Some programs (mandelbulb3d, custom translators) don’t work for me with wine 7.4 (they won’t even start) but they work with wine-staging 7.3

i dont think a change is required, because for me not changing this resulted in no problems

This recent Manjaro Stable update broke the Shiboken2 and Pyside2 libraries. Shiboken2 is still at but Pyside2 has already been upgraded to 5.15.3. This causes a downstream error for FreeCAD as documented here Freecad Doesn't start by a symbol lookup error - FreeCAD Forum and here Build error about setDestroyQApplication - FreeCAD Forum.

How to fix this library mismatch?

I’m experiencing the same issue. Is there a known fix?

Specifically I am getting this:

could not satisfy dependencies:
- removing lib32-expat breaks dependency 'lib32-expat' required by lib32-fontconfig
- removing lib32-libjpeg-turbo breaks dependency 'lib32-libjpeg' required by lib32-gdk-pixbuf2
- removing lib32-libjpeg-turbo breaks dependency 'lib32-libjpeg-turbo' required by lib32-imlib2
- removing lib32-libjpeg-turbo breaks dependency 'libjpeg.so=8-32' required by lib32-libtiff

Update: I needed to update my mirrors. It’s working now.

Have you rebooted after updating?

Yes. Couple of times since the update.

Just checking: do you claim this from memory? Or have you checked?
qt5-styleplugins has actually been in the repositories until not long ago.

Yes, I did claim that from memory. I was sure that I haven’t installed any packages from the AUR. As I tend to avoid it.

Thanks for help!

Since the last update i’m struggeling with my bluetooth. with the last update even the bluetooth mouse was broken. going trough all tutorials here, at the arch-forum and the internet but nothing was succesful. the graphical blueman is one issue, it’s breaking everything but even with the bluetoothctl-cli i wasn’t able to get anything run. the last option was to downgrade kernel 5.16 to 5.10 LTS. after downgrading i was able to get the mouse running again and now i’m challenging with the bluetooth-keyboards. this seems to be a wide problem now because i’m not the only one struggeling with bluetooth-keyboards.
bluetooth keeps on to be an unsolved problem with the os.

edit: even this worked only temporarily. I’m done but with all these issues it’s no longer worth to me for spending time in it. This combination of packages of manjaro are too faulty for me.
I’ve spend too much time in the last week to get it working i should have done better things. time to round up.

1 Like

I got the following error when updating the system.

error: failed to commit transaction (conflicting files)
deepin-session-shell: /etc/lightdm/deepin/qt-theme.ini exists in filesystem

What should I do? Delete this file?

After update, the system didn’t boot anymore. This was caused by new systemd. I had the service systemd-networkd-wait-online enabled, because of issues when mounting network drives. Disabling the service solved the problem. I will see if the mounting issues will occur again. Currently, all is running fine.