[Stable Update] 2022-02-27 - Kernels, Mesa 21.3.7, Plasma 5.24.2, Frameworks 5.91, Pipewire 0.3.47, Toolchain, Gstreamer 1.20, Nvidia 510.54

I got caught by the update in the middle of a simple update…hope nothing breaks. :exploding_head:

“Good news, everyone!” (Professor Hubert J. Farnsworth’s)

Since I was working on something I didn’t want to restart the PC until today Sunday to have time to reinstall just in case. My PC started without any visible or perceivable problems.

Kudos! Manjaro’s Team.


We haven’t heard from @MrE in over an hour! Send a scout down the hole and lay off of pamac until we know more about the situation.


Well, I have done it with tty. So far, so good.
Intel ivy-bridge, igpu, xfce, linux516.

Some mentioned problems are already fixed :

  • KDE Plasma shows visual graphical errors
  • KDE Window Decorations UI with Drag&Drop broken
  • No search results in application launcher when using multiple kickoff instances
1 Like

Using pamac-manager for the update, I had an error that since pamac was unable to update /etc/dunst/dunstrc, the update would not be committed. I am running i3 on an Intel Celeron-based dual-boot PC.

Fixed it by uninstalling dunstify, which then is not available anymore to install. Probably should be automated.

Hope that helps.



4 posts were split to a new topic: Amarok 2.9.71-1 error when start. org.freedesktop.dbus.error.serviceunknown

Mesa got updated to 21.3.6

Mesa is now at 21.3.7

The first mention is redundant, Stable now has 21.3.7-1.
Thanks for another Stable update.

Thanks for the new updates. Especially for KDE plasma 5.24.2. :wink:
I was thinking we will have to wait until KDE plasma 5.24.3 to be in the stable branch.

I want to tell you that I tested Kde plasma 5.24.2 with the testing branch the previous days. I checked the problem that we had with the user’s avatar picture in the previous Kde plasma 5.23.5. Now, with kde plasma 5.24.2, changing the avatar picture is good through KDE settings but the system always display an error message (An error has occurred) after requesting my administrator password. Can you check it and perhaps report it to the KDE developers ?



5 posts were split to a new topic: Issues rebuilding audacious and deadbeef

I had a similar issue, a conflict involving dunstify (sorry, it’s in French):

Analyse des conflits entre fichiers...
La validation de la transaction a échoué:
conflit de fichiers :
- dunst : /usr/bin/dunstify existe déjà dans le système de fichiers (appartient à dunstify)

and couldn’t simply uninstall dunstify, since it is required by many other packages installed on my system.

bluetooth-keyboards get recognized and connected but they are without function. i tried 3 keyboards, it’s the same behaviour at all three of them. bluetooth-mice still works.

I have some icky locale issues after updating. Updated with pamac from TTY. This for example results in gnome-terminal failing to run with error:

# Locale not supported by C library.
#            Using the fallback 'C' locale.
# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

[Edit: fixed my problems. Used Manjaro Settings Manager to use the Locale Settings. They were empty as suspected. Set everything back the way it used to be. Saved. Regenerated initial ramdisk images with sudo mkinitcpio -P. No more errors. Everything back to normal.]

[Edit 2: updated a couple of other PCs also running Manjaro Stable/Cinnamon DE: no issues with those updates.]

Logs from problem below.

Corresponding errors in the pacman.log when generating the initial ramdisk image:
[2022-02-27T13:21:10+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux516.preset: 'default'
[2022-02-27T13:21:10+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-5.16-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.16-x86_64.img
[2022-02-27T13:21:10+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.16.11-2-MANJARO
[2022-02-27T13:21:10+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-02-27T13:21:10+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-02-27T13:21:10+0100] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2022-02-27T13:21:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2022-02-27T13:21:11+0100] [ALPM-SCRIPTLET] /etc/locale.conf: line 2: warning: setlocale: LC_MESSAGES: cannot change locale (en_US.UTF-8): No such file or directory
[2022-02-27T13:21:11+0100] [ALPM-SCRIPTLET] /etc/locale.conf: line 7: warning: setlocale: LC_TIME: cannot change locale (nl_NL.UTF-8): No such file or directory
[2022-02-27T13:21:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-02-27T13:21:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-02-27T13:21:11+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2022-02-27T13:21:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [encrypt]
[2022-02-27T13:21:12+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qat_4xxx
[2022-02-27T13:21:13+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-02-27T13:21:13+0100] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2022-02-27T13:21:13+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-02-27T13:21:13+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-02-27T13:21:15+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-02-27T13:21:15+0100] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-5.16-x86_64.img
[2022-02-27T13:21:15+0100] [ALPM-SCRIPTLET] bsdtar: Failed to set default locale
[2022-02-27T13:21:15+0100] [ALPM-SCRIPTLET] bsdtar: Failed to set default locale
[2022-02-27T13:21:20+0100] [ALPM-SCRIPTLET] ==> Image generation successful
$ inxi -Fzxc0
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_ADDRESS = "nl_NL.UTF-8",
	LC_PAPER = "nl_NL.UTF-8",
	LC_TIME = "nl_NL.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
  Kernel: 5.16.11-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: Cinnamon 5.2.7 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Dell product: Inspiron 660 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0XR1GT v: A00 serial: <superuser required> UEFI: Dell
    v: A13 date: 05/22/2018
  Info: quad core model: Intel Core i5-2320 bits: 64 type: MCP
    arch: Sandy Bridge rev: 7 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 1638 high: 1676 min/max: 1600/3300 cores: 1: 1603
    2: 1676 3: 1621 4: 1652 bogomips: 23961
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0
  Device-2: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 01:00.0
  Display: x11 server: X.Org v: driver: X:
    loaded: amdgpu,ati,modesetting gpu: amdgpu resolution: 1: 1920x1200~60Hz
    2: 1440x900~60Hz
  OpenGL: renderer: AMD Radeon RX 580 Series (POLARIS10 DRM 3.44.0
    5.16.11-2-MANJARO LLVM 13.0.1)
    v: 4.6 Mesa 21.3.7 direct render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.16.11-2-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.47 running: no
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Dell
    driver: ath9k v: kernel bus-ID: 03:00.0
  IF: wlp3s0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel port: d000 bus-ID: 04:00.0
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: ASUSTek Broadcom BCM20702A0 Bluetooth type: USB driver: btusb
    v: 0.8 bus-ID: 1-1.1:3
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Local Storage: total: 763.85 GiB used: 554.04 GiB (72.5%)
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
  ID-2: /dev/sdb vendor: Western Digital model: WD3200AAJS-56M0A0
    size: 298.09 GiB
  ID-1: / size: 456.95 GiB used: 368.62 GiB (80.7%) fs: ext4 dev: /dev/dm-0
    mapped: cryptroot
  ID-2: /boot size: 511 MiB used: 303 MiB (59.3%) fs: vfat dev: /dev/sda1
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) file: /swapfile
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: amdgpu temp: 54.0 C
  Fan Speeds (RPM): cpu: 511 mobo: 1169 gpu: amdgpu fan: 1159
  Processes: 259 Uptime: 25m Memory: 15.5 GiB used: 2.71 GiB (17.5%)
  Init: systemd Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1591
  Shell: Bash v: 5.1.16 inxi: 3.3.13

…look for /etc/locale.gen.pacnew .

I used pacdiff to check for .pacnew files after updating. There was nothing new.
/etc/locale.conf and /etc/locale.gen are back to normal (at least) after I used the Locale Settings in the Manjaro Settings Manager. No idea what happened. I am going to it a try on another PC now.

Intel AX200 Bluetooth is still broken after this update also. (WIFI part works (tested), but don’t care and not using it, as it’s desktop computer)


from inxi:
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 8087:0029
           class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: N/A

    ~  blueman-manager                                                                                ✔ 
blueman-manager 22.20.43 ERROR    Manager:137 on_dbus_name_appeared: Default adapter not found, trying first available.
blueman-manager 22.20.43 ERROR    Manager:141 on_dbus_name_appeared: No adapter(s) found, exiting
    ~  blueman-adapters                                                                               ✔ 
blueman-adapters 22.31.26 ERROR    Adapter:54 __init__  : No adapter(s) found
    ~  bluetoothctl list                                                                              ✔ 
    ~  bluetoothctl show                                                                              ✔ 
No default controller available
    ~  dmesg | grep -iE '(btusb|iwl|blue|ax200|wifi)'                                                                                                ✔ 
[    2.335287] Intel(R) Wireless WiFi driver for Linux
[    2.335330] iwlwifi 0000:27:00.0: enabling device (0000 -> 0002)
[    2.341470] iwlwifi 0000:27:00.0: api flags index 2 larger than supported by driver
[    2.341488] iwlwifi 0000:27:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version:
[    2.341731] iwlwifi 0000:27:00.0: loaded firmware version 67.8f59b80b.0 cc-a0-67.ucode op_mode iwlmvm
[    2.683247] iwlwifi 0000:27:00.0: Detected Intel(R) Wi-Fi 6 AX200 160MHz, REV=0x340
[    2.806938] iwlwifi 0000:27:00.0: Detected RF HR B3, rfid=0x10a100
[    2.871940] iwlwifi 0000:27:00.0: base HW address: f8:e4:e3:00:d2:b4
[    2.889905] Bluetooth: Core ver 2.22
[    2.889918] NET: Registered PF_BLUETOOTH protocol family
[    2.889918] Bluetooth: HCI device and connection manager initialized
[    2.889954] Bluetooth: HCI socket layer initialized
[    2.889955] Bluetooth: L2CAP socket layer initialized
[    2.889957] Bluetooth: SCO socket layer initialized
[    3.041784] usbcore: registered new interface driver btusb
[    3.182855] iwlwifi 0000:27:00.0 muninn: renamed from wlan0
[    3.664130] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    3.664133] Bluetooth: BNEP filters: protocol multicast
[    3.664136] Bluetooth: BNEP socket layer initialized
[    5.048112] Bluetooth: hci0: command 0xfc05 tx timeout
[    5.048112] Bluetooth: hci0: Reading Intel version command failed (-110)

So basically bluetooth devices can’t connect. Because blueman-manager doesn’t find any controllers and doesn’t even start. And it seems I might not be the only one with ax200 problems with recent kernel/firmware/ucode updates – FS#73387 : [linux-firmware] Intel AX210 iwlwifi broken on kernel and firmware upgrade

Made an account to post this.

Plasma Wayland on NVIDIA has broken for me in this update. Just a black screen with blinking cursor. Installed gnome-shell just to test, and wayland works fine on that.

[ 168.525835] [drm:nv_drm_gem_alloc_nvkms_memory_ioctl [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000600] Failed to allocate NVKMS memory for GEM object

Probably due to my dual NVIDIA GPU setup. I’ll update the post if single GPU fixes it.

Edit: Single GPU fixes it.

Thank you for the heads-up… found it in my update log:

Upgrading glibc (2.33-5 -> 2.35-2)...
/etc/locale.gen installed as /etc/locale.gen.pacnew.
Generating locales...
  en_US.UTF-8... done
  en_CA.UTF-8... done
Generation complete.
Upgrading gcc-libs (11.1.0-3 -> 11.2.0-3)...

Using meld I noticed the pacnew file was the same except for one additional line; resolved with:

$ cd /etc
$ sudo rm locale.gen
$ sudo mv locale.gen.pacnew local.gen
$ sudo mkinitcpio -P
1 Like

Since the last update I have a strange dark stripe on Brave-Browser on the left in my favorite newspaper website. I’m not sure if the error is related to Plasma or Brave. Can not say exactly, but those color probably matches the color of global theming.

Hi! Unable to update. This is the last lines of the update via pamac:
Controllo portachiavi…
Verifico l’integrità dei pacchetti…
Caricamento dei file dei pacchetti…
Controllo conflitti tra file…
Inizializzazione del trasferimento non riuscita.:
file in conflitto:

  • dunst: /usr/bin/dunstify already exists in filesystem (owned by dunstify)

I’ve previously had issues with my AX200 bluetooth (Anyone else experiencing Intel AX200 Bluetooth being disabled in kernel515?), and found after this update that it continues to work… No errors in journal, and my bluetooth devices are still listed in the bluetooth plasmoid. Some thoughts that may be helpful…

  • I am using kde plasma manjaro, and although blueman is listed in pamac, I do not have it installed. Not sure if it’s a requirement for your distro, but perhaps blueman is where the problem lies?
  • I am also still on kernel 5.15 (5.15.25) and have not tried 5.16 kernels yet.