[Stable Update] 2022-01-02 - Kernels, Systemd, KDE Frameworks, Mesa, Xorg-Server, Wine, Python 3.10

A post was split to a new topic: No package metadata was found for powerline-shell



Everything went fine, the only issue is a warning that the installed Manjaro-Hello is newer then the one in thte repo.

warning: manjaro-hello: local (0.6.6-10) is newer than extra (0.6.6-9)

Pops up after each update command (“sudo pacman -Syyu”)

Run sudo pacman -Syyuu to downgrade Manjaro-Hello to match the repos.

Thanks, that worked!

1 Like

(I hope I don’t regret asking this, but …) Could someone expand on this please? What does this mean exactly? Thanks.

1 Like

All went fine and a handful of py stuff upgraded ok.
However, I use I3, which still works fine (bindings, windows placement etc), BUT the status bar has dis-appeared (Polybar). Changed config to display status bar on top of screen instead of bottom but still no joy. Is anyone else running I3 and having the same problem? :man_shrugging:

Works, but manjaro hello release info is now mentioning 21.1. :slight_smile:

Refresh your mirrors and update to 3.5.7-1.

The devs must have had a reason for downgrading the package and I’m sure they will sort it all out soon. Also downgrading the package will get rid of the error and force the local system to match the repos. That being said, if the package is causing no issues, it is OK to keep the newer package installed locally if one desires. I did downgrade myself and can confirm that “Release Info” now refers to the prior release. No worries!

1 Like

Thanks for that. All good. :slightly_smiling_face: :ok_hand:

Almost Everything went smoothly, and a HUGE thank you for updating kicad to version 6.0!

The only problem I’m having is that gestures are no longer working with touchegg and the Synaptics touchpad on my laptop. Looks like libinput was part of this update, and systemd displays the following daemon status message:

Jan 02 17:39:55 hostname touchegg[4318]: libinput error: event5 - SynPS/2 Synaptics TouchPad: libinput bug: invalid gesture event GESTURE_EVENT_PINCH in state GESTURE_STATE_NONE

EDIT: False alarm, touchegg and libinput are both working fine. Looks like the kicad major version update sets the default zoom in / zoom out to null, for whatever reason. Manually setting them to ctrl + and ctrl - respectively makes everything function as expected.

A post was split to a new topic: X wouldn’t start properly after upgrade

perhaps this post near the beginning of this thread would help?

I also noticed a second experience and suggestion…

Issues with AUR packages are off topic in Announcement threads.

ah, I’m an AMD user myself, so was not aware the nvidia optimus-manager was an AUR package

I had the Kodi-python problem on 3 HTPCs. I deleted the youtube addon folder from


and Kodi now works fine. Easy fix since I no longer use the youtube addon anyway.
The Endeavor post listed above goes into more detail. Downgrading python doesn’t seem to be necessary.

1 Like

== Update Fail ==

Why does the package core/filesystem complain about /usr/local/share/man, and by complain I mean:

error: extract: not overwriting dir with file /usr/local/share/man
error: problem occurred while upgrading filesystem
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.
===> pacman -Fx /usr/local/share/man
usr/local/share/man is owned by core/filesystem 2021.01.19-1

# pacman -Fy usually runs after a successful install, so had to run it manually
===> pacman -Fx /usr/local/share/man
usr/local/share/man is owned by core/filesystem 2021.12.07-3

I use /usr/local/share/man/ directory tree for local man pages.

I created this directory some time ago, and have done updates with no problems.

== Update Success ==


I moved our man pages from /usr/local/share/man to /usr/local/man.

A post was split to a new topic: After the update gnomecast stopped working

I get stuck here in updating sway on x86_64:

Download of greetd-tuigreet (0.7.1-2) finished                                       
Checking keyring...                                                         [256/256]
Checking integrity...                                                       [256/256]
Error: greetd-tuigreet: signature from "Jonas Strassel <info@jonas-strassel.de>" is invalid
Removing invalid files and retrying...
Resolving dependencies...
Checking inter-conflicts...
Download of greetd-tuigreet (0.7.1-2) started                                        
Download of greetd-tuigreet (0.7.1-2) finished                                       
Checking keyring...                                                         [256/256]
Checking integrity...                                                       [256/256]
Error: greetd-tuigreet: signature from "Jonas Strassel <info@jonas-strassel.de>" is invalid
Error: Failed to commit transaction: invalid or corrupted package:```