After the update gnomecast stopped working

After the update gnomecast stopped working for me.
It is installed via pip with “pip3 install gnomecast”, not the outdated version available via AUR
I tried uninstalling it then reinstalling it but it didn’t fix it.

Actually the application starts but after the update it is no longer able to find the chromecast device on the local network.

I’m guessing it is related to the python 3.10 update but I’m not sure what else to try. If anyone has a suggestion I’ll give it a try otherwise I’ll keep searching for a solution.


Gnomecast has been broken for quite some time now and hasn’t seen any development for about a year.

I had been using the latest version without any problems up until the last update. It’s only stopped working since then. I just can’t work out the error when I run it from the command line because something changed with Python 3.10 I think.

I decided to have another go at getting gnomecast to work with Manjaro.

This command:
pip3 install PyChromecast==1.0.3 zeroconf==0.19.1

from this forum solved the problem:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.