[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

I will test the preview ISO to see how it works. If I have problems with it, I will use the Manjaro 21.1.6 version and then updates to qonos. I don’t need btrfs as I use Ext4.

@maycne.sonahoz : I know that but here I want to make a new installation on another computer. :wink:
As Manjaro 21.2pre1 have all the last packages, I install it directly for a new installation.

1 Like

Hi there,
thanks for this massive update!

Since the update I receive the error message
/user.slice/user-1000.slice/session-1.scope is not a snap cgroup
upon trying to start any snap application. All snaps are uptodate.
Any hints on how I can resolve this?

Hi, I use Openbox, just want to report that after the update ob-autostart stopped working:

ERROR : All required python dependencies were not found!

Editing the script to show more detail revealed this error:

Traceback (most recent call last):
  File "./test.py", line 16, in <module>
    import gtk
  File "/usr/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 30, in <module>
    import gobject as _gobject
  File "/usr/lib/python2.7/site-packages/gobject/__init__.py", line 47, in <module>
    from gobject.constants import *
  File "/usr/lib/python2.7/site-packages/gobject/constants.py", line 24, in <module>
    import gobject._gobject
ImportError: libffi.so.7: cannot open shared object file: No such file or directory

I checked https://wiki.archlinux.org/title/openbox#GUI_configuration, seems like ob-autostart was removed from the AUR

Edit:
installing libffi7 from AUR fixed the problem:

  • https://aur.archlinux.org/packages/libffi7/

Now that the posting has calmed down I’ll take the chance to say thank you to all the Manjaro developers for this stable update.

Brilliant work and I appreciate that you took the time needed to make sure the update would be troublefree for as many people as possible.

1 Like

On xfce
I got asked to replace xdg-desktop-portal-gtk by xdg-desktop-portal-gnome.
Any ideas why?
I declined - no issues so far.

2 Likes

hypnotix / kodi wasn’t able to start. The reason is that after updating the package “python-text-unidecode” is missing. you can install it with pamac and afterwards it will work.

I noticed 2 issues :

First, as mentionned by @anemr, if you have an old laptop, with an old nvidia discrete GPU and you are using Bumblebee, the workaround put in place for making the 390 driver work with this update won’t work out of the box, because it’s placed in /etc/X11/xorg.conf.d instead of /etc/bumblebee/xorg.conf.d/.

The following command and a reboot seems to be working ( + maybe check with systemctl if bumblebeed is working ok)

sudo cp /etc/X11/xorg.conf.d/30-nvidia-ignoreabi.conf /etc/bumblebee/xorg.conf.d/

The second issue is strange, some custom icons in Gnome app drawer and in the doc (and probably in other places too …) have disappeared for several themes, including papirus and papirus maia … Adwaita is working fine though

Thanks for the update, and, as a manjaro user stuck with an old nvidia GPU, thanks for the effort of supporting our old graphic cards as long as possible.

1 Like

The good news for me is that I put the 5.15x kernel I installed last night into suspend mode before retiring for bed. Resumed from sleep this morning without issue. I may have to keep this one!!! I am running the Nourveau driver, btw. Not Nvidia.

2 Likes

Running the new nvidia properitary drivers with x11

after suspending and waking it up again, svg images get corrupted.

for e.g.

I’m using kiwix which depends on libzim. There was a conflict between libzim 7.x.y and libzim6, here is the solution from @maycne.sonahoz

good morning to all the community, “hypnotix” does not work, from the terminal throws the following error…(I don’t know if it is already communicated)

Traceback (most recent call last):
  File "/usr/lib/hypnotix/hypnotix.py", line 30, in <module>
    from unidecode import unidecode
ModuleNotFoundError: No module named 'unidecode'


@Yochanan Please add python-unidecode as dependency for hypnotix.
https://aur.archlinux.org/cgit/aur.git/commit/?h=hypnotix&id=87768d5bbf424f305531dd3d6d516824867c75e0

1 Like

thank you very much maycne.sonahoz, it worked perfect.
greetings and have a happy day

Anything touch MHWD (terminal or System Settings) instantly freezes while rest of system remains intact.

Shutdown and reboot to LTS kernel: no problem at all with MHWD.

Researching command line solution to rollback NVidia proprietary or switch to open source driver.

I already did. :wink:

1 Like

why did not use kernel 5.15.4 ?

is just the same kernel with some bug fix

i think a good idea to add it to kernel manager kernel manager versions

Because Manjaro - Fresh & Stable and Manjaro - Branch Compare

Booted into a black screen, I checked this release page and figured it was due to the drop of Keppler support (I’m running GTX 760).

I hit Ctrl+Alt+F4 to get into tty, and tried to run the mhwd, but had some dependency issues, I had to remove few programs:

sudo pacman -R nvtop
sudo pacman -R cuda

Then I could do

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-470xx

Right after installation it threw me into my KDE environment without having to reset, so everything works correctly now. Thanks to the team for the problem solutions!

2 Likes

A post was split to a new topic: Installing updates breaks dependency

Responding to Gene post 183. You can change the display manager to SDDM to work around the infinite login loop.

1 Like