[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

I use Guake with ohmyzsh. The fancy text/font is now broken for all tabs except the one that was opened last. Does anyone know if there is an easy fix, of should I just wait for an update to fix it?

OhMyZSH is a user plugin. Nothing that I know of changed that would effect it. Create a new thread in #support if you’d like help with it.

Question–update went fine on a multi monitor desktop using terminal (ctl+alt+F2). pacman -Syyu downloaded 588 packages on my system. On checking disk space before updating pacman said 591 packages. Then on updating , pacman said 590 packages. I am curious about where the other 2 or 3 packages came from. Devs/admins??
Thanks

The actual download and install went fine. I rebooted to the new kernel by typing “reboot”. The problems started when I loaded Pamac after the reboot and tried to delete any orphan packages. It would not accept my password after several tries. I also found that sudo no longer worked, so I could not do “sudo make install” on my source-built software. But I was already logged in, so I did a full backup of my entire home directory and all my data to an external drive, which at least would allow me to reinstall Manjaro in the worst case without data loss. Then I did “poweroff”, waited a while, powered back up again, and this time both the login and sudo worked.

I have no idea what happened that blocked sudo or Pamac from accepting my password on the new kernel, but it seems OK now.

Have the same issue as him, scrollbars look really chunky, don’t think it’s supposed to be like that



I’m using the default breeze theme.

Try here first:

mhwd is the correct tool for managing drivers on Manjaro. Before someone else more knowledgeable about Nvidia GPU’s comes along and asks, it might help to post some better information.

mhwd -l

and

mhwd -li

You could also collect and post some of the other systems information too, it can be helpful when diagnosing issues. See the post bellow for details (and expand the arrows for instructions):

Follow the link in his post.

1 Like

6 posts were split to a new topic: Update replaces rustup with rust

A post was split to a new topic: Blur my shell error

Me too, sometimes I cannot even login as the SDDM hangs forever.

See this:

Hi,

I have a the some issue on a machine

Starting version 249.6-3 manjaro
[TIME] Timed out waiting for device /dev/diskby-id/usb-Verbatim_STORE_N_GO
[DEPEND] Dependency failed for /mnt/usb-Verbatim_STORE_N_GO

tty1 hang on that message

System won’t go further.
I have no systemctl failed and booting from another kernell does not fix the issue.

At the moment, I can tty2 but can’t startx

There is no usb attach to my machine.
Could it be an fstab issue?

I commented those line from fstab and the message is gone but still stuck at the Starting version 249.6-3-manjaro with nothing happening

Since changing to kernel 5.15 I found a similar warning in systemd.log, already been mentioned by @GaVenga in Unstable Update 2021-10-23:

.....
kernel:  ata3.00: Read log page 0x08 failed, Emask 0x1
kernel:  ata3.00: Read log page 0x08 failed, Emask 0x1
.....

His solution found at askubuntu:
add to: GRUB_CMDLINE_LINUX_DEFAULT new entry: “libata.force=noncq”
works just fine, but from what I understand it disables NCQ on boot for all drives.

For me, it was just one drive having trouble with NCQ, so I followed the instructions found in the ArchWiki.
So, for the example above the solution would be:
in /etc/default/grub edit the line GRUB_CMDLINE_LINUX_DEFAULT and add libata.force=3.00:noncq
(Don’t forget to sudo update-grub afterwards.)

1 Like

Just noticed that plugging in a USB Stick no longer adds a “Removeable Device” in KDE’s Dolphin (whether mounted or not)… I’m not a fan of this behaviour, and don’t know if this is an intentional feature change/loss or an unintended bug for this new version.

I tried looking in the Dolphin settings, but did not recognize an option to restore showing removable devices.The only related KDE setting revolves around auto-mounting removable devices, which is unrelated to the missing feature.

EDIT: Solved, see my reply below… needed to “Show Hidden Places”

1 Like

Should I follow his instructions?

It’s KDE upstream decision to disable it by default.

2 Likes
4 Likes

In the future, please copy and paste terminal output as preformatted text, not screenshots.

As far as the QGnomePlatform / Qt5ct message, that actually needs to be updated. If you want to use the Adwaita Maia theme, use Qt5ct and choose the matching style sheet. Otherwise with Adwaita or themes based on it with the blue accent, use QGnomePlatform.

I had no audio after the updates. Solution was to run pavucontrol and go to the Configuration tab, and change my Profile to Analog Stereo Output. Somehow it was switched to HDMI output.

2 posts were split to a new topic: After the update my Howdy installation threw an error

Will look at it tomorrow but my keyboard shortcut to lock screen (windows key + L) is not working anymore (running on gnome).