[Stable Update] 2021-07-13 - Kernels, Plasma 5.22, Cinnamon 5, Gnome 40, LibreOffice, Mesa, Nvidia, Pamac

Got no problem with return to hibernation here, neither with return to sleep. Not an update related issue IMHO

Except for one, all ulauncher extensions seem to be broken. Also had some issues with Dash-to-Dock, but those have been resolved now.

OK, thank you @lopasilver , I will try to figure it out myself.

Just forgot to mention that I still use Kernel 5.10

For all the broken ulauncher extensions, you can fix it by forking the extension yourself and adding these lines to the import-section of the code:

import gi
gi.require_version('Gdk', '3.0')

(Like I did here: Fix issue #5 · Masqueey/ulauncher-bluetoothd@5ad74bf · GitHub)

You can also ask the extension developer to add it to their extension.

For some reason I can’t use light theme on Gnome. It just doesn’t want to select it.

Anyone has a solution to this?

Also I can’t access my Dash-to-dock settings:

The settings of extension dash-to-dock@micxgx.gmail.com had an error:

Error: GSettings key preview-size-scale not found in schema org.gnome.shell.extensions.dash-to-dock

Stack trace:


Open the Extensions application and enable User Themes.

That shouldn’t be happening anymore. Try reinstalling:

pamac install gnome-shell-extension-dash-to-dock

Thank you @grau, you are right!

After I added resume=UUID=xxxxxx back to /etc/default/grub, I forgot to run sudo update-grub so it didn’t take effect.

Now I redo these two steps, my computer can resume from hibernation as before.

This may be because I ran pacdiff last month to update the /etc/default/grub file, which removed the resume=UUID=xxxx parameter, but I didn’t run update-grub, so it did not take effect immediately, and the hibernation still worked fine. In this update, update-grub is triggered so the hibernation cannot work anymore.

Thanks also @lopasilver

I’m using 5.10 (KDE), after updating my Autoscript no longer working for my nvidia card (Color Profile update).

nvidia-settings -l

Everything was fine befor i updated :frowning:

Apparently the main developer of ulauncher went AWOL and the package is no longer maintained. Use this fork from the AUR instead. All my extensions work on this version.

1 Like

Thank you.
The theme problem is however now reversed. I’m unable to select a dark theme.

Reinstalling Dash-to-Dock didn’t fix the problem. I still can’t access the settings.

But these aren’t big deal. I hope these problems will fix themselves with future updates.

When I did update with that extension through pamac, I could not have access to the parameters after. So I had restarted the computer to access the settings via extensions.

In my case, the Dash-to-dock extension from Manjaro works and I’m on a Wayland Session.

compiled and installed the nvidia 450 driver packages, black listed the nouveau driver and things are working great with this driver

I have the issue:
portable ssd not detected when system boot, so can’t boot system installed on it. The issue occurred when upgrade Manjaro from version 21.0.6 to version 21.0.7.

I have just post a topic for ask some help:


I was troubled by this problem for quite some time.

Which kernel version do you use?

Hello @hound , I’m using 5.12.16.