[Stable Update] 2021-07-13 - Kernels, Plasma 5.22, Cinnamon 5, Gnome 40, LibreOffice, Mesa, Nvidia, Pamac

  • I cannot open Dash to Dock settings, and the dock looks ugly (see below).

Dash to Dock is not supporting Gnome 40 yet. You could try to install https://aur.archlinux.org/packages/gnome-shell-extension-dash-to-dock-gnome40-git

1 Like

@remark: Or use the default dock from Gnome 40 (if he wants a dock who really works).

for remove only one dep without application(s):

sudo pacman -Rdd pamac-common

I think you should uninstall “plasma-desktop-primex” first and then install “plasma-desktop”.

1 Like

Is there an easy way to switch to that? If I disable the dash to dock extension, the docks gets disabled completely :thinking:

Faced a problem with System Monitor after upgrading to KDE Plasma 5.22.3:

That Dock only appears when you push the Super key…
I switched to Dash to Panel and I like it much better.

2 Likes

With Super key (Windows)or via Activities button. Or via Gnome layout switcher, you choose ‘Gnome’ choice.

‘Dash to dock’ extension is not ready yet for Gnome 40. As Remark, I switched to Dash to Panel and if I want the dock, I will use the dock from Gnome 40.

2 Likes

Happy 10th anniversary, Manjaro! Update went well, however, have to show the usual Linus love for Nvidia once again. After the update on my Laptop with a 1660Ti, some apps, which use OpenGL (like Telegram from Flatpak) and OpenCL (like Darktable from official repositories) cannot use my GPU. Also, my Rendering backend for my compositor is set to XRender since it proved to work better since I changed to it a few months back. Any ideas?
EDIT: specs

System:    Kernel: 5.10.49-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.3 
           Distro: Manjaro Linux base: Arch Linux 
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check rev: A cache: 
           L2: 12 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 800 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 
           8: 800 9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Hewlett-Packard driver: nvidia v: 470.42.01 
           bus-ID: 01:00.0 
           Device-2: Cheng Uei Precision Industry (Foxlink) HP Wide Vision HD Integrated Webcam type: USB 
           driver: uvcvideo bus-ID: 1-6:3 
           Display: x11 server: X.Org 1.20.11 driver: loaded: nvidia resolution: 1: 1920x1080~60Hz 2: 1920x1080~144Hz


Screenshot_20210713_162403

2 Likes

Thank you for your answer, I will try that. If the extension is not supported, then why does it activate with the new Manjaro layout?

EDIT: Same problem with gnome-shell-extension-dash-to-dock-gnome40-git

I also have a display problem in the pamac settings.

Hi,

I uninstalled the package in order to continue with the installation

sudo pacman -R package-query

I guess I can reinstall it later.

Hello,
I’m using Gnome. After this update I got an issue where all extentions will turned off by the system if I logout and login again. Is it an known issue?

@kleinHeiti: Have you tried to enable the toggle for all the extensions in the Extensions applet/software (upper right in the window) ?

Yes, I did. After that, all extensions work again. But after logout and login again, They are all off again.

at first failed to upgrade because of cmake (for some reason failure caused due to files related to it already existing). I even tried using pamac and it has the same problem. so I removed it and it installed without problem.

Sadly, no, but I got exactly the same issue. I started a thread for that: https://forum.manjaro.org/t/opengl-and-opencl-not-working-anymore-after-ugrading-to-nvidia-470-42-01/
Maybe they are more Nvidia Users experiencing this issue.

2 Likes

Gnome 40 on stable. RIP maintainers when the notifications about broken extensions start coming in :joy:

Gnome 40 as itself is great by the way. I don’t use any extensions and it’s been really great on the testing branch :ok_hand:t2:

Also curious to see how many picked up on the fact that both the 470 nvidia drivers and that xwayland patch made it to stable :eyes:

After this update I experienced an issue with detecting my LUKS encrypted partition.
Here’s what I get:

ERROR: device /dev/Mapper/luks-7d5a56a8-c270-44d1 not found
Skipping fsck.
mount: /new_root: no filesystem type specified
Yu are now being dropped into an emergency shell.
sh: can’t access tty; job, control turned off
[rootfs ]#

I already tried chroot from a live usb distro and then re-running mkinitcpio.
Can this be related to /etc/fstab?

Another Gnome here, all went fine and that is what really counts. I am not using anything fancy and I have disabled all animations. The system uses only about 430mb. Puh! Very snappy. Geary, Gnome Web, really nice. Thanks!