[Stable Update] 2021-07-13 - Kernels, Plasma 5.22, Cinnamon 5, Gnome 40, LibreOffice, Mesa, Nvidia, Pamac

Something is wrong on your end,I just tried Adwaita and it looks fine here

1 Like

Could that be a Wallpaper leaking through ?

As far as I remember, I’ve started out using the Breath 2 Dark theme (KDE/Qt) and for GTK apps I’ve used (Breath-Dark). I haven’t done anything fringe in regards to fonts, colors, or themes. So as a stable update on a flagship software (Pamac), this issue caught me by surprise.

Am I missing GTK4 packages that have to be installed manually? I don’t believe I have any GTK4 apps on my system with which I can test if there is a rendering issue. (All my other GTK apps still appear fine, but I believe they are built with GTK3.)

EDIT: Fixed incorrect theme name.

No it wasn’t, but for some reason that weird shadow has gone away since rebooting a second time. I’ll wait and see if it comes back.

Had this issue as well. I had yaourt installed.

sudo pacman -R yaourt
sudo pacman -R package-query

This removed both the issue causing packages, and allowed the update to work.

Pamac has AUR support built in, so I’m not even sure why I had yaourt installed. And it seems like it’s the only thing that requires package-query anyway… Or so I hope.

1 Like

Anyone else on KDE facing this issue (missing icons) after applying the Stable updates and rebooting? I posted the link to the other thread which contains screenshots of the problem.

Hi -

The system’s been restarted several times since the post. There is no change - arrow keys do not work when selecting among the search results.

Layout Switcher? What is that? I searched for it but nothing turns up.

Use the git version of the tools

The upgrade has broken any Steam game that goes full screen. It either crashes Cinnamon to fallback mode or stutters the screen into unresposiveness. One of the game logs indicated that the windows geometry was flipping from 1920x1080 to 1920x1027 and back repeatedly.

The launcher has always had issues, I gave up on it a long time ago.

If you would like additional troubleshooting with it, please create a topic in #support:gaming.

Not quite yet. Pamac <=10.1 still uses gtk3 and libhandy while >=v11 will use gtk4 and libadwaita. :wink:

The package is called gnome-layout-switcher and appears in the application menu as Layouts.

So the Pamac rendering issue cannot be GTK4-related (on my KDE system.)

I’ve tried every combination of themes (Plasma, Qt, and Gtk), as well as colors, as well as rebooting. Something about the new Pamac (10.1.3-3) must have triggered this. It’s the only Gtk application that does not display correctly on my KDE system.

Thanks, I don’t have it installed. I will look for more information on what these other layouts look like before considering this.

Not sure if you tried it already, but maybe you get some helpful messages if you run pamac-manager from terminal. I get some Gtk and Gdk related WARNING (and even a CRITICAL, need to investigate…) message.

Here’s the output of running pamac-manager from the terminal:

(process:566299): GLib-GIO-WARNING **: 21:06:31.377: /etc/xdg/kde-mimeapps.list contains a [Added Associations] group, but it is not permitted here.  Only the non-desktop-specific mimeapps.list file may add or remove associations.

(pamac-manager:566299): Gtk-WARNING **: 21:06:31.395: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version

(pamac-manager:566299): Gdk-CRITICAL **: 21:06:31.694: gdk_window_set_cursor: assertion 'GDK_IS_WINDOW (window)' failed

My mistake then. I was sure Pamac 10 switched to GTK4 I must have mixed information. However, Adwaita is the only GTK theme without issue on KDE for Pamac. I think this is a bit of an issue, even if it is only cosmetic issue.

@winnie open a support thread for your issue, again.

Look in your ~/.local/share/applications if there a Brave and Veracrypt .desktop files and delete them.

Just for comparison, this is the output I get and I don’t have the icons problem (even with unsusual things I setup, it loads everything fine).

There are none. In fact, it effects many programs, including Firefox. I’m trying to discern a pattern. If you’ll notice, it happens on any launcher I use, and yet the icons appear properly in the task bar.

This issue was already reported in another thread, yet it did not affect me until after I applied the Stable Updates today.

Where can I download this ISO ???


Set your system settings with this parameter
translucency off