[Stable Update] 2021-06-14 - Kernels, Browsers, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire, Haskell

Kernel Panic now, typing from phone. Ok so bad update, what is the solution to this please?


Thank you very much. This worked perfectly! :star_struck:

I solved the problem with this recipe from @omano . Tank you.

Updated with pamac, everything was smooth.

Removing lib32-libcanberra-gstreamer and libcanberra-gstreamer worked just fine and I updated with pacman.

There was a new mkinitcpio.conf pacnew file that required merging but all it added was a zstd compression option.

Not sure if the libcanberra workaround merits an edit of the wiki post so I’ll leave that for somebody else’s discretion.


Still in kernel panic and getting user panic too as I chose stable branch to avoid this kind of thing :laughing:
I just tried this Kernel panic message - #3 by Aragorn
Sorry on mobile…
Still stuck in kernel panic, can someone please help?

I’d be interested in a definite answer to that question as well.


Did anyone help you out here? This is the same issue I’m facing

1 Like

Be patient. I’m sure there will be a solution posted here soon.

1 Like


Did you see this post further up?

I did and tried it but I get :

grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your device.map

I have two questions:
I have warning:
Attention: cryptsetup: local (2.3.6-1) is higher than core (2.3.5-4)
Update mkinitcpio (29-1.0 -> 30-1) /etc/mkinitcpio.conf installed as /etc/mkinitcpio.conf.pacnew.
Should I make something with mkinitcpio.conf.pacnew?

Ran sudo pamac update and everything went fine, seemed to take care of the conflicts.

I have exact same problem. I used Timeshift to restore my system to the previous version.

I updated the system using pamac which was apparently good, but on reboot I get the kernel panic. Now I am going to try the solution in [Stable Update] 2021-06-14 - Kernels, Browsers, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire, Haskell - #15 by simonb

MkInitCpio issue I’ve to fix. We don’t have all kernels supporting zstd compression by default.

1 Like

How can you do that when the system is in kernel panic and won’t boot?

Testing has mkinitcpio 29-1.0, so problem version seems to have skipped Testing.

Download an Installation image, write it to a flash drive and boot from that.

Issue with mkinitcpio fixed. Those who have kernel panics on old kernels, may need to get a Manjaro install media to fix it via chroot: Run live system start terminal run su to be root run manjaro-chroot -a edit etc/mkinitcpio.conf as shown in the link run mkinitcpio -P exit chroot and reboot.