[Stable Update] 2021-04-18 - Kernels, Mesa, Wine, Plasma5, KDE Frameworks, LibreOffice, Bluez

Sorry for the noob question: Currently updating and it’s going awfully slow, like <100 KiB/s. It’s not my internet connection, just checked. I used

sudo pacman-mirrors -f && sudo pacman -Syyu

to start the update. Thought this would update mirror lists and pick the fastest one.

Is there a way to safely stop updating or should I just let it run? Thanks a lot!

First of all, thank you guys for your amazing work!! :trophy: :sparkles:

I´ve tried Kate´s workaround (usr/lib/libKF5KIOCore.so.5: undefined symbol: _ZN4KJob14percentChangedEPS_mNS_14QPrivateSignalE), downgrading kio back to 5.79.0, but it didn´t work :frowning:

I can’t downgrade kio:

loading packages ...
solving dependencies ...
looking for conflicts between packages ...

:: kio and kio-git are in conflict. Remove kio-git? [y / n] y
error: could not prepare operation (could not satisfy dependencies)
:: removing kio-git breaks the dependency with "kio-git", necessary for the user-manager-git package  

By the way is there any way to use the 418xx drivers with the newer kernels by compiling them from source? My laptop uses a Nvidia GTX770M card and I´ve built the packages, compiling them manually as @philm exposed in my last 3 updates using the 5.4 LTS kernel

Kate icon has disapear :

And I can’t adjust the size of the icon in the task bar. Maybe it’s a KDE issue…

1 Like

While I don’t use Ark in particular, a common way most archive programs work is they write to a temporary file while building the archive. You may want to look into where the temporary files are being stored and make sure that location the program is using has enough disk space (It most likely will not be the directory you are working on your files in).

Did you do a “sudo update-grub” after uncommented /etc/default/grub? See if in this file there are duplicated #GRUB_DISABLE_OS_PROBER=false

Everything went smooth, thank you!

And oversight on my side - 4.21.1 has been pushed to unstable - if there is no complaints we can push to the other branches as well.


kio-git package is installed and there lies your problem. See

and followups.

Actually, I don’t see it yet in the repo though. Should have been synced in the meanwhile :thinking:

What I find a bit odd is that the response times via HTTP is about ~1 second (since a couple of version already I guess).
When I do a quick implementation in Go, I download that file in about 100ms though.

Anyways, offtopic. We can discuss elsewhere…

@linux-aarhus Created an issue on gitlab:

same here, Repos from Germany

installed it via makepkg -si on my test environment

The wine 6.6 staging release is pretty borked and could use an update, a patch seems to be out:

and the reboot did not help me, only the extension that was recommended above Jocix

This is the update output I got in comparison:

upgrading manjaro-system…
e[1;1me[1;32m==>e[1;0me[1;1m Checking for ‘os-prober’ setup …e[1;0m
We will reenable ‘os-prober’ for you …
Generating grub configuration file …

These are the last three lines in my /etc/default/grub file

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

The update appends GRUB_DISABLE_OS_PROBER=false after my entry.

Maybe you should remove the line with the comment: #GRUB_DISABLE_OS_PROBER=false
And update-grub

Twenty hours later issue solved

Big Thank You to the Manjaro Team

1 Like

Python 3.9.4 was released on April 4.
3.9.3 was available for only 2 days, but 2 weeks later it’s still in Arch.
Maybe because (it seems like) the error does not affect 64-bit:
“… fail on 32-bit. On 64-bit it passes …”

My second monitor is no longer detected since the reboot.
It was working during the installation, but I disconnected it before doing the restart.
Even a reboot with the monitor connected is not bringing it back.

I’m completely lost on how to investigate further, first search results in the forum doesn’t seem to apply to my situation?

When you see the SDDM login screen revert to the very old look, it usually means that the SDDM theme that you were using is not compatible with the latest updates to plasma, causing SDDM to show the fallback login screen.

I’m almost sure you would actually have been able to login to your desktop even with that old login screen, and then from there you could have changed your SDDM theme to something that works, or installed from KDE store a newer version of that broken theme. But I don’t know all the facts.

Try using xrandr.
That always works for me.

Still having the same issues that a lot of KDE stuff won’t open after the update. I still cannot open my application dashboard, add widgets, show alternatives, and Kate won’t start either.
Trying to launch Kate from the terminal returns:

$ kate
kate: symbol lookup error: /usr/lib/libKF5TextEditor.so.5: undefined symbol: _ZN9KLineEdit16returnKeyPressedERK7QString

I have seen and tested the workaround proffered here:

In some rare cases you may face the following error on your KDE Plasma Desktop: usr/lib/libKF5KIOCore.so.5: undefined symbol: _ZN4KJob14percentChangedEPS_mNS_14QPrivateSignalE.

wget https://archive.archlinux.org/packages/k/kio/kio-5.79.0-1-x86_64.pkg.tar.zst
sudo pacman -U kio-5.79.0-1-x86_64.pkg.tar.zst
echo "IgnorePkg = kio" | sudo tee -a /etc/pacman.conf

kio has successfully been downgraded to v. 5.79, along with replacing the *git version of it with the non-git version.

$ pacman -Q kio
warning: config file /etc/pacman.conf, line 100: directive 'IgnorePkg' in section 'multilib' not recognised.
kio 5.79.0-1

In hopes of finding a solution, I have read through this thread: Kate don’t start after last update and attempted the solution offered there—which turned out to just be the workaround described above, except for also resolving dependency conflicts—but to no avail. I still receive the above-mentioned error when attempting to start Kate and my application dashboard still won’t open.

Trying to see what the application dashboard itself has to say, I (re-)started the plasmashell from the terminal using killall plasmashell; kstart5 plasmashell. Once I did, I received an output every time I clicked the icon for the application launcher/application dashboard:

file:///usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/CompactRepresentation.qml:115: TypeError: Cannot call method 'toggle' of null

After a few clicks, it changed to:

file://usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/CompactRepresentation.qml:115: TypeError: Cannot read property 'toggle' of null

“Show Alternatives…” returns:

 "Error loading QML file.\n27: plugin cannot be loaded for module \"org.kde.plasma.private.shell\": Cannot load library /usr/lib/qt/qml/org/kde/plasma/private/shell/libplasmashellprivateplugin.so: (/usr/lib/libKF5TextEditor.so.5: undefined symbol: _ZN9KLineEdit16returnKeyPressedERK7QString)\n"
Alternatives UI does not inherit from Dialog

“Add Widgets…” returns:

file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/explorer/WidgetExplorer.qml:32:1: plugin cannot be loaded for module "org.kde.plasma.private.shell": Cannot load library /usr/lib/qt/qml/org/kde/plasma/private/shell/libplasmashellprivateplugin.so: (/usr/lib/libKF5TextEditor.so.5: undefined symbol: _ZN9KLineEdit16returnKeyPressedERK7QString)

(I will post the complete output of killall plasmashell; kstart5 plasmashell to my initial support thread: Application Launcher, Add Widgets, Show Alternatives, and others no longer open after update)

I will also mention, as I did in my support thread, that timeshifting back to a backup from 10th April makes everything work once. However, as soon as I reboot that timeshifted system, I’m back to my current issues.

I’m still lost here … Please help me. :frowning: