[Stable Update] 2021-04-18 - Kernels, Mesa, Wine, Plasma5, KDE Frameworks, LibreOffice, Bluez

Twenty hours later issue solved

Big Thank You to the Manjaro Team

1 Like

Python 3.9.4 was released on April 4.
3.9.3 was available for only 2 days, but 2 weeks later it’s still in Arch.
Maybe because (it seems like) the error does not affect 64-bit:
https://bugs.python.org/issue43710
“… fail on 32-bit. On 64-bit it passes …”

My second monitor is no longer detected since the reboot.
It was working during the installation, but I disconnected it before doing the restart.
Even a reboot with the monitor connected is not bringing it back.

I’m completely lost on how to investigate further, first search results in the forum doesn’t seem to apply to my situation?

When you see the SDDM login screen revert to the very old look, it usually means that the SDDM theme that you were using is not compatible with the latest updates to plasma, causing SDDM to show the fallback login screen.

I’m almost sure you would actually have been able to login to your desktop even with that old login screen, and then from there you could have changed your SDDM theme to something that works, or installed from KDE store a newer version of that broken theme. But I don’t know all the facts.

Try using xrandr.
That always works for me.

Still having the same issues that a lot of KDE stuff won’t open after the update. I still cannot open my application dashboard, add widgets, show alternatives, and Kate won’t start either.
Trying to launch Kate from the terminal returns:

$ kate
kate: symbol lookup error: /usr/lib/libKF5TextEditor.so.5: undefined symbol: _ZN9KLineEdit16returnKeyPressedERK7QString

I have seen and tested the workaround proffered here:

In some rare cases you may face the following error on your KDE Plasma Desktop: usr/lib/libKF5KIOCore.so.5: undefined symbol: _ZN4KJob14percentChangedEPS_mNS_14QPrivateSignalE.

wget https://archive.archlinux.org/packages/k/kio/kio-5.79.0-1-x86_64.pkg.tar.zst
sudo pacman -U kio-5.79.0-1-x86_64.pkg.tar.zst
echo "IgnorePkg = kio" | sudo tee -a /etc/pacman.conf

kio has successfully been downgraded to v. 5.79, along with replacing the *git version of it with the non-git version.

$ pacman -Q kio
warning: config file /etc/pacman.conf, line 100: directive 'IgnorePkg' in section 'multilib' not recognised.
kio 5.79.0-1

In hopes of finding a solution, I have read through this thread: Kate don’t start after last update and attempted the solution offered there—which turned out to just be the workaround described above, except for also resolving dependency conflicts—but to no avail. I still receive the above-mentioned error when attempting to start Kate and my application dashboard still won’t open.

Trying to see what the application dashboard itself has to say, I (re-)started the plasmashell from the terminal using killall plasmashell; kstart5 plasmashell. Once I did, I received an output every time I clicked the icon for the application launcher/application dashboard:

file:///usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/CompactRepresentation.qml:115: TypeError: Cannot call method 'toggle' of null

After a few clicks, it changed to:

file://usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/CompactRepresentation.qml:115: TypeError: Cannot read property 'toggle' of null

“Show Alternatives…” returns:

"file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/explorer/AppletAlternatives.qml" 
 "Error loading QML file.\n27: plugin cannot be loaded for module \"org.kde.plasma.private.shell\": Cannot load library /usr/lib/qt/qml/org/kde/plasma/private/shell/libplasmashellprivateplugin.so: (/usr/lib/libKF5TextEditor.so.5: undefined symbol: _ZN9KLineEdit16returnKeyPressedERK7QString)\n"
Alternatives UI does not inherit from Dialog

“Add Widgets…” returns:

file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/explorer/WidgetExplorer.qml:32:1: plugin cannot be loaded for module "org.kde.plasma.private.shell": Cannot load library /usr/lib/qt/qml/org/kde/plasma/private/shell/libplasmashellprivateplugin.so: (/usr/lib/libKF5TextEditor.so.5: undefined symbol: _ZN9KLineEdit16returnKeyPressedERK7QString)

(I will post the complete output of killall plasmashell; kstart5 plasmashell to my initial support thread: Application Launcher, Add Widgets, Show Alternatives, and others no longer open after update)

I will also mention, as I did in my support thread, that timeshifting back to a backup from 10th April makes everything work once. However, as soon as I reboot that timeshifted system, I’m back to my current issues.

I’m still lost here … Please help me. :frowning:

2 Likes

I got a file like that in my home folder too, what is that?

Had no issue using matcha-sea-dark theme on qt apps in previous updates. now it looks like this

link: https://imgur.com/a/JTuji0N

notice how some panes are light-themed and texts are almost impossible to read (using manjaro-gnome)

1 Like
  1. Please wrap your links in single backticks (`) in the future, until you’ve reached the required trust level to post links. This will cause them to be rendered like this: https://imgur.com/a/JTuji0N. It just makes it that much easier to read and work with the links.
  2. It looks like a descrepency between QT and GTK applications, specifically, it looks like the GTK apps do not have a dark theme, making them stand out. Ensure this is correct.

Hope this helps!

Solved. Thanks!

Me too.

“you would actually have been able to login to your desktop even with that old login screen, and then from there you could have changed your SDDM theme to something that works”

That’s the problem, I cant log in when this broken.

Fair enough.

Gnome, 5.4

After the update I have lost RDP functionality in Remmina. So far I have tried reinstalling Remmina, and various RDP plugins. If I find a solution I’ll post for anyone else that has this issue.

No problem with the upgrade. but can someone help me how to make it so that when I upgrade the kernel to a newer version, the package related to the kernel is also upgraded without having to manually declare it.
In my case, when I upgrade the kernel from linux54 to linux510, I also need to include linux510-nvidia and linux510-bbswitch.

This is the output of the command, no difference when the monitor is connected or not:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm
   1920x1080     60.01*+  59.93  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Yes, that fixes the problem. The check does not like multiple GRUB_DISABLE_OS_PROBER entries, even if it is just a comment.

1 Like

Thanks for posting the link to the check. My grub file had two problems. First, I had added a space between # and GRUB_DISABLE_OS_PROBER=false. Second, I actually needed to delete the #GRUB_DISABLE_OS_PROBER=false comment altogether.