[Stable Update] 2021-03-08- Kernels, Plasma 5.21.2, Haskell, Kodi, Grub, KDE-Dev

Hello Manjaro community!

The latest update cannot be applied with linux59-rt kernel.
The problem seems to come from linux-59-rt-nvidia which hasn’t been updated to 460.56-1 from 460.39-1 and it causes a dependency issue with lib32-nvidia-utils, mhwd-nvidia and nvidia-utils.

I was also curious about newer real-time kernel, is 510-rt in the plans? I would love to shift to 5.10 since it is the new LTS release. :slight_smile:

Thank you for you hard work!

Thank you very much! That worked fine! Many thanks and keep the great work going!

Hey guys,
I have upgraded recently and (almost) everything is working smoothly as usual. The only thing I noticed are two small things:
On my desktop system the power management tray icon is still incorrect (see screenshot), this has been the case since the fresh installation of Manjaro 20.1 Nibia, so even before the upgrade to Xfce 4.16. On my notebooks (two different models, but also Manjaro Xfce with current stable upgrade) the problem does not exist, here the icon is displayed correctly as a battery icon.

I also noticed a little bug with screenfetch that I didn’t have before either. As seen on the screenshot, there seems to be an invalid character in line 1802 of the file /usr/bin/screenfetch. How that got there doesn’t make sense to me, I didn’t make any manual changes.

Thanks for the support and the great work you guys do to make Manjaro Linux possible. :slight_smile:


Hi @LinKostik, and welcome!

About the power saving icon, I have absolutely no idea.

About screenfetch, I have no idea what could cause it, except if you’ve edited usr/bin/screenfetch, which I gather you haven’t. I also don’t know if screenfetch is buggy or not, I only used it for about a moth.
However, I do use neofetch which works fine, so you could install it and give it a shot.
This, combined with yakuake and oh-my-zsh makes for one damn fine command line experience, if you ask me.
Now that I think about it, even if you don’t ask me, is still makes for a damn fine experience, I’m just not telling you.

Which is your loss, really.
1 Like

Another “interesting” phenomenon that seems to be associated with the change from pulseaudio to pipewire-pulse.

Whenever Audacious changes track and there’s a different number of channels in the new track (ie going from a mono track to a stereo one or vice-versa), the balance immediately jumps from centre to left.

Playing around with the output settings, I’ve found that changing the output plugin from PulseAudio to SDL seems to fix it, though I’ve no idea what the implications of making this change are.

[Edit]: curious. Certain (low-quality) podcasts end up with unpleasant artefacts when using SDL, so evidently that’s not going to be a good solution. I need to dig deeper.

[Edit 2]: as explained in this thread, pipewire is only actually required if the pulseeffects package is installed. So removing that and reinstalling the original pulseaudio solves all the problems.

No problem (aside the window grub one, but I don’t care about it, seen are ages that I want to erase the win partition; maybe it is the time I do it), so I marked the box “no issue”; thanks for the update. Just a question: why remove the os-prober recognition of win?

Apparently it wasn’t Manjaro but grub development team. (I might be wrong, but that’s how I understand it.)

1 Like

I experience random reboots after this update, how do I troubleshoot it ?

Well, try another kernel version first.

If that doesn’t work, see if you can find anything in the logs.

last reboot | less

Might help. Open another thread if you need more assistance.

Hope this helps!

Update on 12 Systems without Problems.


The Grub OS Prober ‘update’ should have been an opt-in, not a total unwelcome surprise on a stable system!

Updated with no issues, except Firefox is utterly useless now. Youtube videos lag, immense scroll lag / problems on old.reddit.com, facebook etc.
Here’s a test between Firefox and Chromium as you can see FF has a lot of issues.


AMD 3600X, Nvidia 1060 6GB, 1080p so no potato!
I think it’s due to webrender which is disabled by ENV but I force-enabled it so that google maps 3D works as I use it a lot. If I disable everything gets better but maps no longer works in 3D. Thing is, previous to this update (yesturday) everything worked great!

Update without problems :slight_smile:

Everything went fine on my XFCE system but the Flameshot tray icon turned to a blue exclamation dot while remmina’s tray icon disappeared. It’s still there on the left of the volume icon but doesn’t show up (though I can right-click on it and access remmina’s options).

Was Firefox 86.0.1 update pushed to Stable? Today I received this update along with Chromium and Manjaro mirrors update, but I don’t see any notification about it in the forum.

I’m on KDE stable, btw.

Yes. They were built after the announcement.

Consider yourself notified. :wink:

Cool. Thank you.

Hi everyone, I’m having trouble loading the Add/Remove Software. The application simply don’t load. Does anybody have the same issue?

Open a terminal and write “pamac-manager” press enter and see what’s happening.