[Stable Update] 2021-03-08- Kernels, Plasma 5.21.2, Haskell, Kodi, Grub, KDE-Dev

Was there a change to cups or the splix package in particular? My Samsung printer is only printing (literally on paper) pages with an error code now:

        POSITION: 0x2804a (163914)

        SYSTEM: h6fwsim_mono/xl_image

        LINE: 132

        VERSION: SPL 5.05 01-04-2006

GRUB_TIMEOUT_STYLE is hidden or menu ?

Since this update, lutris doesn’t start my games running on wine anymore (Overwatch using lutris-6.0-x86_64 and League of Legends using lutris-lol-5.5-2).
In ~/.cache/lutris/lutris.log, no useful information can be found:

[WARNING:2021-03-11 13:04:07,718:game]: Game still running (state: running)
[INFO:2021-03-11 13:04:07,718:game]: Stopping Overwatch (wine)

I uninstalled those games, uninstalled lutris, installed lutris once again, and now I can’t even install the games, I’m told “no file provided”.

I managed to install Battle.net in console using WINEPREFIX=/home/phoko/Games/overwatch/ wine ./Battle.net-Setup.exe, but can’t manage to launch Overwatch that way (“Overwatch has stopped working”).

What can I do about that?

I’m using kernel 5.4.101-1-MANJARO and Nvidia Driver Version: 450.80.02 (and cannot upgrade the driver since my GPU stopped at this version).

A post was split to a new topic: My screens flickers after upgrade

If you have the same problem that I have (different game, though) it’s been a Wine-problem for a while. For me I noticed that it’s related to what’s in the clipboard when starting something (yes, seriously). That’s the relevant part of Wine’s log:

0288:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
00c0:err:clipboard:convert_selection Timed out waiting for SelectionNotify event
00c0:err:clipboard:convert_selection Timed out waiting for SelectionNotify event
0288:err:seh:dispatch_exception Fatal EXCEPTION_WINE_CXX_EXCEPTION exception (code=e06d7363) raised
0288:err:virtual:virtual_setup_exception stack overflow 2064 bytes in thread 0288 addr 0x7bc31f20 stack 0x1207f0 (0x120000-0x121000-0x220000)

Note the err:clipboard. It helps to copy a very simple plain text into the clipboard or you can also run echo wtf | xclip -selection clipboard in a terminal before you run the game.

How to proceed:

So let’s say you tried to launch the game and that halted:

  1. Lutris has an option to kill all Wine-processes. The option is available if you click on the game after which buttons become available at the bottom. The one with the icon (don’t know what that’s supposed to be) to the left of “Platform” contains that “Kill all Wine processes”. Click that.
  2. Check your running processes if there are some left related to your game or Wine and kill them (shouldn’t be, but who knows)
  3. Open a text editor of your choice or the terminal and copy something into the clipboard. Yes, plain text, nothing from your web-browser, writer application, …
  4. Run the game again. Theoretically it works now.

WARNING: Hook 'sd-lvm2' is deprecated. Replace it with 'lvm2' in your config

/me no-like-y

initramfs is where everyone should be conservative

2 posts were split to a new topic: Discover is reporting that updates are available after stable update

A post was merged into an existing topic: Discover is reporting that updates are available after stable update

Happy to annouce I have 0 issues after the lastest update.
But i do NOT have dual boot (Win + Linux).
Even Steam looks OK

Hello Manjaro community!

The latest update cannot be applied with linux59-rt kernel.
The problem seems to come from linux-59-rt-nvidia which hasn’t been updated to 460.56-1 from 460.39-1 and it causes a dependency issue with lib32-nvidia-utils, mhwd-nvidia and nvidia-utils.

I was also curious about newer real-time kernel, is 510-rt in the plans? I would love to shift to 5.10 since it is the new LTS release. :slight_smile:

Thank you for you hard work!

Thank you very much! That worked fine! Many thanks and keep the great work going!

Hey guys,
I have upgraded recently and (almost) everything is working smoothly as usual. The only thing I noticed are two small things:
On my desktop system the power management tray icon is still incorrect (see screenshot), this has been the case since the fresh installation of Manjaro 20.1 Nibia, so even before the upgrade to Xfce 4.16. On my notebooks (two different models, but also Manjaro Xfce with current stable upgrade) the problem does not exist, here the icon is displayed correctly as a battery icon.

I also noticed a little bug with screenfetch that I didn’t have before either. As seen on the screenshot, there seems to be an invalid character in line 1802 of the file /usr/bin/screenfetch. How that got there doesn’t make sense to me, I didn’t make any manual changes.

Thanks for the support and the great work you guys do to make Manjaro Linux possible. :slight_smile:


Hi @LinKostik, and welcome!

About the power saving icon, I have absolutely no idea.

About screenfetch, I have no idea what could cause it, except if you’ve edited usr/bin/screenfetch, which I gather you haven’t. I also don’t know if screenfetch is buggy or not, I only used it for about a moth.
However, I do use neofetch which works fine, so you could install it and give it a shot.
This, combined with yakuake and oh-my-zsh makes for one damn fine command line experience, if you ask me.
Now that I think about it, even if you don’t ask me, is still makes for a damn fine experience, I’m just not telling you.

Which is your loss, really.
1 Like

Another “interesting” phenomenon that seems to be associated with the change from pulseaudio to pipewire-pulse.

Whenever Audacious changes track and there’s a different number of channels in the new track (ie going from a mono track to a stereo one or vice-versa), the balance immediately jumps from centre to left.

Playing around with the output settings, I’ve found that changing the output plugin from PulseAudio to SDL seems to fix it, though I’ve no idea what the implications of making this change are.

[Edit]: curious. Certain (low-quality) podcasts end up with unpleasant artefacts when using SDL, so evidently that’s not going to be a good solution. I need to dig deeper.

[Edit 2]: as explained in this thread, pipewire is only actually required if the pulseeffects package is installed. So removing that and reinstalling the original pulseaudio solves all the problems.

No problem (aside the window grub one, but I don’t care about it, seen are ages that I want to erase the win partition; maybe it is the time I do it), so I marked the box “no issue”; thanks for the update. Just a question: why remove the os-prober recognition of win?

Apparently it wasn’t Manjaro but grub development team. (I might be wrong, but that’s how I understand it.)

1 Like

I experience random reboots after this update, how do I troubleshoot it ?

Well, try another kernel version first.

If that doesn’t work, see if you can find anything in the logs.

last reboot | less

Might help. Open another thread if you need more assistance.

Hope this helps!

Update on 12 Systems without Problems.