[Stable Update] 2021-03-08- Kernels, Plasma 5.21.2, Haskell, Kodi, Grub, KDE-Dev

I reject your whole premise since that subject is not related to receiving feedback about an OS update in the first place, so please stop bringing it up.

1 Like

:+1: :man_shrugging: :+1:

Xfce, Kernel 4.14; after appyling this update I faced a behaviour never seen before: all python applications were freezed and prone to crash (eg; sublime text and solaar); however: after a reboot (after every system update I have the habit to do a reboot) everything seems fine, I waiting for voting the poll.

Yay! All is fine :slight_smile:

Where does it say that though. My file doesn’t even contain the word ‘edit’
This is literally the file to make change to grub. Which then it turns updates the actual grub file when you do sudo update-grub
EDIT: I think you’re thinking of grub.cfg, which you indeed should not edit directly. But /etc/default/grub IS the file that you should edit for grub changes

1 Like

That’s right, my bad

I’m experiencing at least two issues on GNOME after updating.

  1. Bluetooth is behaving strangely. When I first log in, my Bluetooth mouse connects automatically, as it should. But my Bluetooth keyboard (Lenovo ThinkPad Trackpoint II) does not. When I go to the Bluetooth settings menu in GNOME, it lists the keyboard but fails to connect to it when prompted. In an attempt to resolve the issue, I select “Remove Device” in Bluetooth settings, then try reconnecting the keyboard as a new device. This initially appears successful, but this is where things get really odd. The newly connected keyboard is unresponsive. Then, moments after it connects, the Bluetooth settings menu refreshes and shows Bluetooth as being switched off. The dropdown menu on the GNOME status bar likewise says Bluetooth is switched off. But clearly Bluetooth is not actually switched off, because the Bluetooth mouse continues working the whole time. I tried to tinker by launching bluetoothctl on the command line, but it hangs on launch while the GNOME Bluetooth settings are showing this weird state. For reference, I’ve already tried rebooting a couple times and the whole sequence above repeats each time.

UPDATE: No fix yet, but I’ve opened a new thread on the issue here.

  1. My other problem is simpler (I hope). A couple applets aren’t appearing on startup like they usually do, despite still being listed as startup applications in the GNOME tweak tool. mntray, for example no longer appears in the taskbar, though it appears to be running in the background, as attempting to start it in the terminal results in the error, mntray already running, exiting (it also shows up in the list of running processes output by ps aux).

UPDATE: This config file modification alleviates the mntray issue.

1 Like

Try downgrading powerdevil to 5.20.5.

Me too, Thanks!

I had an issue after update and following the recommended reboot, Manjaro do not detect my synaptic touchpad, i installed then the xf86 for synaptic, reboot and the same. I test with an usb mouse and recognize it normally but touchpad nothing. Then I reboot again and tried to change kernel options (I have others installed too by Manjaro’s recommendation) and surprisingly the keyboard doesn’t work in grub but when it comes to lightdm and xfce desktop it works normally. I reboot once again and probe the keyboard with my BIOS and everything works fine, then out of it when comes into grub again it doesn’t worked but it was fine into login and after login.

Solution you may asking?

Well, I theorize that some PC’s (and exceptionally in majority laptops) when you put shutdown, they do not always do entirely so, to solve some problems related to possibly bad access in memory you need to disconnect from the power source and retire battery. After that, no problems at all in any phase during switched on.

I haven’t updated yet as I have a manjaro - W10 dual boot setup (two different physical hard-drives).

Can I add GRUB_DISABLE_OS_PROBER=false to /etc/default/grub and do a sudo update-grub before the update to avoid the problem right away or does the update itself change this property in the /etc/default/grub-file?

Thank you very much in advance. :slight_smile:

I added the grub_disable_os_prober=false line to /etc/default/grub prior to applying the updates and everything was fine after applying and rebooting. My dual boot setup remained. You won’t need to do the sudo update-grub after added the line as it’ll happen after updating.


That will work also. Your configuration file should’t get overwritten or replaced during the update. Instead, a .pacnew file is placed alongside /etc/default/grub.

In general: Make sure to look for .pacnew files in /etc regularly and merge them back to the corresponding configuration files as described in my previous post.

1 Like

Really wonder what the issue was. I have two computers on KDE and they have been receiving updates for about two years now, and there have been a few fixes along the way, nothing major. It is strange that you are having so much difficulty. Unusual hardware? Packages added from AUR? Custom scripts?

I guess I had the opposite experience, Mint would break in a month. I kept trying it for the guest gaming computer, but finally gave up.

Could you be more specific which line it needs to be added to?

I had exactly the same issue. I then ran
pamac install manjaro-pipewire
from Known issues and solutions above ( Pulseeffects stopped working)
The update completed with no other issues. Audio on youtube still seems to work so I think this solved it.


Thanks a lot. But i do not use powerdevil (plasma). I use Gnome and the software “thinkfan”. Any idea?

To it’s own line anywhere. It doesn’t matter the placement.

1 Like

Does anybody have an idea?

But what is the output of systemctl status thinkfan.service?
Consider to open a discussion in the “Support” section:

Support - Manjaro Linux Forum

You will have more chanches to have more attentions about.

Long shot, but maybe check the .conf files and make sure they are valid? Or try a different kernel?