[Stable Update] 2021-02-28 - Kernels, Plasma 5.21.1, Frameworks 5.79, Firefox, Thunderbird, Python

Thanks @Fabby !

Update: I uninstalled plasma-desktop by not paying attention.

All seemingly went well at first on my KDE system, but after a second reboot (upgrading to kernel 511), the desktop is just a blank black screen. Everything works (krunning, Yakuake, keyboard shortcuts, bluetooth, etc.) but there is no wallpaper nor does my panel load.

I hopped back over to kernel 510 but the problem persists. Logs are full of kwin and other plasma/kde warnings and errors. I found and followed this Arch forum post that addresses the kwin keymap logs, but it did not help my overall situation.

Journalctl info (journalctl -b -p warning): journalctl - Pastebin.com

we have the list in the update announcement

This list comes from boxit but not easy to read

Otherwise, before update, we have branch-compare:
if a package is tag “n/a” in testing or unstable: it will be removed in stable (exists a filter on this page)

for me, i have only flatix-theme flatix-theme-dark ht irccat lrcalc1 refind-theme-maia removed …

1 Like

In KDE, the wallpaper disappeared and I can’t right-click on the desktop to restore it. The menu doesn’t appear when right-clicking.

Thank you.

If a user has VerbosePkgLists enabled in /etc/pacman-conf I wonder if that would contain similar info as boxit. With that option set, along with the package name, Old Version, New Version and Net Change are listed. It seems to list the added (Old Version empty), but nothing for the removed. I suppose the user finds out by getting a pacman dependency error, and then asking in the forum. I haven’t used a rolling release long enough to know if this happens often and how to address it efficiently.

Did you reboot after the update?

1 Like

I had a similar issue, and for me the issue was I forgot that I had installed kwin-lowlatency. I had meant to uninstall that before I went to 5.21, but hadn’t. So I simply installed kwin, rebooted and I had my desktop again. So hopefully you have the same problem.

Unfortunately just regular kwin here :confused: Thanks for the info though.

XFCE + 5.10.18 all good, as always.
I wish GNOME was as stable and functional as XFCE …


Odd … after the fourth reboot it worked out.

i heard pamac has a small bug its better to use sudo pacman -Syu i always use the terminal and never have an issue

1 Like

System76 Oryx Pro running Manjaro KDE
Update went very smooth. The download was slow, but that’s probably a demand issue. Restarted and updated the Kernel. After restart 5.11 shows as installed but not running. Probably inexperience here, but I can’t for the life of me figure out how to make it active.

optimus-manager-qt requires optimus-manager 1.4,you need to wait for Manjaro to update the one in the repos to 1.4 and then you update the optimus-manager-qt,so wait for now.

Did you select the kernel in the GRUB?

1 Like

Got it. Thanks! And no, I did not select it in GRUB. My past experience has been that it just chooses the most recent kernel. I’ve never had to manually change it.

1 Like
  1. I replaced mesa-git and lib32-mesa-git with mesa and lib32-mesa respectively.
  2. Updated system
  3. Then replaced mesa and lib32-mesa with mesa-git (AUR) and lib32-mesa-git (AUR) respectively.
    (the community/multilib versions are only named “git” but have nothing to do with “git” really)

Check this post I made on Testing branch, it is easy to get the old one back
I made a tutorial actually


No issues on reboot. However I noticed that the icons on the new plasma taskbar are bigger than before. I ran xrandr because I thought the update changed my res but confirmed that’s not the issue.

How do I change the icon size of the apps on the taskbar? I don’t see the option in the menus when I right the bar.

Also it’s only the app icons on the left side of the bar the right side icons are expected size. Was this done by the plasma team on purpose?

Same issue here, for me I uninstalled ksysguard and I think that might be part of the problem. After installing it back I notice that plasma-desktop wasn’t installed so I did it and I got almost everything back. Had to mess around a bit to get latte-dock back, but everything seems to be working now.

Hope it helps.

1 Like

Yep, exactly that :man_facepalming: I also uninstalled ksysguard to go and install the new system monitor (only to learn ksysguard is a dependency on plasma-systemmonitor). Plasma-desktop was dependent on ksysguard. My fault for not reading when removing packages.

Thanks for the help

Dude you need to look what it uninstalls when you uninstall one package and you see a bunch of other packages…

pamac remove ksysguard
Checking dependencies...

To remove (5):
  plasma-desktop        5.21.1-1                           extra
  accountsservice       0.6.55-3                           extra
  polkit-kde-agent      5.21.1-1                           extra
  plasma-systemmonitor  5.21.1-1  (Depends On: ksysguard)  extra
  ksysguard             5.21.1-1                           extra

//EDIT: at least you have the list of what you probably removed now. You should use TimeShift to create system backup, in case of ‘dumb’ things like that, sometimes you can really mess the system to a difficult state to recover. TimeShift allows you to go back to previous system state :wink: