[Stable Update] 2021-02-09 - Kernels, Gnome 40-Alpha, KDE Apps 20.12.2, Systemd, Mesa, LibreOffice

Update went fine here. Manjaro KDE with Kernel 5.9 on AMD Ryzen 7 with iGPU. So far so good. I’ll give a try to other kernel versions later.

Thanks Manjaro team for the great work!

I’m getting the following errors…

    error: filesystem: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is invalid
    :: File /var/cache/pacman/pkg/filesystem-2021.01.19-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] 
    error: gcc-libs: signature from "Allan McRae <me@allanmcrae.com>" is invalid
    :: File /var/cache/pacman/pkg/gcc-libs-10.2.0-6-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] 
    error: failed to commit transaction (invalid or corrupted package)
    Errors occurred, no packages were upgraded.

Plasma seems to be broken for me after this update. My application drawer doesn’t work at all, any control actions like Alt+Space or changing sound level from keyboard don’t work and then they randomly happen after a minute or so.
Also, at every reboot, I have to relog to chrome?

Kernel 5.10 and 5.4, nvidia drivers 460

errors I get:

kernel: nvidia-gpu 0000:06:00.3: i2c timeout error e0000000
kernel: ucsi_ccg 0-0008: i2c_transfer failed -110
kernel: ucsi_ccg 0-0008: ucsi_ccg_init failed - -110
systemd-coredump[1788]: Process 1334 (baloo_file) of user 1000 dumped core.

Since the new update Dolphin doesn’t save the previous opened folders after an update and I can’t open any .exe with wine. Steam proton works fine, though

I also had a geoclue issue that I noticed because Redshift gave me an error. Since I didn’t want to set fixed coordinates, I read around a bit. I don’t understand what exactly it is or why it worked before, but the problem was that /usr/lib/geoclue-2.0/demos/agent wasn’t started, apparently.

Since I use i3, I fixed it by adding this to my ~/.config/i3/config:

exec --no-startup-id /usr/lib/geoclue-2.0/demos/agent
1 Like

That needs some more probing so open a new issue in the #support:graphic-cards category and provide more information there and link to this post and mention @Fabby

1 Like

Hi, I’ve got a problem since the update. My touchpad just stopped working.

My current setup:

  • Thinkpad P14 (identical to the T14) with a Ryzen CPU.
  • KDE
  • Kernel: 5.9.16-1

Does anybody encounter a similar issue?

Using version 5.10 of the Kernel solved the issue.

That is due to the latest update of papirus icon theme

seems there were some issues with extramodules on linux510. pushed now a new kernel:



May be related to the issue reported by @cryptocurious .

Great update! No issues! Everthing ok in KDE
Thanks Manjaro Team :grinning: :+1:

A post was split to a new topic: Error with wps-office

Hey guys, I made my update today. GNOME.
Had the issue with the locale, otherwise it looks good.
I applied the fix as mentioned here and it worked.


1 Like

Updated successfully without any problems.

Running 5.4.95, KDE Plasma

Thanks, Team!!

Grub created a pacnew:

warning: /etc/default/grub installed as /etc/default/grub.pacnew

which is remonving the apparmor activation:

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"


GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"  

Is it safe to replace with pacsave?

dav1d update seems to have caused a lot of problems. A lot of software, including OpenMW and a bunch of KDE stuff like Kontact are failing to start because they can’t find libdav1d.so.4 because it’s now libdav1d.so.5.

That’s why the update creates a .pacnew: for you to decide whether to keep apparmor or not. (I kept it)



I just upgraded and try to fix the PulseEffects issue.

I figured there is a manjaro-pipewire in the Community repo, and one in the Extra repo. Even after refreshing databases. Which one to pick?

Also, at both of them, I get opted to get pulseaudio removed:

    ✔ ~ [master L|✚ 1] 
23:14 $ LANG=C yay -Ss manjaro-pipewire
community/manjaro-pipewire 20210102-1 (7.7 KiB 0.0 B) 
    Meta package for pipewire support.
extra/manjaro-pipewire 20210109-1 (2.1 KiB 0.0 B) 
    Meta package for pipewire support.
✔ ~ [master L|✚ 1] 
23:15 $ LANG=C yay -S manjaro-pipewire
resolving dependencies...
looking for conflicting packages...
:: pipewire-pulse and pulseaudio are in conflict. Remove pulseaudio? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: pipewire-pulse and pulseaudio are in conflict
error installing repo packages

While I would love to remove any farts of Lennart Pöttering off my system (without removing any functionality), removing pulseaudio would likely result in a machine with not working audio.

Any ideas? :thinking:

Install PulseEffect Legacy (version 4.xx) from AUR OFFICIAL REPOS (just noticed it is in the Manjaro repos), as suggested on PulseEffect official documentation, if you don’t use PipeWire.

1 Like

KDE, Linux510: Update went mostly fine for me. Restarted just fine. Xpad & KGet wouldn’t open. After one restart Xpad came back, but KGet did not. Several restarts later, no difference. Launching from terminal only gives me this:

Icon theme "ubuntu-mono-dark" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.

All other Plasma apps (that I’ve tried) seem to run fine. Everything else is is doing great. Thank you and keep up the great work!