Something's broken after 2021-02-09 stable update


After the update it seems that my Plasma is broken. The application drawer/toolbar doesn’t work at all - it’s neither interactable nor it actualises status (e.g. clock). Actions like Alt+Space (KRunner?) or changing volume work after a huge delay (like 1 minute?). MangoHud and switching apps with Alt+Tab works. Switching desktops/workspaces doesn’t. Games work fine.

After running journalctl -p err -b I get:

kernel: nvidia-gpu 0000:06:00.3: i2c timeout error e0000000
kernel: ucsi_ccg 0-0008: i2c_transfer failed -110
kernel: ucsi_ccg 0-0008: ucsi_ccg_init failed - -110
systemd-coredump[1788]: Process 1334 (baloo_file) of user 1000 dumped core.

I have no idea what to do next.

I have nvidia 460 driver and tried on 5.10 and 5.4 kernels.

I’m not sure if its graphics card issue but @Fabby asked me to post it here for more probing.

EDIT: I’ve also just noticed a new thing - some kind of loading started: 2021-02-11_11-03
then I got a notification from Plasma: “Error Malformed Url”. And everything apart from KRunner started to work normally(?). That’s however after multiple reboots and using the system for ~10 hours.

1 Like

Does this also happen in a newly created user? (E.G. jango2)

Can you also post an inxi --admin --verbosity=7 --filter --no-host --width which would be the minimum required information we need to continue looking into this… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)


Ok so this is very weird for me. I created a new user, everything worked fine. Now I rebooted into my account and everything works fine, despite it didn’t work after multiple reboots I had before.

The only thing I did today was downloading updated kernel 5.10 related files - however after rebooting it didn’t work. Should I close this thread? I’m so confused.
I still have this nvidia timeout error in log.

here's inxi:
  Kernel: 5.4.95-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=ab088bab-04ae-4641-90c1-111ffa0d2f48 rw quiet apparmor=1 
  security=apparmor resume=UUID=bf80c539-0561-49b7-8bd8-714c8b718028 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: AB350M-DS3H V2 v: N/A 
  serial: <filter> 
  Mobo: Gigabyte model: AB350M-DS3H V2-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F50 date: 12/02/2019 
  RAM: total: 15.65 GiB used: 2.61 GiB (16.7%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701013 
  L2 cache: 3 MiB bogomips: 86268 
  Speed: 3592 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 3592 2: 2051 3: 2142 4: 3578 5: 2053 6: 2095 7: 1979 8: 3065 9: 3593 
  10: 2046 11: 2053 12: 2079 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs irperf lahf_lm lbrv lm 
  mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc 
  nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq 
  pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse 
  pse36 rdpid rdrand rdseed rdt_a rdtscp rep_good sep sev sha_ni skinit smap 
  smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm 
  svm_lock syscall tce topoext tsc tsc_scale umip v_vmsave_vmload vgif 
  vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: Gigabyte 
  driver: nvidia v: 460.39 alternate: nouveau,nvidia_drm bus ID: 06:00.0 
  chip ID: 10de:2187 class ID: 0300 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.0x10.7") 
  s-diag: 554mm (21.8") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102 
  size: 480x270mm (18.9x10.6") diag: 551mm (21.7") 
  OpenGL: renderer: GeForce GTX 1650 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39 
  direct render: Yes 
  Device-1: NVIDIA TU116 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 06:00.1 chip ID: 10de:1aeb 
  class ID: 0403 
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 08:00.4 chip ID: 1022:1487 
  class ID: 0403 
  Device-3: Logitech Webcam C170 type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 1-6:3 chip ID: 046d:082b class ID: 0102 
  Sound Server: ALSA v: k5.4.95-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8168 v: 8.048.03-NAPI modules: r8169 port: f000 
  bus ID: 04:00.0 chip ID: 10ec:8168 class ID: 0200 
  IF: enp4s0 state: down mac: <filter> 
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: f000 
  bus ID: 05:00.0 chip ID: 8086:2526 class ID: 0280 
  IF: wlp5s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-3: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
  bus ID: 1-7:4 chip ID: 8087:0025 class ID: e001 
  WAN IP: <filter> 
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
  v: 0.8 bus ID: 1-7:4 chip ID: 8087:0025 class ID: e001 
  Report: ID: hci0 state: up running pscan iscan bt-v: 3.0 lmp-v: 5.1 
  sub-v: 100 hci-v: 5.1 rev: 100 address: <filter> 
  Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff 
  link-mode: slave accept 
  service-classes: rendering, capturing, object transfer, audio 
  Message: No RAID data was found. 
  Local Storage: total: 931.51 GiB used: 729.68 GiB (78.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 023 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw size: 914.01 GiB size: 898.66 GiB (98.32%) 
  used: 729.68 GiB (81.2%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: ab088bab-04ae-4641-90c1-111ffa0d2f48 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 9D50-4D3E 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17.21 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: bf80c539-0561-49b7-8bd8-714c8b718028 
  Message: No Unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 1-4:2 info: Dell Universal Bluetooth Receiver 
  type: Keyboard,Mouse,HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0 
  speed: 12 Mb/s chip ID: 413c:301b class ID: 0300 
  Device-2: 1-6:3 info: Logitech Webcam C170 type: Video,Audio 
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 046d:082b class ID: 0102 
  Device-3: 1-7:4 info: Intel Wireless-AC 9260 Bluetooth Adapter 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 8087:0025 class ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  Hub-5: 5-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 5-4:2 info: Microdia USB DEVICE type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 0c45:8508 class ID: 0301 
  Hub-6: 6-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  System Temperatures: cpu: 38.9 C mobo: N/A gpu: nvidia temp: 46 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 308 Uptime: 5m wakeups: 0 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 Packages: 1603 pacman: 1600 lib: 449 flatpak: 0 snap: 3 
  Shell: Bash v: 5.1.0 running in: yakuake inxi: 3.3.00

Let’s close this topic: Either the new kernel update or the new user fixed it.

One last piece of advice:

 Kernel: swappiness: 60 (default) cache pressure: 100 (default) 

For a machine with 16GB of RAM, create the following file:


and add the following into it:

# janquo: 2021-02-11: change "swappiness" from default 60 to 10:
#  Theoretically, only swap when RAM usage reaches around 80 or 90 percent
vm.swappiness = 10

# janquo: 2021-02-11: Lower vm.vfs_cache_pressure to 75%
# (once cached, probably not immediately needed any more)
# This percentage value controls the tendency of the kernel to reclaim
# the memory which is used for caching of directory and inode objects.
# At the default value of vfs_cache_pressure=100 the kernel will attempt to
# reclaim dentries and inodes at a "fair" rate with respect to pagecache and
# swapcache reclaim.  Decreasing vfs_cache_pressure causes the kernel to prefer
# to retain dentry and inode caches.
vm.vfs_cache_pressure = 75

In a nutshell: the system will swap out later (only at 90% memory utilisation, and once swapped out, not try to swap in immediately as memory becomes available… (snappier performance under high load)


Thanks a lot!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.