[Stable Update] 2021-01-19 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

I just removed then add the Whisker menu in the panel, and that made favorites come back…Slightly different behavior after that, nice improvement IMHO.

Thanks a lot. Everything is running smoothly after I followed your instructions.

Some of my icon is broken too (the battery icon became too big and the show desktop icon became blue). Have you found a way to fix the broken icon?

I had also a little warning in MenulLibre editor about usr/share/applications/org.kde.kded5.desktop invalid type - maybe that was there before the update, I rarely use this stuff, I just had to change the type from “Service” to “Application” in this file to get rid of the warning.


For future reference, first you rebuild the kernel images mkinitcpio -P, and only then you update-grub.

As for updating the system with yay, I don’t think that was the issue. I don’t use yay, but I assume it updates the system from the distro repositories before updating AUR packages. Personally, I always update the system first, with pacman, and only then update AUR packages.

You probably installed your system before the package linux-54-nvidia was created. With this package installed, these modules will be kept up to date.

If I’m not wrong, -uu upgrades and also downgrades some package if repository has older version.

Who knows that your problem does not arise from this.

So, I it is better stay on
sudo pacman -Syyu or -Syu

It’s Xfce issue, because some applications doesn’t display proper icons in the system tray as well.
Also some of the Xfce’s goodies are having issues as well, like the Notes not having the change color option.

Hi community!
Great update, here seems stable.

But my connection is dropping, I use wifi and wired connection, did I miss some config?
If I use only wifi or wired the connection stabilize.

The update went smooth but I was kinda tricked into updating as I got a notification for an update to google chrome only, decided to let it update but after pamac checked the mirrors it decided to just download everything without properly informing me on what it was about to do.

Hi @nickcagenick,

I might be wrong, but AFAIK you can and should only use 1 connection per network at a time. Or that was last time I checked. With that in mind, what you’re describing makes sense.

I don’t know if it’ll help/make sense, butt I hope it does.

yes it may be true

on the last update I used both connections without problems.
The wifi I only use because of kdeconnect, otherwise I would only use the network cable

Hi @acca85, and welcome!

That is the nature of a rolling release distribution like Manjaro. When you update one thing, everything gets updated.

some users at Ubuntu use wifi and wired connection at same time with NetworkManager:

I’m not saying it’s recommended, but that it’s possible

I don’t even have a wireless card. I only have a cable to my PC. I do have a wireless network, though, for the phones, tablets and laptop.

But I don’t have or want it for my PC.

1 Like

For the missing standard Favorites in the Whisker menu (XFCE) I have a manual fix:

  • Open Edit Menu (right-click),
  • Create a new folder, name it Favorites (german “Favoriten”),
  • Create a new starter named Filemanager (german “Dateiverwaltung”) with the commandline copied from the filemanager entry at the bottom of the list,
  • Open the menu, search for Filemanager (“Dateiverwaltung”),
  • Right-click, Add to Favorites,
  • Repeat Search and Add for the standard Favorites missing,
  • Remove additional Starter and Folder.

That fixed it for me.

Regarding the Powermanagement icon issue see the answer to Reply 31 here in this thread - see /t/stable-update-2021-01-19-kernels-xfce-plasma-pulseaudio-pipewire-mesa-firefox-thunderbird-kde-apps/49391/32.
+++ The developer on xfce-org (see link in above mentioned answer/reply) advised for XFCE4 panel users not to use the tray icon but the panel plugin. I followed the advise - when I added the power manager plugin to the panel, the tray icon was automatically disabled - now I have a battery-shape icon on my desktop, too, the ‘no icon’ icon is gone. To me a battery is even more intuitive than a plain circle with a very small flash in the center. Just need to get used to that additional tray icons appear right hand of the battery. +++ Maybe this setting should be adopted by the Manjaro XFCE default setup? +++
(UI does not allow me to insert a small screenshot or links…)

There’s another thread about the Whisker menu with a fix in this forum: /t/start-menu-disappeared-after-update/49515/3
(Sorry, you’ll have to copy the path yourself to the address bar, the UI doesn’t allow me to insert links.)



No, that’s an old thing.

1 Like

Same problem with Failed to start Load Kernel Modules.
I tried kernels:

Hi @pixel,

AFAIK there never was a mhvd, but rather an mhwd. And it’s still there and present. I used it earlier.

A post was split to a new topic: Spyder: cannot open/save files due to segfault

Hi @Leebut,

  • I recommend booting with a live ISO.
  • When everything is done and it’s booted up, start a terminal.
  • Enter manjaro-chroot -a to enter a chroot for your installation.
  • When inside the chroot environment, install/update the graphics card drivers as neccesary.
  • reboot.

It should be fine now. At least, mine was a few hours ago.

1 Like