[Stable Update] 2021-01-19 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

all went fine for me on the reboot for kde. Only thing I noticed was that the manjaro boot menu doesn’t show anymore.

Have a problem with suspend. After suspend notebook immediately wakes up. Then try suspend again and again wakes up. This messages i can see:

[ 1576.610062] ieee80211 phy0: brcmf_inetaddr_changed: fail to get arp ip table err:-52
[ 1586.095105] brcmfmac 0000:02:00.0: brcmf_pcie_pm_enter_D3: Timeout on response for entering D3 substate
[ 1586.095148] PM: pci_pm_suspend(): brcmf_pcie_pm_enter_D3+0x0/0x180 [brcmfmac] returns -5
[ 1586.095164] PM: dpm_run_callback(): pci_pm_suspend+0x0/0x160 returns -5
[ 1586.095172] PM: Device 0000:02:00.0 failed to suspend async: error -5
[ 1586.095400] PM: Some devices failed to suspend, or early wake event detected
[ 1593.348248] brcmfmac 0000:02:00.0: brcmf_pcie_pm_enter_D3: Timeout on response for entering D3 substate
[ 1593.348298] PM: pci_pm_suspend(): brcmf_pcie_pm_enter_D3+0x0/0x180 [brcmfmac] returns -5
[ 1593.348304] PM: dpm_run_callback(): pci_pm_suspend+0x0/0x160 returns -5
[ 1593.348310] PM: Device 0000:02:00.0 failed to suspend async: error -5
[ 1593.348457] PM: Some devices failed to suspend, or early wake event detected

There is a hissing sound in the headset after updating to the latest manjaro version,I don’t know why.

Everything works fine, except it borked Far Cry 5. Other distros say to avoid nvidia’s 460 drivers. How do I use 455 again?

Everything went perfectly fine in both KDE and XFCE machines and one KDE VM. Thanks Manjaro team! :pray:

I updated the system while playing a game and nothing even disturbed me. Nice job you’ve done here!

That was a flawless update for me. :smile:
Thanks Manjaro Team! Kudos !! :+1:

Was paranoid my nVidia card’s drivers were dropped. It looked as if it was/would be. So I disabled updating them in /etc/pacman.xonf with IgnorePkg:

IgnorePkg = lib32-nvidia-utils linux510-nvidia linux54-nvidia mhwd-nvidia mhwd-nvidia-390xx nvidia-utils

Did the upgrade and everything went well.

Rebooted and sure enough, as @Phokopi said, I couldn’t boot with error,

Failed to start Load Kernel Modules

So I rebooted with a live ISO and did a manjaro-chroot -a into the installation.

There, I commented out the IgnorePkg line, to unignore my nvidia drivers. Silly, I know. I then ran pacman -Syyu again, and it showed me that my 455xx (or something) drivers will be upgraded to 460xx (or whatever, can’t remember exactly now.) Which suits me just fine! Especially seeing as I read somewhere that 460xx (once again, I think that’s it) is nvidia’s next Long life (I think, but it’s similar to LTS) driver. (By the way, is there a way to confirm this?)

After installation was complete, I rebooted and my system is once again working like a charm.

Thank you VERY much to team Manjaro for the excellent work you do!!! I still feel like this is my home. Thank you. Thank you. Thank you!

The service still won’t work if the following is not in order:
“These services are started at boot if passno in /etc/fstab for the file system is set to a value greater than zero”.
See man systemd-fsck-root.service

I cannot upgrade due to a tricky package conflict with pulseaudio-git (yes, an AUR package, but one I needed for hardware support). I get the following message when attempting ‘pacman -Syu’:

looking for conflicting packages...
:: libpulse and pulseaudio-git are in conflict (libpulse.so). Remove pulseaudio-git? [y/N]

Declining to remove pulseaudio-git aborts the upgrade (“error: unresolvable package conflicts detected”), and opting to remove it also causes the update to error out with the following dependency errors:

error: failed to prepare transaction (could not satisfy dependencies)
:: removing pulseaudio-git breaks dependency 'pulseaudio-bluetooth' required by gnome-bluetooth
:: removing pulseaudio-git breaks dependency 'pulseaudio-bluetooth' required by manjaro-bluetooth
:: removing pulseaudio-git breaks dependency 'pulseaudio-equalizer' required by manjaro-pulse
:: removing pulseaudio-git breaks dependency 'pulseaudio-jack' required by manjaro-pulse
:: removing pulseaudio-git breaks dependency 'pulseaudio-zeroconf' required by manjaro-pulse
:: removing pulseaudio-git breaks dependency 'pulseaudio-lirc' required by manjaro-pulse

I can’t temporarily remove any of the packages that require pulseaudio-git, either, as they’re required by yet other packages, which are required by yet other packages.

Attempting to install vanilla pulseaudio in place of pulseaudio-git is also a non-starter, as it yields the same initial error message as above (“libpulse and pulseaudio-git are in conflict (libpulse.so).”, etc.).

Any help climbing out of this rabbit hole would be greatly appreciated.

You could try this;

sudo pacman-mirrors --fasttrack && sudo pacman -Syyu

It refreshes the mirror list and forces the updates through. Hope it helps

No. There’s an error. The second sudo shouldn’t start with a capital.

sudo pacman-mirrors --fasttrack && sudo pacman -Syyu
1 Like

Thank you! It was an error, I am typing from my phone.

No worries, man!


Had the same issue.
To solve it add this line
to ~/.config/xfce4/panel/whiskermenu-8.rc

Still have issues with xfce power manager icon, and few broken icons in the xfce, so I guess xfce have few other issues regarding the icons.
On the other hand I got the proper good looking fonts back.


Hello, everyone…

Just wanted to say all went good kernel 5.4 LTS - XFCE 4.16 .
So far so good, no errors, no problems. The font looks little bit tight, but oki.

Thanks ManjaroTeam :ok_hand: :beers: :slight_smile:

Hahaha…you literally got my back​:joy::joy::joy:.

I found another issue, this time on my desktop. It had no sound and integrated sound card wasn’t detected at all. It happened because pulseaudio replaced my ~/.config/pulse/default.pa user file. I need to set my default card in this file, otherwise it isn’t available. I’m yet to comprehend why pulseaudio replaces user files with a copy of /etc/pulse/default.pa. It makes no sense.

Kernel: linux54.
GPU: Nvidia GTX 1060
CPU: i6700k
RAM: 32G

Updated yesternight, using

yay -Syyuu

That seemed to have gone well, but my system didn’t boot into KDE, anymore.

I’m running KDE on X11 (tried to switch to wayland, some time ago … with no luck … so I feared, that maybe this could play into my problem).
I also have the line

Failed to start Load Kernel Modules

3 times. And then it hangs there forever.

So I used CTRL+ALT+F2 to switch to another TTY and logged in with my user.

pacman -Scc && pacman -Syyuu
yay -Scc && yay -Syyuu

and rebooted … with no luck.
Then started google’ing and tried

mkinitcpio -P

also with no luck.
Tried re-installing the kernel and saw, that it misses headers for compiling DKMS for virtualbox. So I installed the headers, and tried the above again (update-grub and mkinitcpio).

After all that, I got the

Failed to start Load Kernel Modules

only 2 times, instead of 3 times.

Then I’ve noticed, that linux54-nvidia-455xx nvidia-455xx-utils were still installed, but the mwhd had been updated to 460xx (finally found my problem).

So I ran

pacman -S linux-54-nvidia

I got asked, whether I wanted to replace the 455xx (and utils) with the 460xx version … to which I replied: “Y”.
The installation went well without any further naggings.

After a shutdown -r now , my system was booting fine, again.
Didn’t see anything else (yet) that doesn’t work.

I love manjaro, but those kinds of problems are really annoying and time-consuming and seem to be preventable (I might be wrong).

Is it my fault for using yay -Syyuu to do the upgrade?
Or would this have happened with pacman -Syyuu, too?

Hi @cefk,

I don’t think it was a mistake, as mine did it with pacman -Syyu as well.

As for preventable, nobody can know what’s going to happen to everyone. Even less do with the size of the Manjaro team. Compare it to Microsoft, while they have a LOT more people on it, they also have regular problems.