[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Hello. The update dialog is asking me to do the following:

[ALPM-SCRIPTLET] >>please run /usr/bin/cups-genppdupdate
[ALPM-SCRIPTLET] >>and restart cups daemon

I tried opening a terminal and entering the command:


And I received:

No Gutenprint PPD files to update.

And then I entered:

restart cups daemon

And I received:

bash: restart: command not found

How should I proceed?

Do I need to follow this first

and then do what the ALPM-SCRIPTLET says?

Thank you.

warning: sndio: local (20180120-1) is newer than community (1.7.0-3)

their version numbers seem rather different. should I force downgrade, because it may be actually upgrade afterall?

1 Like

Installed it. How do I use it? reb[tab] only summoned “reboot” to cli :smiley: is there a command I can actually run to detect the need?

1 Like

Had the same issue. Turns out it is checkrebuild instead of rebuildcheck or whateva :sweat_smile:

It should trigger by itself as a post upgrade hook anyway I think.

Thats not a command per se, just thing to do for you. To restart cups:

$ systemctl restart cups

If you’ve already rebooted, that would be moot though.

1 Like
[deemon@Zen ~]$ checkrebuild 
foreign	codelite
foreign	gns3-converter
foreign	gns3-gui
foreign	gns3-server
foreign	libselinux
foreign	libunity
foreign	packettracer
foreign	piper-git
foreign	python-aiohttp-cors-gns3
foreign	python-aiohttp-gns3
foreign	python-async-timeout-gns3
foreign	python-multidict-gns3
foreign	python-prompt_toolkit-gns3
foreign	python-sentry_sdk
foreign	python-zipstream-gns3
foreign	wattman-gtk-git
foreign	zoom
[deemon@Zen ~]$ checkrebuild --help
/usr/bin/checkrebuild: illegal option -- -

now what? what does it mean? that I should upgrade all those packages or just that it detected and checked those packages? also there is no help available :smiley:

edit: testcase… started zoom and it started just fine without any rebuild need.

Yeah, that utility just does what it’s name says, it checks. Now I think you have to rebuild those packages. Like in manually reinstalling them the same way you did before.

Also apparently sometimes it flags some packages like needing a rebuild, but it isn’t the case. So it’s up to encountering a problem or not I guess…

1 Like

For each of the lines, for each packasge, you nead to tun pamac build.

For example:

pamac build codelite

Or that’s what I had to do anyway.

1 Like

Did rebuild couple of them. Only some of them disappeared from the next checkrebuild (codelite), some remained there even after clean rebuild (zoom).

1 Like

I have read, somewhere on the forums, that it can happen that they don’t disappear. I don’t know why this happens. But if they disappear this is what you want and all’s good. (AFAIK anyway.)

1 Like

Normal booting using 5.10 kernel wasn’t possible till today. Had to choose manually 5.9.

Simple solution:

sudo pacman -S linux510

Then reboot. It seems, that pacman had repaired grub/init/system-d whatever.

I’m happy now again. Hopefully this was my worst desaster on Manjaro forever :wink:

1 Like

Ah man, I love hearing success stories. And to achieve that success…it’s a wonderful experience!

1 Like

Do we have to change in /etc/systemd/homed.conf from ext4 to btrfs?

Apart from the boot partition, all is in ext4 on my computer…
Nevertheless, this line is commented both in the homed.conf and in its pacnew file.


Not likely, the approach used to remove all the various versions of nvidia drivers was the “rip the bandaid” off approach. I was running the latest kernel at the time before this update (5.9 and running the latest nvidia drivers (455 series) and when the update was over all nvidia drivers had been removed and I was on the free drivers. In my case this wasn’t a problem other than performance and was then able to easily update to 5.10 and add the nvidia drivers back however on some of the newer nvidia hardware the free drivers don’t work in which case being forced onto them will make it so you don’t get a desktop and have to switch to a terminal to manually make sure all the old drivers got remvoved properly and then install the new 455 or if you can’t run the 455 drivers the legacy nvidia driver.

So basically read these forums as there are excellent step by step directions of what you have to do and make sure you have some time to mess around with it and a good backup before you start and then just do it.

1 Like

checkrebuild in the command line

Use verbose mode checkrebuild -v to get a bit more information about why these packages are flagged.

FYI, that’s deprecated and won’t build anymore. You most likely don’t need it, anyway.


firefox-nightly seems to always be ‘detected’ due to some libs under /opt

It’s just a recommendation I guess. Maybe a newly installed system would use btrfs as default filesystem?

1 Like

I have a hybrid card intel/Nvidia Quadro T2000 on lenovo thinkpad p1, and ran the update and installed kernel 5.10. I also ran the nvidia driver install command mentioned in the first post using mhwd. The problem is that it won’t load the nvidia driver.

I did not run into any booting trouble. The nvidia driver 455 is installed but somehow did not load.

I found a fixed that worked for me. I unstalled the 390 and 340 drivers in pacmac, then installed mhwd and mhwd-db, and ran the 5.4 kernel. Now I see the hybrid drivers and I can also connect to an external screen via nvidia gpu. Using kernel 5.10 does not seem to work with this hardware or perhaps combined with cinnamon. It’s strange because it is recent hardware.

After the update, I can’t use hdmi audio anymore. The image works, but neither the setting nor pavucontrol recognize the hdmi output.

I also can’t remove neither pulseaudio nor pipewire, because both are system dependencies (only pipewire-pulse)