[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

@philm I am glad to help reporting issues.
I also noticed problems with Chromium:

Actually I’m not getting any audio from kernels 5.10 , 5.9 or 5.4

Which Hardware do u use?
Do u have tried 4.19?

As far as I know, after the upgrade your old virtualenvs will not work anymore, and you need to rebuild them. If you have the requirements.txt file, it should be straightforward. Otherwise, you need to remember all the packages you installed in the virtualenv… you may explore lib/python3.8/site-packages directory to see what you had in your old virtualenv.

People have mentioned here issues with Nvidia already, I’m running a laptop with an Intel GPU + 1050Ti and after the update and the reboot all is well, except for one major thing (for me) which is CUDA.

Running nvcc on a .cu works fine, but trying to run it after compiling gives:

the provided PTX was compiled with an unsupported toolchain.

I’m working to solve this ASAP because I need CUDA for a work I have to present due in two weeks, so any help is more than welcome.

Also I’ve always had issues with Nvidia as I only want the drivers to run CUDA, nothing else, I don’t want my X to be on the dGPU or play videogames, but I’ve always had issues to make this work. Before needing CUDA for school I was just using the Intel GPU and everything worked much better, will see how it goes from here with this new update.

Here are the packages installed on my system:

$ pacman -Qe | grep cuda
cuda 11.2.0-1

$ pacman -Qe | grep nvidia
lib32-nvidia-utils 455.45.01-3
linux54-nvidia-455xx 455.45.01-4
nvidia-455xx-utils 455.45.01-1
nvidia-prime 1.0-4

$ uname -a
Linux UD-Legion 5.4.85-1-MANJARO #1 SMP PREEMPT Mon Dec 21 21:38:53 UTC 2020 x86_64 GNU/Linux

After I installed this update I tried to install kernel 5.10 and I get the following error:
/usr/bin/grub-probe: error while loading shared libraries: libzfs.so.2: cannot open shared object file: No such file or directory
Running sudo update-grub gives the same error. I verified that I have zfs-utils installed.
The first time I installed Linux 5.10 I didn’t see the error and I also deleted Linux 5.9, not I only have the fallback kernel, 4.19.
Now I can’t make any kernel besides 4.19 which was already installed to show up in grub. Any help is appreciated!

EDIT: I fixed it by replacing grub-vanilla with grub.


the font is the same but looks different

I have an old nvidia gpu on that computer, had an issue after updating: black screen, no error.

Fixed by opening virtual console alt + shift + F2
installed nvidia drivers packet called linux510-nvidia

Works after that. :+1:

I have intel-nvidia hybrid card. GTX 850M. After the update nvidia-prime not working. Auto install not working. Any help?

Auto install proprietary driver gives me this error.

> Using config 'video-hybrid-intel-nvidia-prime' for device: 0000:00:02.0 (0300:8086:0416) Display controller Intel Corporation 4th Gen Core Processor Integrated Graphics Controller
> Dependencies to install:  video-modesetting
> Installing dependency video-modesetting...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/video-modesetting/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
> Successfully installed dependency video-modesetting
> Installing video-hybrid-intel-nvidia-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
warning: nvidia-prime-1.0-4 is up to date -- skipping
warning: lib32-nvidia-utils-455.45.01-3 is up to date -- skipping
resolving dependencies...
looking for conflicting packages...
:: nvidia-utils and nvidia-455xx-utils are in conflict (nvidia-libgl). Remove nvidia-455xx-utils? [y/N] error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

:: nvidia-utils and nvidia-455xx-utils are in conflict
Error: pacman failed!
Error: script failed!

Done ...

Hi! Just updated and I can’t run vorta, this is what I get:

Traceback (most recent call last):
  File "/usr/bin/vorta", line 33, in <module>
    sys.exit(load_entry_point('vorta==0.7.1', 'gui_scripts', 'vorta')())
  File "/usr/bin/vorta", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 790, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3.9/site-packages/vorta/__main__.py", line 9, in <module>
    from vorta.models import init_db
  File "/usr/lib/python3.9/site-packages/vorta/models.py", line 17, in <module>
    from vorta.utils import slugify
  File "/usr/lib/python3.9/site-packages/vorta/utils.py", line 22, in <module>
    from vorta.borg._compatibility import BorgCompatibility
  File "/usr/lib/python3.9/site-packages/vorta/borg/_compatibility.py", line 1, in <module>
    from pkg_resources import parse_version
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3239, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3222, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3251, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 567, in _build_master
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 884, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 770, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'apscheduler' distribution was not found and is required by vorta

Seems to be working now, I just rebuilt the packages python-apscheduler and then vorta itself

@rf2020 for nordvpn:

you need to create the system group manually and add yourself to that group:

sudo groupadd -r nordvpn
sudo systemctl enable --now nordvpnd.service
sudo gpasswd -a your user name nordvpn


And this is configured in the OS settings

Hi all!

I have an Intel-Nvidia Optimus Laptop, with manjaro KDE and kernel 5.4 LTS.
After updating to this new stable release, an old issue came up.
During shutdown i got this message

sd-unmount[xxxx]: Failed to unmount /oldroot: Device or resource busy
sd-unmount[xxxx]: Failed to unmount /oldroot/sys: Device or resource busy
shutdown[1]:Failed to finalize file systems, ignoring

I always thought this was an Nvidia driver or a systemd issue. But probably has something to do with manjaro mhwd scripts.

Here is how i solved it (or at least i think i solved it…)

  1. I removed video-hybrid-intel-nvidia-455xx-prime driver with
sudo mhwd -r pci video-hybrid-intel-nvidia-455xx-prime

but i kept video-modesetting intact

  1. I removed with pacman every Nvidia related package, leaving in the end only the mhwd-nvidia-xxx ones. These should not be removed! In the end, i have something like:
$ pacman -Q | grep nvidia

  1. I manually installed with pacman the following packages (in this order)

and the last one…

  1. I rebooted.

After that, no more errors, during shutdown. Both intel and nvidia drivers are loaded ( checked with inxi -Gxxxz ). And the Nvidia driver works on demand. Of course I’m not sure if there is any switching between the two drivers as I don’t know how to check it. Any help?

Otherwise, a flawless update.

Can you be more specific? I can’t find it.

Zeitgeist is an actual dependency of Pantheon Music, it’s not in Orphans, and if I try to remove it, pamac wants to remove Pantheon Music as well, so it’s not just a build dependency.

I’ll just go without a GUI file search until the conflict gets resolved.

No issues with update. After switching to 5.10 kernel, noticed a bit quicker system all around - nice. I went to delete 5.9 kernel but it would not delete, said it was needed by linux-latest. Space isn’t an issue so no big deal, but shouldn’t linux-latest point to 5.10?

Thank you for your reply, but this doesn’t change anything. In the new update the font looks more wide then the old one (but I can’t paste a link here).

Where do you see them broken?
On which environment? I am on Xfce and emojis are ok everywhere; tell us more to help you :slight_smile:

Another issue:
When in the xfce4-terminal i paste something, such text is higlithed: didn’t occurs before.