[Stable Update] 2020-11-22 - Kernels, Pamac, Gnome, Jade, OnlyOffice, Xorg-Server

Same here! Came to forum to see why I was getting a new kernel outside of a Stable update. :confused:


Perhaps this is a fast tracked security update hitting both channels?

can confirm. I am on stable and still got the update :slight_smile:

I have made the update on three computers:
1 * KDE and 2 * XFCE
All went fine.


1 Like

I’m unable to upgrade qt5-xcb-private-headers

:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "qt5-base=5.15.2", a dependency of "qt5-xcb-private-headers"
:: The following package cannot be upgraded due to unresolvable dependencies:

:: Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'qt5-base=5.15.2' required by qt5-xcb-private-headers

Kernel 5.9.10 show me in stable branch.

So please post about problems in the current stable announcement

Or just add a vote if there were no problems.

Are your mirrors up to date?


1 Like

I’m was using https://ftp.lysator.liu.se/pub/manjaro/stable/$repo/$arch

But I’ve also tried these mirrors with the same problem:

(I don’t particularly like running pacman-mirrors as it is only measuring ping time and not actual download speed.)

How can I check the update status of mirrors? If this status check could be scripted I could build a script that makes sure to never upgrade from a mirror that is in a half upgraded state.

I checked the package and qt5-base that I have installed, it is indeed at 5.15.1-3 instead of the required 5.15.2.


update ok, no problems but a (GNOME) question.

This got an update:
nautilus-typeahead 3.38.1 --> 3.38.2

This not:
Files (nautilus) 3.38.1

distrowatchcom reports: Latest Packages: nautilus 3.38.2

Does this mean that nautilus-typeahead 3.38.2 is in sync with nautilus 3.38.2?

Great update! Now Kernel 5.9 finally works on my laptop :smile:

I found Manjaro Repository, Status of mirrors: https://repo.manjaro.org/

All the mirrors I tested above are listed as “Up to date”.

1 Like

No, this script download pacman db file core for test file

exists ! pacman-mirrors use same api as <repo.manjaro.org> for test if mirror is updated, run it without parameter :wink:

1 Like

I see, thanks for clarifying.
I take it that it is not a mirror issue then?

(I’ve had much better luck with speed by picking mirrors manually than letting pacman-mirros pick them for me, I travel a lot a need to change mirrors often depending on the region I’m in.)

Just for brevity I ran pacman-mirror interactive mode checking all mirrors from Northeren Europe, it picked https://manjaro.moson.org which I tried before and that one does not have the newer version of qt5-base.

I also found “Discover Software”: Package - qt5-base - Discover Packages On Manjaro Linux

qt5-base is listed as being version 5.14.1-3 here so this page is not updated.

Great job !
linux59-nvidia-390xx finally released. :smile:

I fixed it by now.


A post was split to a new topic: Screen brightness issues

Just for quick feedback I no longer get the error message, after upgrading the mirror it no longer tries to upgrade the package qt5-xcb-private-headers.

I assume that is the correct fix, so thank you very much for the fast update!

Wasn’t there an update just like four days ago? Are there reasons for this?

1 Like

Hi, just a quick note. For some reason my last i3 config line which sets up a shortcut to change keyboard mapping is not enabled after the update:

exec "setxkbmap -option 'grp:win_space_toggle'"

i had to run setxkbmap -option 'grp:win_space_toggle separately and don’t know what caused this.