[Stable Update] 2020-10-01 - Kernels, Mesa, KDE-Framework, Deepin, Systemd, Pamac, Xorg-Server, Qt

9 posts were split to a new topic: Pacman says “there is nothing to do”

Thank you for your suggestion, unfortunately it didn’t work :frowning:


Cita System:    Kernel: 5.7.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.19.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81FB v: 330S-15ARR serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: 31900002 WIN serial: <filter> UEFI: LENOVO v: 7WCN37WW 
           date: 05/22/2019 
Battery:   ID-1: BAT1 charge: 25.9 Wh condition: 26.7/30.0 Wh (89%) model: LENOVO BASE-BAT 
           status: Unknown 
CPU:       Topology: Dual Core model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx bits: 64 
           type: MT MCP arch: Zen L2 cache: 1024 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 19969 
           Speed: 2070 MHz min/max: 1600/2500 MHz Core speeds (MHz): 1: 1556 2: 1603 3: 1576 4: 1591 
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] vendor: Lenovo 
           driver: amdgpu v: kernel bus ID: 03:00.0 
           Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus ID: 3-1:2 
           Display: x11 server: X.Org 1.20.9 driver: amdgpu FAILED: ati unloaded: modesetting 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.37.0 5.7.19-2-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.8 
           direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel 
           v: kernel bus ID: 03:00.1 
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A bus ID: 03:00.5 
           Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 03:00.6 
           Sound Server: ALSA v: k5.7.19-2-MANJARO 
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo 
           driver: rtl8821ce v: N/A port: 2000 bus ID: 01:00.0 
           IF: wlp1s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.82 TiB used: 233.67 GiB (12.5%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB 
Partition: ID-1: / size: 191.25 GiB used: 15.26 GiB (8.0%) fs: ext4 dev: /dev/sda7 
           ID-2: /home size: 1.31 TiB used: 218.41 GiB (16.3%) fs: ext4 dev: /dev/sda8 
Swap:      ID-1: swap-1 type: partition size: 8.01 GiB used: 0 KiB (0.0%) dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 50.5 C mobo: N/A gpu: amdgpu temp: 50 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 218 Uptime: 16m Memory: 6.76 GiB used: 2.31 GiB (34.2%) Init: systemd Compilers: 
           gcc: 10.2.0 Packages: 1308 Shell: Bash v: 5.0.18 inxi: 3.1.05

Hi there, my issue with this update was the black screen after updating Nvidia Driver non-free. Before I usually was able to clear out all problems in manjaro with this forum, through only reading.


But after this latest update am toally disrupted, cause the whole night yesterday and the one before I had tried to follow different gustos of the solution quest to why the screen went black after dating up from 440xx series to 450xx. http://mhwd install 440xx
Later the day I got all 450xx unqinstalled and “maybe” I’ve also managed to leave none of configs etc or any disturbing code. http://ix.io/2zKI
But it did still not show the normal login splash screen.
So, I researched further till I solved the problem of not having GUI login with enabling the acpid.service.

But then after I checked some settings and restarted it went black again, though the enabled and activated acpid.service was running and all other stuff seemed to be not the cause as well.

I had left the Manjaro stay behind the dual boot and I further used the Windows 10 today.
THen while am writing here I started into Linux Manjaro and the Login screen at least appeared and the grub while updated it stays till now.
But it left me really clueless, so I want to try to brin a little light into the tunnel. After having checked the systemd, the loginctl systemctl, journalctl and so forth, haven’t yet seen enough.
My specs I have added to my sig.
Here some movements, trying to post it chronologically:
Start xserver
then Ive uninstalled 440xx, checked for the installed rests and checked the available packages for Nvidia
Installed and the startup screen came back.
Lol, I was totallz confused and somehow after a restart nothing worked unless the shell console started with F2 pkus Ctrl and looked up status of acpid.service again
Anyway. If its not working again any day, I will write about it more thoroughly

Which Desktop Environment are you running? If you are running KDE have you tried the solution provided above?

1 Like

@philm Is there a plan when this fix will be in an update? I mean I’m not sure if I’d be affected by it as I use XFCE, but it’s glib after all and I use linked directories to a server…

1 Like

3 posts were split to a new topic: 2.66 regression: Unable to copy files on a ZFS volume configured with noatime

A post was split to a new topic: Pavumeter doesn’t start

no, try this:
sudo killall -9 plasmashell

A post was merged into an existing topic: Issues with pinging websites by DNS name

No issues here, thank you!

what symptom was it? can’t count how many blackscreen type of issues now appear, but i try softer methods first:

plasmeshell --replace
kwin_x11 --replace

and the brand new
loginctl unlock-sessions which is able to recover all apps. I don’t kill apps anymore and i have tons of nvidia issues.

recently noticed this issue of frozen desktop with mouse moving. It’s as easy to replicate as pressing Win+L. I found this in KDE Neon, Kubuntu Groovy, and now Manjaro. All of them have same recent plasma+framework. Also windows get not only emptied as before, but transparent.
The good news is yesterday update of Groovy Beta brought the fix! (and no, eventcalendar didn’t make difference).

Went just fine on KDE (intel/nvidia desktop) and XFCE (dell laptop)

Hi all,
What do I do with this?

mhwd --install pci Your450Family

where `Your450Family` is obviously one of `video-hybrid-amd-nvidia-440xx-prime` **OR** `video-nvidia-440xx` that you noted above

just how do I know what “family” I have?
By the way, none of the utils are on my system…is that normal?

[melissa@Avalon ~]$ pacman -Q nvidia-450xx-utils
error: package 'nvidia-450xx-utils' was not found
[melissa@Avalon ~]$ pacman -Q nvidia-440xx-utils
error: package 'nvidia-440xx-utils' was not found


Great, have a shovel handy? I may need to dig her up. :frowning_face:
I asked how to do it the Linux way…without having to consult a medium…but thanks anyway…


mhwd -l will give you available configs for your system.

1 Like

Thank ou so much :smile_cat:
:rose: Melissa :rose:

1 Like

Does me sorry, I knew that not…
I do not want to dig my parents up, too

(Corectrl is a handy tool btw…)

1 Like

Thanks :slight_smile:
There was no way you had to know. Was just a…“weird” answer :wink:

Metoo (I am a old white male german leftist)

Has mbb solved your question?? corectrl is similar to cpu-x - but give more details of your system,
its a graphical tool, most puritans like inxi on the command-line…

Same here, xfce, autologin stopped working since the last update. Did you manage to fix it?

I followed all the steps here from the archlinux wiki (I am not allowed to post links) but to no avail.
I even did a fresh install in a Virtual Machine and compared /etc/lightdm/lightdm.conf and /etc/pam.d/lightdm between the VM installation and my installation and they were exactly the same.

Any tipps here?