[Stable Update] 2020-09-11 - Kernels, Gnome 3.36.6, MHWD, Pamac, VirtualBox

see this

4 Likes

Adding intel_pstate=active to the kernel command line worked. Thanks for a simple fix!
Also worth noting that you can get this change to be permanent by editing the /etc/default/grub file and adding intel_pstate=active to the GRUB_CMDLINE_LINUX_DEFAULT variable.

2 Likes

can you report

inxi -MCza
1 Like

Machine: Type: Laptop System: Dell product: Precision 7710 v: N/A serial: Chassis: type: 9 serial:
Mobo: Dell model: 08P7T1 v: A00 serial: UEFI [Legacy]: Dell v: 01.06.06 date: 07/27/2016
CPU: Topology: Quad Core model: Intel Core i7-6820HQ bits: 64 type: MT MCP arch: Skylake-S family: 6 model-id: 5E (94)
stepping: 3 microcode: D6 L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 43214
Speed: 800 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable

Failed to start VirtualBox Guest VMSVGA resize client message on boot of Manjaro Linux Gnome guest on Vbox v6.114 on MacOS Catalina10.15.6 host.

Screen spams "Failed to start VirtualBox Guest VMSVGA resize client”, eventually GUI comes up, but on login hands and freezes on login screen. System was stable before this upgrade, looks like a newer kernel might have been swapped in. Previously working on 5.4 No GRUB menu on boot to choose a different kernel.

Can’t get a terminal window to open. Other than reinstall, any suggestions?

Hello! I thought it was my imagination that my Ivy Bridge laptop was running slower since I upgraded to kernel 5.8, but I followed your advice and added intel_pstate=active parameter to my grub configuration and my speed seems to be back to normal! I can’t believe I missed an Announcement about this issue?!?

Could you possibly (or someone else above my pay grade :wink:) add something about this issue in the “Known issues and solutions” section? I don’t think I could explain the matter properly myself.

1 Like

Regarding the known issue solution on nvidia, at that step:

I got an error where mhwd couldn’t find nvidia-video-450xx because it did not exist. Indeed the system was not updated!
I fixed it by updating everything with pacman -Syyu after removing everything 440-related and before trying to install 450. The update went well.
But then, I had a config file conflict, so could not install 450 with mhwd. Mhwd still listed 440 as being installed, so I removed 440 with mhwd --remove pci nvidia-video440xx and then I could finally install the new 450 drivers.

Probably happened because I didn’t update manjaro for a while.
I suggest someone add this precision in the solution if it makes sense!
Thanks for everything, and RIP to the old forum xD

can you provide

inxi -MCza
1 Like

this is how:

https://wiki.archlinux.org/index.php/Reset_lost_root_password

If that would not help, please open a separate issue here

1 Like

Hi Manjaro Team,

I installed Manjaro 20.1 Mikah Kde version on a desktop PC. I have a bug with pamac. I can’t install local packages with the pamac menu. The local packages are on an usb key. Each time, pamac vanished. For now, the only way that I found to install local packages through the usb key is to make a right clic on the local package and choose software manager.

Can you have a look ?

Thanks.

Thanks for your help!

inxi -MCza

Machine:
Type: Laptop System: Dell product: Latitude E5430 non-vPro v: 01 serial: Chassis: type: 9 serial:
Mobo: Dell model: N/A serial: UEFI: Dell v: A21 date: 11/30/2018
CPU:
Topology: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58)
stepping: 9 microcode: 21 L2 cache: 3072 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20740
Speed: 1196 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1196 2: 1196 3: 1196 4: 1196
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected

Will intel_pstate=active be an appropriate kernel parameter in grub when using kernel 5.9 and later? I read online that passive mode was made the default for reasons that I don’t completely understand with my limited Linux knowledge…

for kernel5.9 , cpu frequency will change again , no more intel_pstate.

1 Like

Good feedback. I presume the Enter annoyance is caused by Space being the default action on the web etc.

After this upgrade sound and microphone levels are reset after each reboot.

Operating System: Manjaro Linux
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.73.0
Qt Version: 5.15.0
Kernel Version: 5.8.6-1-MANJARO
OS Type: 64-bit

I looked into this matter further and found this Reddit on the subject of modern kernel Power Management:

Linux kernel 5.8 defaults to passive mode for intel_pstate driver for cpu before Skylake

so I removed intel_pstate=active as a kernel parameter in grub (remember to sudo update-grub, and Restart) and instead opened TLPUI and changed the CPU Scaling Governor from “powersave” to “schedutil”, again Restart.

More observation is needed but I think this fixed my issue!

inxi -MCza:

Machine:
Type: Laptop System: Dell product: Latitude E5430 non-vPro v: 01 serial: Chassis: type: 9 serial:
Mobo: Dell model: N/A serial: UEFI: Dell v: A21 date: 11/30/2018
CPU:
Topology: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58)
stepping: 9 microcode: 21 L2 cache: 3072 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20740
Speed: 2392 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1756 2: 1254 3: 1378 4: 1556
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected

sudo cpupower frequency-info:

analyzing CPU 0:
driver: intel_cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 20.0 us
hardware limits: 1.20 GHz - 3.20 GHz
available cpufreq governors: performance schedutil
current policy: frequency should be within 1.20 GHz and 3.20 GHz.
The governor “schedutil” may decide which speed to use
within this range.
current CPU frequency: Unable to call hardware
current CPU frequency: 1.33 GHz (asserted by call to kernel)
boost state support:
Supported: yes
Active: yes
3000 MHz max turbo 4 active cores
3000 MHz max turbo 3 active cores
3000 MHz max turbo 2 active cores
3200 MHz max turbo 1 active cores

I also have thermald installed.

I welcome the feedback of more experienced Linux users of the Manjaro community to confirm that this is the correct logic for kernel 5.8, the upcoming 5.9 and next.

2 Likes

Update went ok. :slightly_smiling_face:

There is this warning:

warning: directory permissions differ on /var/lib/AccountsService/icons/ filesystem: 755 package: 775

Is it safe to run:
sudo chmod 775 /var/lib/AcconutsService/icons/ ?

1 Like

If you have to ask, it means you’re not running backups… Please read this:

Then take a system backup, then run that command.

Yes, it’s safe. take backups anyway!

:innocent:

2 Likes

Oh, I just do a backup before the update (as always I do), but I will follow your advice.
Thanks @Fabby!
:yum:

1 Like

I can’t comment on if this is “right” but I am trying it. I will note right off that my system is ramping up and down more aggressively and to higher levels with theramld and schedutil. The net seems to actually be better performance, but I’ll have to give it more time to make sure it’s not just a placebo effect.

1 Like

Great update. Super stable. No issues here. Nice job guys.