[Stable Update] 2020-08-16 - Kernels, Plasma, KDE Framework, Systemd, Pamac, VirtualBox, Firefox

Yes, the new 450 driver works.
One way to install it for now is to use dkms and this repo: GitHub - Frogging-Family/nvidia-all: Nvidia driver 450 to 396 series AIO installer

Don’t forget to remove the 440 driver with mhwd first

1 Like

Yeah, some of the emoticons turned monochrome. I’m certain they were working before the update.

Fixed it following the instructions provided here:

All went well with my update (below). Great updated packages.


With the ongoing discussion on grub, how do i know whether my system is susceptible? Does this apply to all grub users? What are the potential consequences of not doing the upgrade? I have a luks encrypted system and would not want to reinstall given all the time it takes to tweak the configuration.

██████████████████ ████████ --------------
██████████████████ ████████ OS: Manjaro Linux x86_64
██████████████████ ████████ Host: HP Z440 Workstation
████████ ████████ Kernel: 5.7.14-1-MANJARO
████████ ████████ ████████ Uptime: 4 hours, 32 mins
████████ ████████ ████████ Packages: 1574 (pacman)
████████ ████████ ████████ Shell: bash 5.0.18
████████ ████████ ████████ Resolution: 1920x1080, 1920x1080
████████ ████████ ████████ DE: Plasma
████████ ████████ ████████ WM: KWin
████████ ████████ ████████ WM Theme: Aritim-Dark
████████ ████████ ████████ Theme: Aritim-Dark [Plasma], Breeze [GTK2/3]
████████ ████████ ████████ Icons: oxygen [Plasma], oxygen [GTK2/3]
Terminal: konsole
Terminal Font: Lucida Console 10
CPU: Intel Xeon E5-1620 v3 (8) @ 3.600GHz
GPU: NVIDIA Quadro K2200
Memory: 5491MiB / 32035MiB

NOTE: Please make sure that if/when you attempt re-installing grub, that you have a bootable flash drive in case you end up with an unbootable system.

The grub re-install was not scripted probably because not everyone has grub setup the same way. There isn’t really a universal command for reinstalling grub exactly the way everyone has it. In this case it is better to let the end user take care of it per their configuration, than risk borking a lot of installs.

For example, I did the grub update initially with

sudo grub-install /dev/sdY

(specific to Legacy/BIOS systems; replace Y with actual device)

Only to have an unbootable system afterward. Turns out I had used GPT with Legacy/BIOS, and while my system had been working fine for years, apparently it wasn’t a supported configuration (it did not have a separate 8mb partition with the “bios_grub” flag).

To get my setup bootable again, I used gparted to:

  1. shrink my boot partition by 8mb (this can be any partition within the first 2TB of space on the drive)
  2. format the new 8mb space as “unformatted”
  3. mark the 8mb partition with “bios_grub” flag
  4. chroot into my system and run the grub-install command again.

@jim1112 i was in the same boat. Refer to the steps outlined in this post. If you still need help, create a support thread and link it here.


Only one issue related to backlight on kernel 5.8:

$ ls -la /sys/class/backlight/
total 0
drwxr-xr-x  2 root root 0 Aug 16 18:20 .
drwxr-xr-x 70 root root 0 Aug 16 18:20 ..
lrwxrwxrwx  1 root root 0 Aug 16 18:20 amdgpu_bl0 -> ../../devices/pci0000:00/0000:00:08.1/0000:04:00.0/backlight/amdgpu_bl0
$ systemctl status systemd-backlight@backlight\:amdgpu_bl0.service
● systemd-backlight@backlight:amdgpu_bl0.service - Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0
     Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static; vendor preset: disabled)
     Active: failed (Result: exit-code) since Sun 2020-08-16 18:20:20 BST; 13min ago
       Docs: man:systemd-backlight@.service(8)
    Process: 824 ExecStart=/usr/lib/systemd/systemd-backlight load backlight:amdgpu_bl0 (code=exited, status=1/FAILURE)
   Main PID: 824 (code=exited, status=1/FAILURE)

Aug 16 18:20:20 my-pc systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0...
Aug 16 18:20:20 my-pc systemd-backlight[824]: amdgpu_bl0: Saved brightness 64000 too high; decreasing to 255.
Aug 16 18:20:20 my-pc systemd-backlight[824]: amdgpu_bl0: Failed to write system 'brightness' attribute: No such device or address
Aug 16 18:20:20 my-pc systemd[1]: systemd-backlight@backlight:amdgpu_bl0.service: Main process exited, code=exited, status=1/FAILURE
Aug 16 18:20:20 my-pc systemd[1]: systemd-backlight@backlight:amdgpu_bl0.service: Failed with result 'exit-code'.
Aug 16 18:20:20 my-pc systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0.
$ journalctl -b _PID=824
-- Logs begin at Tue 2019-11-12 20:32:42 GMT, end at Sun 2020-08-16 18:35:44 BST. --
Aug 16 18:20:20 my-pc systemd-backlight[824]: amdgpu_bl0: Saved brightness 64000 too high; decreasing to 255.
Aug 16 18:20:20 my-pc systemd-backlight[824]: amdgpu_bl0: Failed to write system 'brightness' attribute: No such device or address

As a consequence this message appears during startup…

Failed to start Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0.

… and backlight is set to maximum on login.

System:    Kernel: 5.8.0-2-MANJARO x86_64 bits: 64 compiler: N/A Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel
           wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:   Type: Laptop System: HP product: HP EliteBook 755 G5 v: N/A serial: <filter> Chassis: type: 10 serial: <filter>
           Mobo: HP model: 83D5 v: KBC Version 08.58.00 serial: <filter> UEFI: HP v: Q81 Ver. 01.10.03 date: 03/24/2020
Battery:   ID-1: BAT0 charge: 50.4 Wh condition: 50.6/50.6 Wh (100%) volts: 12.8/11.6 model: Hewlett-Packard Primary
           type: Li-ion serial: <filter> status: Unknown
CPU:       Topology: Quad Core model: AMD Ryzen 7 PRO 2700U w/ Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen
           L2 cache: 2048 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 35147
           Speed: 1223 MHz min/max: 1600/2200 MHz boost: enabled Core speeds (MHz): 1: 1223 2: 1277 3: 1224 4: 1224 5: 1269
           6: 1391 7: 1221 8: 1220
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] vendor: Hewlett-Packard driver: amdgpu
           v: kernel bus ID: 04:00.0 chip ID: 1002:15dd
           Device-2: Chicony HP HD Camera type: USB driver: uvcvideo bus ID: 4-2:3 chip ID: 04f2:b5ee
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
           resolution: 1920x1080~60Hz s-dpi: 96
           OpenGL: renderer: AMD RAVEN (DRM 3.38.0 5.8.0-2-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.5 direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard
           driver: snd_hda_intel v: kernel bus ID: 04:00.1 chip ID: 1002:15de
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
           bus ID: 04:00.6 chip ID: 1022:15e3
           Sound Server: ALSA v: k5.8.0-2-MANJARO
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8168
           v: 8.048.03-NAPI port: 3300 bus ID: 01:00.0 chip ID: 10ec:8168
           IF: enp1s0f0 state: down mac: <filter>
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: 3000 bus ID: 02:00.0 chip ID: 8086:24fd
           IF: wlp2s0 state: up mac: <filter>
           IF-ID-1: docker0 state: down mac: <filter>
Drives:    Local Storage: total: 238.47 GiB used: 357.29 GiB (149.8%)
           ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB speed: 15.8 Gb/s lanes: 2 serial: <filter>
           rev: ADHA0101 scheme: GPT
Partition: ID-1: / size: 233.43 GiB used: 178.63 GiB (76.5%) fs: ext4 dev: /dev/nvme0n1p2
Swap:      Alert: No Swap data was found.
Sensors:   System Temperatures: cpu: 62.9 C mobo: 46.0 C gpu: amdgpu temp: 62 C
           Fan Speeds (RPM): N/A
Info:      Processes: 270 Uptime: 24m Memory: 30.38 GiB used: 1.94 GiB (6.4%) Init: systemd v: 245 Compilers: gcc: 10.1.0
           clang: 10.0.1 Packages: pacman: 1436 Shell: Bash v: 5.0.18 running in: server inxi: 3.1.05

Updated without issues, KDE, Kernel 5.4.57, AMD/Nvidia.

Thanks Manjaro Team

Hi @jaroMAN. Neither do I :wink: Just run convert.lua conkyfile . Normally all will be fine after this . There could be some minor issues.
Conky-manager doesn’t work anymore. If I’m not mistaken, there is also a conky-manager2 (git) in the AUR [but it won’t compile. (Something with missing dependencies, but I didn’t have the time to look at it.]

Seems there was a problem introduced with the palette of musescore in this update. See: MuseScore Palette is broken from Manjaro Repo

Now i’m confused regarding this grub update note.
Do i have to do something before updating the system? If so, what and how exactly?
Or can i do the system update and then do the grub update?
Does the system reboot after update if i didn’t update grub before?


1 Like

no issues till now, even the nvidia update went smooth.

Me dumb, I was clicking on an optional stuff for conky-lua-nv. Now it installs, but it installs nothing… The conky executable doesn’t exist. It only install this :


Cinnamon 5.4, update went smooth, all is good. Thanks Manjaro team!

Some quick findings:

  • Conky no longer supports old config format so I had to convert all my scripts to lua. Conky manager2 from aur is also needed to support these scripts.

  • Opencl in darktable doesn’t work on my intel iris. I suspect intel-compute-runtime has something to do with this.

  • arc theme no longer displays menu icon on the left in the titlebar

From the old forum:

I hope it helps you.


Xfce, Kernel 4.14.
Everything is fine, no problems with Conky nor with fonts.

Yes, thanks, that worked nicely. To quote Aragorn from Updating grub to grub-2.04-11.1

No, it can easily be done from a terminal. :wink: :arrow_down:

sudo pacman -Syyu
sudo grub-install --recheck --no-rs-codes 

i did this and it works fine.

Thanks Lunix, but didn’t help me all files including ones with .conf all report same error:

./convert.lua: line 6: syntax error near unexpected token `newline’

./convert.lua: line 6: ‘<! DOCTYPE html>’

Adding html tags dosn’t help LoL.

Looking at “conky-startup.sh” and no widgets enabled now.

ALSO running conky conky_file has a NEW error:

conky: error while loading shared libraries: liblua.so.5.3: cannot open shared object file: No such file or directory

So looking around, liblua.so.5.3 is only found in the timeshift snapshots.
And in /usr/lib it’s 5.1 !!!

Clearly not enough/any Manjaro testers use conky.

TOMORROW I’m going to timeshift back to pre-Sunday’s update and will start incremental updates (kernel, microcode, etc) until I find what’s messing up lua.

Ok, you can open a new topic with this problem. I think there will be others with the same issue.
Or you can reply in the topic from @Ben

Good luck !


1 Like

there is a much simpler solution to the conky problem: [Testing Update] 2020-08-14 - Kernels, KDE-git, Deepin, KODI, Firefox, QEmu, Python, Haskell